---
- Fix buffering for funny sample formats (namely, 24 bit), that do not
  fit nicely into 32768 bytes. Effect was a nasty endless loop where
  mpg123 needs to be externally killed.

1.22.1
---
- Fix mpg123-id3dump when writing images with funny (manipulated) MIME type.
  Stupid mistake in length computation of the fallback file extension caused
  junk from memory being appended to the filename if the pointer size
  is less than 64 bit. For 64 bit pointers (or longer) it was correct by
  accident.
- Fix pedantic build by cleaning up out123 source, also now really showing
  the encoding list in --longhelp instead of possibly, again, writing junk
  from memory in there.
- Not linking libmpg123 against libltdl anymore (bug 215).
- Update MSVC++ ports a bit to make them work again.
This commit is contained in:
adam 2015-07-24 10:33:27 +00:00
parent f01e95c34c
commit 1e4ee78122
3 changed files with 20 additions and 7 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.65 2014/10/09 14:06:03 wiz Exp $
# $NetBSD: Makefile,v 1.66 2015/07/24 10:33:27 adam Exp $
DISTNAME= minicom-2.6.2
DISTNAME= minicom-2.7
CATEGORIES= comms
MASTER_SITES= http://alioth.debian.org/frs/download.php/3869/
MASTER_SITES= http://alioth.debian.org/frs/download.php/file/3977/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://alioth.debian.org/projects/minicom/

View file

@ -1,11 +1,12 @@
$NetBSD: distinfo,v 1.14 2013/10/09 10:53:24 adam Exp $
$NetBSD: distinfo,v 1.15 2015/07/24 10:33:27 adam Exp $
SHA1 (minicom-2.6.2.tar.gz) = e4267f89e4046c4e3d28cad5aa643edb1de4169a
RMD160 (minicom-2.6.2.tar.gz) = c6c2936bc0e4ae662bdf09ead6e76b68d7278e56
Size (minicom-2.6.2.tar.gz) = 855340 bytes
SHA1 (minicom-2.7.tar.gz) = 939eef8ca1bda82ee801b087d9db4f16a19fbe6e
RMD160 (minicom-2.7.tar.gz) = a7947e2e45cc6655b55b70cb65f8784a606248ce
Size (minicom-2.7.tar.gz) = 863544 bytes
SHA1 (patch-ab) = e87dbe616958b2b1a01a9a7dfa8cb8f8c1a6978f
SHA1 (patch-ac) = b2ffa106989ea562b8ea85bfd15e516713a37f3f
SHA1 (patch-ad) = a3e50ae6dcacb6ae6a177e5b6e4d3d959d960eca
SHA1 (patch-ae) = ea2fb58212de7caaaed4c0817290ca3612212b6c
SHA1 (patch-ag) = 5f635b67e2e48d13c9df7f3ed4fdca83a1c7f7ef
SHA1 (patch-ah) = ae6048f6a8e81134a459aaf21527e944c68ae07f
SHA1 (patch-src_script.c) = 239d4e1b17429dfa28c6445a0ab3468f6d6804b8

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_script.c,v 1.1 2015/07/24 10:33:27 adam Exp $
--- src/script.c.orig 2015-07-24 10:31:38.000000000 +0000
+++ src/script.c
@@ -32,6 +32,7 @@
#include <config.h>
#endif
+#include <sys/wait.h>
#include <stdarg.h>
#include "port.h"