Re: PR 25720 Syntax errors prevent compilation with gcc 3.4.0
The patch-al fixes a problem where a label appeared at end of block by supplying a null statement for the label. The patch-am provides a missing argument list separator (comma) in four places. This closes the PR.
This commit is contained in:
parent
ae68b0fb15
commit
1eb78e7a02
3 changed files with 53 additions and 14 deletions
|
@ -1,17 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.9 2003/09/30 21:50:55 seb Exp $
|
||||
$NetBSD: distinfo,v 1.10 2004/06/01 08:55:34 shannonjr Exp $
|
||||
|
||||
SHA1 (dictd-1.8.0.tar.gz) = c8318ae83a540d336405db126ff04bfc60b60ffc
|
||||
Size (dictd-1.8.0.tar.gz) = 574796 bytes
|
||||
SHA1 (dict-gazetteer-1.3.tar.gz) = d46d3e0aeb956bb2b49e1ec1cda271017eed94c4
|
||||
Size (dict-gazetteer-1.3.tar.gz) = 2857457 bytes
|
||||
SHA1 (dict-misc-1.5.tar.gz) = faa183a736da3809719bb513c2df4c6b9814e51f
|
||||
Size (dict-misc-1.5.tar.gz) = 4204499 bytes
|
||||
SHA1 (dict-web1913-1.4.tar.gz) = 727751063813fbdc67f8f2a42933d8c9bf35689b
|
||||
Size (dict-web1913-1.4.tar.gz) = 293649 bytes
|
||||
SHA1 (web1913-0.46-a.tar.gz) = 56d6b00b79ab31c4104862b44be8c9287babecb1
|
||||
Size (web1913-0.46-a.tar.gz) = 13795530 bytes
|
||||
SHA1 (dict-wn-1.5.tar.gz) = 56cfd7200e4149504376b280e36aa37abcbe054e
|
||||
Size (dict-wn-1.5.tar.gz) = 6363650 bytes
|
||||
SHA1 (patch-ab) = ad9343e6fad32d9c8f6ccc221ff1fe035ace4551
|
||||
SHA1 (patch-ac) = 4239819d518ccbe4b279376f7a8b2f52028b18b9
|
||||
SHA1 (patch-ad) = 75d08ce1778898edcd52b4b94c974aba54f769a7
|
||||
|
@ -21,4 +11,5 @@ SHA1 (patch-ah) = d3453553e15858054bce4943a0316d485938806a
|
|||
SHA1 (patch-ai) = 21b2c9ace814e005139c64c4b6890e8b7e249f29
|
||||
SHA1 (patch-aj) = 76527be1d4ff89aeec72606d9575a99e6a8e2d3b
|
||||
SHA1 (patch-ak) = 4167c9007ed7b31ff9a29b368d82154bc95893cf
|
||||
SHA1 (patch-al) = d2dbe247c7b3a8c574e1ff4f4e127abe1722ca47
|
||||
SHA1 (patch-al) = 4a959c6a363941a38256f5eb984a79eec98ab44f
|
||||
SHA1 (patch-am) = 5221f23eb9299202d77da2bcb041b438ee6a468e
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-al,v 1.3 2003/09/30 21:50:55 seb Exp $
|
||||
$NetBSD: patch-al,v 1.4 2004/06/01 08:55:34 shannonjr Exp $
|
||||
|
||||
--- dictfmt.c.orig 2002-08-23 17:33:10.000000000 +0000
|
||||
--- dictfmt.c.orig 2002-08-23 11:33:10.000000000 -0600
|
||||
+++ dictfmt.c
|
||||
@@ -369,7 +369,7 @@ static void help( FILE *out_stream )
|
||||
several words to have the same definition\n\
|
||||
|
@ -11,3 +11,11 @@ $NetBSD: patch-al,v 1.3 2003/09/30 21:50:55 seb Exp $
|
|||
head words will not be copied to .dict file",
|
||||
0 };
|
||||
const char **p = help_msg;
|
||||
@@ -685,6 +685,7 @@ int main( int argc, char **argv )
|
||||
fmt_newline();
|
||||
}
|
||||
skip:
|
||||
+ ;
|
||||
}
|
||||
|
||||
fmt_newheadword(NULL,0);
|
||||
|
|
40
textproc/dict-server/patches/patch-am
Normal file
40
textproc/dict-server/patches/patch-am
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-am,v 1.3 2004/06/01 08:55:34 shannonjr Exp $
|
||||
|
||||
--- libmaa/parse.c.orig 2002-08-02 13:43:15.000000000 -0600
|
||||
+++ libmaa/parse.c
|
||||
@@ -75,7 +75,7 @@ void prs_file( const char *filename )
|
||||
|
||||
if (!cpp) {
|
||||
if ((cpp = getenv( "KHEPERA_CPP" ))) {
|
||||
- PRINTF(MAA_PARSE,(__FUNCTION__ ": Using KHEPERA_CPP from %s\n",cpp));
|
||||
+ PRINTF(MAA_PARSE,(__FUNCTION__, ": Using KHEPERA_CPP from %s\n",cpp));
|
||||
}
|
||||
|
||||
/* Always look for gcc's cpp first, since
|
||||
@@ -86,7 +86,7 @@ void prs_file( const char *filename )
|
||||
|
||||
if (fread( buf, 1, 1023, tmp ) > 0) {
|
||||
if ((t = strchr( buf, '\n' ))) *t = '\0';
|
||||
- PRINTF(MAA_PARSE,(__FUNCTION__ ": Using GNU cpp from %s\n",buf));
|
||||
+ PRINTF(MAA_PARSE,(__FUNCTION__, ": Using GNU cpp from %s\n",buf));
|
||||
cpp = str_find( buf );
|
||||
extra_options = "-nostdinc -nostdinc++";
|
||||
}
|
||||
@@ -103,7 +103,7 @@ void prs_file( const char *filename )
|
||||
for (pt = cpps; **pt; pt++) {
|
||||
if (!access( *pt, X_OK )) {
|
||||
PRINTF(MAA_PARSE,
|
||||
- (__FUNCTION__ ": Using system cpp from %s\n",*pt));
|
||||
+ (__FUNCTION__, ": Using system cpp from %s\n",*pt));
|
||||
cpp = *pt;
|
||||
break;
|
||||
}
|
||||
@@ -123,7 +123,7 @@ void prs_file( const char *filename )
|
||||
sprintf( buffer, "%s -I. %s %s 2>/dev/null", cpp,
|
||||
_prs_cpp_options ? _prs_cpp_options : "", filename );
|
||||
|
||||
- PRINTF(MAA_PARSE,(__FUNCTION__ ": %s\n",buffer));
|
||||
+ PRINTF(MAA_PARSE,(__FUNCTION__ ,": %s\n",buffer));
|
||||
if (!(yyin = popen( buffer, "r" )))
|
||||
err_fatal_errno( __FUNCTION__,
|
||||
"Cannot open \"%s\" for read\n", filename );
|
Loading…
Reference in a new issue