Fixed building with PostgreSQL>=9, works with any 8.x and 9.x version now.

Bumpe PKGREVISION.
This commit is contained in:
fhajny 2012-03-14 16:41:09 +00:00
parent 98bce36f6f
commit 1ec2f49494
3 changed files with 30 additions and 3 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.8 2012/01/08 18:39:49 gdt Exp $
# $NetBSD: Makefile,v 1.9 2012/03/14 16:41:09 fhajny Exp $
DISTNAME= postgis-1.5.3
PKGNAME= postgresql${PGSQL_VERSION}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= http://postgis.refractions.net/download/
@ -13,7 +14,7 @@ LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
PGSQL_VERSIONS_ACCEPTED= 84 83
PGSQL_VERSIONS_ACCEPTED= 91 90 84 83
DEPENDS+= postgresql${PGSQL_VERSION}-server>=0:../../databases/postgresql${PGSQL_VERSION}-server
@ -43,6 +44,9 @@ SUBST_STAGE.paths= pre-configure
INSTALLATION_DIRS= ${DOCDIR} ${DOCDIR}/images ${PKGMANDIR}/man1
MAKE_ENV+= PERL5=${PERL5:Q}
INSTALL_ENV+= mkinstalldirs=${INSTALL_DATA_DIR:Q}
post-install:
${INSTALL_DATA} ${BUILD_DIRS:Q}/README.postgis ${DESTDIR}${DOCDIR}
${INSTALL_DATA} ${BUILD_DIRS:Q}/doc/html/postgis.html ${DESTDIR}${DOCDIR}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2012/01/10 14:00:46 gdt Exp $
$NetBSD: distinfo,v 1.8 2012/03/14 16:41:10 fhajny Exp $
SHA1 (postgis-1.5.3.tar.gz) = e8c572e0258ba760a67b7f717bdc8321b9f6cd58
RMD160 (postgis-1.5.3.tar.gz) = e30275890b175cbe1d70d5899cbe45ec34ddbafb
@ -7,3 +7,4 @@ SHA1 (patch-configure) = 5995e773b9f8ec20e710d6cb690e928856c2650e
SHA1 (patch-configure.ac) = 993358912b61670733602511d507e497c9677875
SHA1 (patch-doc_Makefile.in) = 98807010256cf42e4d179305febe2525efbb6cd1
SHA1 (patch-doc_html_image__src_Makefile.in) = 89e19e03dbb936d723d1e6748cd2bd77232bcf6d
SHA1 (patch-postgis_Makefile.in) = db0e73dac0d4c88cd44fe33253c8b766c576b664

View file

@ -0,0 +1,22 @@
$NetBSD: patch-postgis_Makefile.in,v 1.1 2012/03/14 16:41:10 fhajny Exp $
Specify perl binary directly, rather than rely on PostgreSQL.
--- postgis/Makefile.in.orig 2010-01-08 22:48:29.000000000 +0000
+++ postgis/Makefile.in
@@ -106,13 +106,13 @@ endif
sed 's,MODULE_PATHNAME,$$libdir/postgis-@POSTGIS_MAJOR_VERSION@.@POSTGIS_MINOR_VERSION@,g' $< >$@
postgis_upgrade_15_minor.sql: postgis.sql
- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.5 > $@
+ $(PERL5) ../utils/postgis_proc_upgrade.pl $< 1.5 > $@
postgis_upgrade_14_to_15.sql: postgis.sql
- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.4 > $@
+ $(PERL5) ../utils/postgis_proc_upgrade.pl $< 1.4 > $@
postgis_upgrade_13_to_15.sql: postgis.sql
- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.3 > $@
+ $(PERL5) ../utils/postgis_proc_upgrade.pl $< 1.3 > $@
# Generate any .sql.in files from .sql.in.c files by running them through the C pre-processor
$(SQL_OBJS): %.in: %.in.c