vlc: Update to 3.0.10
Changes between 3.0.9.2 and 3.0.10: ---------------------------------- Misc: * Update Twitch & VLSub scripts Changes between 3.0.9.1 and 3.0.9.2: ---------------------------------- Misc: * Properly bump the version in configure.ac Changes between 3.0.9 and 3.0.9.1: ---------------------------------- Misc: * Fix VLSub returning 401 for earch request Changes between 3.0.8 and 3.0.9: ---------------------------------- Core: * Work around busy looping when playing an invalid item through VLM Access: * Multiple dvdread and dvdnav crashs fixes * Fixed DVD glitches on clip change * Fixed dvdread commands/data sequence inversion in some cases causing unwanted glitches * Better handling of authored as corrupted DVD * Added libsmb2 support for SMB2/3 shares Demux: * Fix TTML entities not passed to decoder * Fixed some WebVTT styling tags being not applied * Misc raw H264/HEVC frame rate fixes * Fix adaptive regression on TS format change (mostly HLS) * Fixed MP4 regression with twos/sowt PCM audio * Fixed some MP4 raw quicktime and ms-PCM audio * Fixed MP4 interlacing handling * Multiple adaptive stack (DASH/HLS/Smooth) fixes * Enabled Live seeking for HLS * Fixed seeking in some cases for HLS * Improved Live playback for Smooth and DASH * Fixed adaptive unwanted end of stream in some cases * Faster adaptive start and new buffering control options Packetizers: * Fixes H264/HEVC incomplete draining in some cases * packetizer_helper: Fix potential trailing junk on last packet * Added missing drain in packetizers that was causing missing last frame or audio * Improved check to prevent fLAC synchronization drops Decoder: * avcodec: revector video decoder to fix incomplete drain * spudec: implemented palette updates, fixing missing subtitles on some DVD * Fixed WebVTT CSS styling not being applied on Windows/macOS * Fixed Hebrew teletext pages support in zvbi * Fixed Dav1d aborting decoding on corrupted picture * Extract and display of all CEA708 subtitles * Update libfaad to 2.9.1 * Add DXVA support for VP9 Profile 2 (10 bits) * Mediacodec aspect ratio with Amazon devices Audio output: * Added support for iOS audiounit audio above 48KHz * Added support for amem audio up to 384KHz Video output: * Fix for opengl glitches in some drivers * Fix GMA950 opengl support on macOS * YUV to RGB StretchRect fixes with NVIDIA drivers * Use libpacebo new tone mapping desaturation algorithm Text renderer: * Fix crashes on macOS with SSA/ASS subtitles containing emoji * Fixed unwanted growing background in Freetype rendering and Y padding Mux: * Fixed some YUV mappings macOS: * Use a layer based video output on 10.14 and higher, which should fix various rendering issues where the vout would glitch between a wrong size and the correct size. Additionally this works around OpenGL issues with Macs that have a dedicated NVIDIA GPU, which caused rendering artifacts in the whole OS, especially when the "Reduce transparency" accessibility option is used * Remove qtsound module and add avaudiocapture module as replacement * Fix audio capture on macOS Catalina by using avaudiocapture * Inform the user in case OS permissions are missing for certain actions * Fix Apple Remote support on macOS Catalina * Add support for pausing Apple Music on macOS Catalina * Fix UPnP discovery crash without an active network interface * Fix rare placement issues with fullscreen panel * Fix problem in audio output remembering the last device configuration in digital mode Service Discovery: * Update libmicrodns to 0.1.2 Misc: * Update YouTube, SoundCloud and Vocaroo scripts: this restores playback of YouTube URLs. * Add missing .wpl & .zpl file associations on Windows * Improved chromecast audio quality
This commit is contained in:
parent
2c709664fd
commit
1edc8d5bb2
5 changed files with 123 additions and 98 deletions
|
@ -1,16 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.231 2020/04/12 08:29:03 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.232 2020/05/01 13:51:54 nia Exp $
|
||||
|
||||
DISTNAME= vlc-${VLC_VERSION}
|
||||
PKGREVISION= 7
|
||||
DISTNAME= vlc-3.0.10
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= https://download.videolan.org/pub/videolan/vlc/${VLC_VERSION}/
|
||||
MASTER_SITES= https://download.videolan.org/pub/videolan/vlc/${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
VLC_VERSION= 3.0.8
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://www.videolan.org/
|
||||
COMMENT= VLC media player and streaming server
|
||||
COMMENT= VideoLAN media player and streaming server
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
CONFLICTS= vlc07-[0-9]* vlc08-[0-9]*
|
||||
|
@ -25,7 +22,7 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS+= --with-kde-solid=${PREFIX}/share/kde/apps/solid/actions
|
||||
PTHREAD_OPTS+= require
|
||||
USE_LANGUAGES= c99 c++
|
||||
PLIST_VARS+= altivec cdrom oss v4l2 x86simd
|
||||
PLIST_VARS+= altivec cdrom egl oss v4l2 x86simd
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "options.mk"
|
||||
|
@ -33,13 +30,14 @@ PLIST_VARS+= altivec cdrom oss v4l2 x86simd
|
|||
BUILDLINK_API_DEPENDS.zlib+= zlib>=1.2.0
|
||||
BUILDLINK_API_DEPENDS.vcdimager+= vcdimager>=0.7.20nb1
|
||||
|
||||
LUA_VERSIONS_ACCEPTED= 51 52
|
||||
CONFIGURE_ENV= LUAC=${LUA_COMPILER}
|
||||
CONFIGURE_ENV= LUAC=${PREFIX}/bin/luac5.2
|
||||
|
||||
# Avoid codec duplication with ffmpeg, etc
|
||||
|
||||
CONFIGURE_ARGS+= --disable-aom
|
||||
CONFIGURE_ARGS+= --disable-archive
|
||||
CONFIGURE_ARGS+= --disable-aribsub
|
||||
CONFIGURE_ARGS+= --disable-aribb25
|
||||
CONFIGURE_ARGS+= --disable-bluray
|
||||
CONFIGURE_ARGS+= --disable-caca
|
||||
CONFIGURE_ARGS+= --disable-chromaprint
|
||||
CONFIGURE_ARGS+= --disable-chromecast
|
||||
|
@ -54,6 +52,7 @@ CONFIGURE_ARGS+= --disable-fluidlite
|
|||
CONFIGURE_ARGS+= --disable-goom
|
||||
CONFIGURE_ARGS+= --disable-gst-decode
|
||||
CONFIGURE_ARGS+= --disable-libplacebo
|
||||
CONFIGURE_ARGS+= --disable-libmpeg2
|
||||
CONFIGURE_ARGS+= --disable-live555
|
||||
CONFIGURE_ARGS+= --disable-mad
|
||||
CONFIGURE_ARGS+= --disable-mfx
|
||||
|
@ -64,7 +63,6 @@ CONFIGURE_ARGS+= --disable-nfs
|
|||
CONFIGURE_ARGS+= --disable-notify
|
||||
CONFIGURE_ARGS+= --disable-opencv
|
||||
CONFIGURE_ARGS+= --disable-projectm
|
||||
CONFIGURE_ARGS+= --disable-samplerate
|
||||
CONFIGURE_ARGS+= --disable-sdl-image
|
||||
CONFIGURE_ARGS+= --disable-secret
|
||||
CONFIGURE_ARGS+= --disable-sftp
|
||||
|
@ -72,13 +70,16 @@ CONFIGURE_ARGS+= --disable-shine
|
|||
CONFIGURE_ARGS+= --disable-sid
|
||||
CONFIGURE_ARGS+= --disable-smbclient
|
||||
CONFIGURE_ARGS+= --disable-sndio
|
||||
CONFIGURE_ARGS+= --disable-soxr
|
||||
CONFIGURE_ARGS+= --disable-spatialaudio
|
||||
CONFIGURE_ARGS+= --disable-speex
|
||||
CONFIGURE_ARGS+= --disable-srt
|
||||
CONFIGURE_ARGS+= --disable-svg
|
||||
CONFIGURE_ARGS+= --disable-svgdec
|
||||
CONFIGURE_ARGS+= --disable-tiger
|
||||
CONFIGURE_ARGS+= --disable-twolame
|
||||
CONFIGURE_ARGS+= --disable-udev
|
||||
CONFIGURE_ARGS+= --disable-vpx
|
||||
CONFIGURE_ARGS+= --disable-vnc
|
||||
CONFIGURE_ARGS+= --disable-vsxu
|
||||
CONFIGURE_ARGS+= --disable-x264
|
||||
|
@ -87,7 +88,7 @@ CONFIGURE_ARGS+= --disable-x265
|
|||
CONFIGURE_ARGS+= --disable-zvbi
|
||||
|
||||
# which platforms support OSSv4?
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
.if ${OPSYS} == "NetBSD" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "SunOS"
|
||||
PLIST.oss= yes
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
.else
|
||||
|
@ -119,6 +120,11 @@ PLIST.v4l2= yes
|
|||
CONFIGURE_ARGS+= --disable-v4l2
|
||||
.endif
|
||||
|
||||
.include "../../graphics/MesaLib/features.mk"
|
||||
.if ${MESALIB_SUPPORTS_EGL} == "yes"
|
||||
PLIST.egl= yes
|
||||
.endif
|
||||
|
||||
INSTALLATION_DIRS+= share/vlc/http/dialogs share/vlc/http/images \
|
||||
share/vlc/http/js share/vlc/http/old \
|
||||
share/vlc/http/old/admin share/vlc/http/old/vlm \
|
||||
|
@ -163,23 +169,22 @@ SUBST_MESSAGE.fnt= Fixing hardcoded font paths.
|
|||
CHECK_WRKREF_SKIP= lib/libvlccore.a \
|
||||
lib/libvlccore.so*
|
||||
|
||||
MAKE_FLAGS+= BUILDCC=${CC}
|
||||
MAKE_FLAGS+= BUILDCC=${CC:Q}
|
||||
|
||||
pre-configure:
|
||||
${RUN} cd ${WRKSRC} && ${SH} ./bootstrap
|
||||
|
||||
.include "../../audio/fluidsynth/buildlink3.mk"
|
||||
.include "../../audio/flac/buildlink3.mk"
|
||||
.include "../../audio/fluidsynth/buildlink3.mk"
|
||||
.include "../../audio/liba52/buildlink3.mk"
|
||||
.include "../../audio/libcddb/buildlink3.mk"
|
||||
.include "../../audio/libmodplug/buildlink3.mk"
|
||||
.include "../../audio/libopus/buildlink3.mk"
|
||||
.include "../../audio/libsamplerate/buildlink3.mk"
|
||||
.include "../../audio/libshout/buildlink3.mk"
|
||||
.include "../../audio/libsoxr/buildlink3.mk"
|
||||
.include "../../audio/libvorbis/buildlink3.mk"
|
||||
.include "../../audio/mpg123/buildlink3.mk"
|
||||
.include "../../audio/musepack/buildlink3.mk"
|
||||
.include "../../audio/speexdsp/buildlink3.mk"
|
||||
.include "../../audio/taglib/buildlink3.mk"
|
||||
.include "../../converters/fribidi/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
|
@ -187,20 +192,23 @@ pre-configure:
|
|||
.include "../../devel/libmtp/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../fonts/fontconfig/buildlink3.mk"
|
||||
.include "../../fonts/harfbuzz/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../lang/lua/buildlink3.mk"
|
||||
.include "../../lang/lua52/buildlink3.mk"
|
||||
.include "../../misc/libcdio/buildlink3.mk"
|
||||
.include "../../mk/jpeg.buildlink3.mk"
|
||||
.include "../../multimedia/ffmpeg4/buildlink3.mk"
|
||||
.include "../../multimedia/libass/buildlink3.mk"
|
||||
.include "../../multimedia/libbluray/buildlink3.mk"
|
||||
.include "../../multimedia/libdvdplay/buildlink3.mk"
|
||||
.include "../../multimedia/libdvbpsi0/buildlink3.mk"
|
||||
.include "../../multimedia/libdvdnav/buildlink3.mk"
|
||||
.include "../../multimedia/libdvdread/buildlink3.mk"
|
||||
.include "../../multimedia/libkate/buildlink3.mk"
|
||||
.include "../../multimedia/libmatroska/buildlink3.mk"
|
||||
.include "../../multimedia/libmpeg2/buildlink3.mk"
|
||||
.include "../../multimedia/libogg/buildlink3.mk"
|
||||
.include "../../multimedia/libtheora/buildlink3.mk"
|
||||
.include "../../multimedia/schroedinger/buildlink3.mk"
|
||||
|
@ -209,8 +217,5 @@ pre-configure:
|
|||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
# libX11 should be built with xcb enabled
|
||||
BUILDLINK_API_DEPENDS.libX11+= libX11>=1.3.5
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.64 2019/09/02 12:54:15 nia Exp $
|
||||
@comment $NetBSD: PLIST,v 1.65 2020/05/01 13:51:54 nia Exp $
|
||||
@pkgdir share/vlc/http/dialogs
|
||||
@pkgdir share/vlc/http/images
|
||||
@pkgdir share/vlc/http/js
|
||||
|
@ -122,8 +122,8 @@ lib/libvlccore.la
|
|||
lib/pkgconfig/libvlc.pc
|
||||
lib/pkgconfig/vlc-plugin.pc
|
||||
${PLIST.pulseaudio}lib/vlc/libvlc_pulse.la
|
||||
${PLIST.qt5}lib/vlc/libvlc_vdpau.la
|
||||
${PLIST.qt5}lib/vlc/libvlc_xcb_events.la
|
||||
${PLIST.vdpau}lib/vlc/libvlc_vdpau.la
|
||||
${PLIST.x11}lib/vlc/libvlc_xcb_events.la
|
||||
lib/vlc/lua/extensions/VLSub.luac
|
||||
lib/vlc/lua/intf/cli.luac
|
||||
lib/vlc/lua/intf/dummy.luac
|
||||
|
@ -178,6 +178,7 @@ lib/vlc/plugins/access/libhttp_plugin.la
|
|||
lib/vlc/plugins/access/libhttps_plugin.la
|
||||
lib/vlc/plugins/access/libidummy_plugin.la
|
||||
lib/vlc/plugins/access/libimem_plugin.la
|
||||
lib/vlc/plugins/access/liblibbluray_plugin.la
|
||||
${PLIST.pulseaudio}lib/vlc/plugins/access/libpulsesrc_plugin.la
|
||||
lib/vlc/plugins/access/librtp_plugin.la
|
||||
lib/vlc/plugins/access/libsatip_plugin.la
|
||||
|
@ -188,12 +189,12 @@ lib/vlc/plugins/access/libtimecode_plugin.la
|
|||
lib/vlc/plugins/access/libudp_plugin.la
|
||||
${PLIST.cdrom}lib/vlc/plugins/access/libvcd_plugin.la
|
||||
lib/vlc/plugins/access/libvdr_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/access/libxcb_screen_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/access/libxcb_screen_plugin.la
|
||||
lib/vlc/plugins/access_output/libaccess_output_dummy_plugin.la
|
||||
lib/vlc/plugins/access_output/libaccess_output_file_plugin.la
|
||||
lib/vlc/plugins/access_output/libaccess_output_http_plugin.la
|
||||
lib/vlc/plugins/access_output/libaccess_output_livehttp_plugin.la
|
||||
lib/vlc/plugins/access_output/libaccess_output_shout_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/access_output/libaccess_output_shout_plugin.la
|
||||
lib/vlc/plugins/access_output/libaccess_output_udp_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libaudio_format_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libaudiobargraph_a_plugin.la
|
||||
|
@ -208,12 +209,11 @@ lib/vlc/plugins/audio_filter/libmono_plugin.la
|
|||
lib/vlc/plugins/audio_filter/libnormvol_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libparam_eq_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libremap_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libsamplerate_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libscaletempo_pitch_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libscaletempo_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libsimple_channel_mixer_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libsoxr_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libspatializer_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libspeex_resampler_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libstereo_widen_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libtospdif_plugin.la
|
||||
lib/vlc/plugins/audio_filter/libtrivial_channel_mixer_plugin.la
|
||||
|
@ -230,7 +230,6 @@ ${PLIST.pulseaudio}lib/vlc/plugins/audio_output/libpulse_plugin.la
|
|||
lib/vlc/plugins/codec/liba52_plugin.la
|
||||
lib/vlc/plugins/codec/libadpcm_plugin.la
|
||||
lib/vlc/plugins/codec/libaes3_plugin.la
|
||||
lib/vlc/plugins/codec/libaom_plugin.la
|
||||
lib/vlc/plugins/codec/libaraw_plugin.la
|
||||
lib/vlc/plugins/codec/libavcodec_plugin.la
|
||||
lib/vlc/plugins/codec/libcc_plugin.la
|
||||
|
@ -246,7 +245,6 @@ lib/vlc/plugins/codec/libg711_plugin.la
|
|||
lib/vlc/plugins/codec/libjpeg_plugin.la
|
||||
lib/vlc/plugins/codec/libkate_plugin.la
|
||||
lib/vlc/plugins/codec/liblibass_plugin.la
|
||||
lib/vlc/plugins/codec/liblibmpeg2_plugin.la
|
||||
lib/vlc/plugins/codec/liblpcm_plugin.la
|
||||
lib/vlc/plugins/codec/libmpg123_plugin.la
|
||||
lib/vlc/plugins/codec/liboggspots_plugin.la
|
||||
|
@ -258,7 +256,6 @@ lib/vlc/plugins/codec/libschroedinger_plugin.la
|
|||
lib/vlc/plugins/codec/libscte18_plugin.la
|
||||
lib/vlc/plugins/codec/libscte27_plugin.la
|
||||
lib/vlc/plugins/codec/libspdif_plugin.la
|
||||
lib/vlc/plugins/codec/libspeex_plugin.la
|
||||
lib/vlc/plugins/codec/libspudec_plugin.la
|
||||
lib/vlc/plugins/codec/libstl_plugin.la
|
||||
lib/vlc/plugins/codec/libsubsdec_plugin.la
|
||||
|
@ -274,9 +271,8 @@ lib/vlc/plugins/codec/libuleaddvaudio_plugin.la
|
|||
${PLIST.vaapi}lib/vlc/plugins/codec/libvaapi_drm_plugin.la
|
||||
${PLIST.vaapi}lib/vlc/plugins/codec/libvaapi_plugin.la
|
||||
lib/vlc/plugins/codec/libvorbis_plugin.la
|
||||
lib/vlc/plugins/codec/libvpx_plugin.la
|
||||
lib/vlc/plugins/codec/libwebvtt_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/codec/libxwd_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/codec/libxwd_plugin.la
|
||||
${PLIST.dbus}lib/vlc/plugins/control/libdbus_plugin.la
|
||||
lib/vlc/plugins/control/libdummy_plugin.la
|
||||
lib/vlc/plugins/control/libgestures_plugin.la
|
||||
|
@ -285,7 +281,7 @@ ${PLIST.lirc}lib/vlc/plugins/control/liblirc_plugin.la
|
|||
lib/vlc/plugins/control/libmotion_plugin.la
|
||||
lib/vlc/plugins/control/libnetsync_plugin.la
|
||||
lib/vlc/plugins/control/liboldrc_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/control/libxcb_hotkeys_plugin.la
|
||||
${PLIST.qt5}${PLIST.x11}lib/vlc/plugins/control/libxcb_hotkeys_plugin.la
|
||||
lib/vlc/plugins/demux/libadaptive_plugin.la
|
||||
lib/vlc/plugins/demux/libaiff_plugin.la
|
||||
lib/vlc/plugins/demux/libasf_plugin.la
|
||||
|
@ -350,7 +346,7 @@ lib/vlc/plugins/misc/libgnutls_plugin.la
|
|||
lib/vlc/plugins/misc/liblogger_plugin.la
|
||||
lib/vlc/plugins/misc/libstats_plugin.la
|
||||
lib/vlc/plugins/misc/libvod_rtsp_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/misc/libxdg_screensaver_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/misc/libxdg_screensaver_plugin.la
|
||||
lib/vlc/plugins/misc/libxml_plugin.la
|
||||
lib/vlc/plugins/mux/libmux_asf_plugin.la
|
||||
lib/vlc/plugins/mux/libmux_avi_plugin.la
|
||||
|
@ -382,7 +378,7 @@ lib/vlc/plugins/services_discovery/libpodcast_plugin.la
|
|||
${PLIST.pulseaudio}lib/vlc/plugins/services_discovery/libpulselist_plugin.la
|
||||
lib/vlc/plugins/services_discovery/libsap_plugin.la
|
||||
lib/vlc/plugins/services_discovery/libupnp_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/services_discovery/libxcb_apps_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/services_discovery/libxcb_apps_plugin.la
|
||||
lib/vlc/plugins/spu/libaudiobargraph_v_plugin.la
|
||||
lib/vlc/plugins/spu/libdynamicoverlay_plugin.la
|
||||
lib/vlc/plugins/spu/liblogo_plugin.la
|
||||
|
@ -418,15 +414,15 @@ lib/vlc/plugins/stream_out/libstream_out_smem_plugin.la
|
|||
lib/vlc/plugins/stream_out/libstream_out_standard_plugin.la
|
||||
lib/vlc/plugins/stream_out/libstream_out_stats_plugin.la
|
||||
lib/vlc/plugins/stream_out/libstream_out_transcode_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/text_renderer/libfreetype_plugin.la
|
||||
lib/vlc/plugins/text_renderer/libfreetype_plugin.la
|
||||
lib/vlc/plugins/text_renderer/libtdummy_plugin.la
|
||||
${PLIST.vaapi}lib/vlc/plugins/vaapi/libvaapi_filters_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/vdpau/libvdpau_adjust_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/vdpau/libvdpau_avcodec_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/vdpau/libvdpau_chroma_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/vdpau/libvdpau_deinterlace_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/vdpau/libvdpau_display_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/vdpau/libvdpau_sharpen_plugin.la
|
||||
${PLIST.vdpau}lib/vlc/plugins/vdpau/libvdpau_adjust_plugin.la
|
||||
${PLIST.vdpau}lib/vlc/plugins/vdpau/libvdpau_avcodec_plugin.la
|
||||
${PLIST.vdpau}lib/vlc/plugins/vdpau/libvdpau_chroma_plugin.la
|
||||
${PLIST.vdpau}lib/vlc/plugins/vdpau/libvdpau_deinterlace_plugin.la
|
||||
${PLIST.vdpau}${PLIST.x11}lib/vlc/plugins/vdpau/libvdpau_display_plugin.la
|
||||
${PLIST.vdpau}lib/vlc/plugins/vdpau/libvdpau_sharpen_plugin.la
|
||||
lib/vlc/plugins/video_chroma/libchain_plugin.la
|
||||
lib/vlc/plugins/video_chroma/libgrey_yuv_plugin.la
|
||||
lib/vlc/plugins/video_chroma/libi420_10_p010_plugin.la
|
||||
|
@ -487,21 +483,21 @@ lib/vlc/plugins/video_filter/libsharpen_plugin.la
|
|||
lib/vlc/plugins/video_filter/libtransform_plugin.la
|
||||
lib/vlc/plugins/video_filter/libvhs_plugin.la
|
||||
lib/vlc/plugins/video_filter/libwave_plugin.la
|
||||
${PLIST.egl}lib/vlc/plugins/video_output/libegl_x11_plugin.la
|
||||
${PLIST.egl}${PLIST.x11}lib/vlc/plugins/video_output/libegl_x11_plugin.la
|
||||
lib/vlc/plugins/video_output/libflaschen_plugin.la
|
||||
lib/vlc/plugins/video_output/libgl_plugin.la
|
||||
${PLIST.egl}${PLIST.qt5}${PLIST.vaapi}lib/vlc/plugins/video_output/libglconv_vaapi_drm_plugin.la
|
||||
${PLIST.egl}${PLIST.qt5}${PLIST.vaapi}lib/vlc/plugins/video_output/libglconv_vaapi_x11_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/video_output/libglconv_vdpau_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/video_output/libglx_plugin.la
|
||||
${PLIST.egl}${PLIST.vaapi}lib/vlc/plugins/video_output/libglconv_vaapi_drm_plugin.la
|
||||
${PLIST.egl}${PLIST.vaapi}${PLIST.x11}lib/vlc/plugins/video_output/libglconv_vaapi_x11_plugin.la
|
||||
${PLIST.vdpau}lib/vlc/plugins/video_output/libglconv_vdpau_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_output/libglx_plugin.la
|
||||
lib/vlc/plugins/video_output/libvdummy_plugin.la
|
||||
lib/vlc/plugins/video_output/libvmem_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/video_output/libxcb_window_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/video_output/libxcb_x11_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/video_output/libxcb_xv_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_output/libxcb_window_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_output/libxcb_x11_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_output/libxcb_xv_plugin.la
|
||||
lib/vlc/plugins/video_output/libyuv_plugin.la
|
||||
lib/vlc/plugins/video_splitter/libclone_plugin.la
|
||||
${PLIST.qt5}lib/vlc/plugins/video_splitter/libpanoramix_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_splitter/libpanoramix_plugin.la
|
||||
lib/vlc/plugins/video_splitter/libwall_plugin.la
|
||||
lib/vlc/plugins/visualization/libglspectrum_plugin.la
|
||||
lib/vlc/plugins/visualization/libvisual_plugin.la
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.76 2019/08/22 16:20:24 nia Exp $
|
||||
$NetBSD: distinfo,v 1.77 2020/05/01 13:51:54 nia Exp $
|
||||
|
||||
SHA1 (vlc-3.0.8.tar.xz) = 424a9795e051c198e7fa28107b15809ee6820d43
|
||||
RMD160 (vlc-3.0.8.tar.xz) = ccb9cf848ba3aa3d57e1dc6a4ccec9f59002883c
|
||||
SHA512 (vlc-3.0.8.tar.xz) = 5ade0b350e98fd6fa90035bffabda96f0addb3844a7c0a242b4db1cab6a746e1adb1d713ddcb48ae51a7d1736090f096f5d3b0637a9f958ccf4fcf27e838cf70
|
||||
Size (vlc-3.0.8.tar.xz) = 26041520 bytes
|
||||
SHA1 (vlc-3.0.10.tar.xz) = 4b3c75d1861bf463db53ba9059e8cc165f5c30a7
|
||||
RMD160 (vlc-3.0.10.tar.xz) = b3b0d383f34dbf58e2e79729884c8b9fcdd02807
|
||||
SHA512 (vlc-3.0.10.tar.xz) = dcfa39e3e61bf522ea3a0e1686251356ec262dd8826fc64ccae5ac34a62f72ddc9fe9f2e2b45588013d5907e39649cf39d0c9156980d1eb679eac9b9cb434341
|
||||
Size (vlc-3.0.10.tar.xz) = 26096828 bytes
|
||||
SHA1 (patch-compat_Makefile.am) = 1c3e0a7c4610c55c3ec9ba80d66b9959661139b3
|
||||
SHA1 (patch-configure.ac) = 99e975954323b4e94daeb75ce2ae439b49c51b0f
|
||||
SHA1 (patch-lib_core.c) = 8ec5557424e6ddc05cc365aacd1ec847d9a94605
|
||||
SHA1 (patch-lib_video.c) = 362aaf7977c264bb70a79e98cf18da923ae62e39
|
||||
SHA1 (patch-m4_dolt.m4) = a1aac0c1021001a489f9b515e218904e065ed659
|
||||
SHA1 (patch-modules_access_http_Makefile.am) = d91904c6cba1a75a6872d042e4fe87ed9ce65a22
|
||||
SHA1 (patch-share_Makefile.am) = 380dc4ac4a1a19cd1ccc8219b3d1d3b927585c49
|
||||
SHA1 (patch-share_Makefile.am) = 4f126948c73159d06aef323b47a702442b5981e8
|
||||
|
|
|
@ -1,24 +1,33 @@
|
|||
# $NetBSD: options.mk,v 1.34 2019/07/08 10:16:12 nia Exp $
|
||||
# $NetBSD: options.mk,v 1.35 2020/05/01 13:51:54 nia Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.vlc
|
||||
PKG_SUPPORTED_OPTIONS= alsa avahi dbus debug dts jack pulseaudio
|
||||
PKG_SUPPORTED_OPTIONS+= vlc-skins qt5
|
||||
PKG_SUGGESTED_OPTIONS= dbus qt5
|
||||
PKG_SUPPORTED_OPTIONS+= vlc-skins qt5 x11
|
||||
PKG_SUGGESTED_OPTIONS= dbus qt5 x11
|
||||
PKG_SUGGESTED_OPTIONS.Linux+= alsa
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "../../mk/bsd.fast.prefs.mk"
|
||||
|
||||
.if ${OPSYS} != "Darwin"
|
||||
PKG_SUGGESTED_OPTIONS+= x11
|
||||
.endif
|
||||
|
||||
### Add VAAPI if it is available
|
||||
.include "../../multimedia/libva/available.mk"
|
||||
PLIST_VARS+= vaapi
|
||||
.if ${VAAPI_AVAILABLE} == "yes"
|
||||
PKG_SUPPORTED_OPTIONS+= vaapi
|
||||
PKG_SUGGESTED_OPTIONS+= vaapi
|
||||
.endif
|
||||
|
||||
### Add VDPAU if it is available
|
||||
.include "../../multimedia/libvdpau/available.mk"
|
||||
.if ${VAAPI_AVAILABLE} == "yes"
|
||||
PKG_SUPPORTED_OPTIONS+= vdpau
|
||||
PKG_SUGGESTED_OPTIONS+= vdpau
|
||||
.endif
|
||||
|
||||
### Add LIRC if it is available
|
||||
.include "../../comms/lirc/available.mk"
|
||||
PLIST_VARS+= lirc
|
||||
.if ${LIRC_AVAILABLE} == "yes"
|
||||
PKG_SUPPORTED_OPTIONS+= lirc
|
||||
PKG_SUGGESTED_OPTIONS+= lirc
|
||||
|
@ -27,10 +36,9 @@ PKG_SUGGESTED_OPTIONS+= lirc
|
|||
###
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= ${PKG_SUPPORTED_OPTIONS}
|
||||
|
||||
## ALSA support
|
||||
|
||||
PLIST_VARS+= alsa
|
||||
.if !empty(PKG_OPTIONS:Malsa)
|
||||
CONFIGURE_ARGS+= --enable-alsa
|
||||
.include "../../audio/alsa-lib/buildlink3.mk"
|
||||
|
@ -41,6 +49,7 @@ CONFIGURE_ARGS+= --disable-alsa
|
|||
|
||||
## Avahi support
|
||||
|
||||
PLIST_VARS+= avahi
|
||||
.if !empty(PKG_OPTIONS:Mavahi)
|
||||
CONFIGURE_ARGS+= --enable-avahi
|
||||
.include "../../net/avahi/buildlink3.mk"
|
||||
|
@ -51,6 +60,7 @@ CONFIGURE_ARGS+= --disable-avahi
|
|||
|
||||
## PulseAudio support
|
||||
|
||||
PLIST_VARS+= pulseaudio
|
||||
.if !empty(PKG_OPTIONS:Mpulseaudio)
|
||||
CONFIGURE_ARGS+= --enable-pulse
|
||||
.include "../../audio/pulseaudio/buildlink3.mk"
|
||||
|
@ -61,6 +71,7 @@ CONFIGURE_ARGS+= --disable-pulse
|
|||
|
||||
## Jack Audio Connection Kit support
|
||||
|
||||
PLIST_VARS+= jack
|
||||
.if !empty(PKG_OPTIONS:Mjack)
|
||||
CONFIGURE_ARGS+= --enable-jack
|
||||
.include "../../audio/jack/buildlink3.mk"
|
||||
|
@ -71,6 +82,7 @@ CONFIGURE_ARGS+= --disable-jack
|
|||
|
||||
## DBUS message bus support
|
||||
|
||||
PLIST_VARS+= dbus
|
||||
.if !empty(PKG_OPTIONS:Mdbus)
|
||||
CONFIGURE_ARGS+= --enable-dbus
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
|
@ -88,6 +100,7 @@ CONFIGURE_ARGS+= --disable-optimizations
|
|||
|
||||
## SKINS frontend
|
||||
|
||||
PLIST_VARS+= vlc-skins
|
||||
.if !empty(PKG_OPTIONS:Mvlc-skins)
|
||||
CONFIGURE_ARGS+= --enable-skins2
|
||||
PLIST.vlc-skins= yes
|
||||
|
@ -96,41 +109,40 @@ INSTALLATION_DIRS+= share/vlc/skins2
|
|||
CONFIGURE_ARGS+= --disable-skins2
|
||||
.endif
|
||||
|
||||
## X11 dependency and QT5 frontend
|
||||
## QT5 frontend
|
||||
|
||||
PLIST_VARS+= egl
|
||||
PLIST_VARS+= qt5
|
||||
.if !empty(PKG_OPTIONS:Mqt5)
|
||||
DEPENDS+= dejavu-ttf>=2.0:../../fonts/dejavu-ttf
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../x11/libXv/buildlink3.mk"
|
||||
.include "../../x11/libXvMC/buildlink3.mk"
|
||||
.include "../../x11/libXxf86vm/buildlink3.mk"
|
||||
.include "../../x11/libXdamage/buildlink3.mk"
|
||||
.include "../../x11/libXinerama/buildlink3.mk"
|
||||
.include "../../x11/libXpm/buildlink3.mk"
|
||||
.include "../../x11/libxcb/buildlink3.mk"
|
||||
.include "../../x11/xcb-util-keysyms/buildlink3.mk"
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../graphics/glu/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtsvg/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtx11extras/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --enable-qt \
|
||||
--with-x
|
||||
PLIST.qt5= yes
|
||||
. if ${MESALIB_SUPPORTS_EGL} == "yes"
|
||||
PLIST.egl= yes
|
||||
. endif
|
||||
CONFIGURE_ARGS+= --enable-qt
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-x \
|
||||
--disable-xcb \
|
||||
--disable-qt \
|
||||
--disable-freetype \
|
||||
--disable-vdpau
|
||||
CONFIGURE_ARGS+= --disable-qt
|
||||
.endif
|
||||
|
||||
## X11 video output
|
||||
|
||||
PLIST_VARS+= x11
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libxcb/buildlink3.mk"
|
||||
PLIST.x11= yes
|
||||
CONFIGURE_ARGS+= --enable-xcb
|
||||
CONFIGURE_ARGS+= --enable-xvideo
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-xcb
|
||||
CONFIGURE_ARGS+= --disable-xvideo
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mx11) && !empty(PKG_OPTIONS:Mqt5)
|
||||
.include "../../x11/qt5-qtx11extras/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
## DTS support (libdca is non-redistributable)
|
||||
|
||||
PLIST_VARS+= dts
|
||||
.if !empty(PKG_OPTIONS:Mdts)
|
||||
CONFIGURE_ARGS+= --enable-dca
|
||||
PLIST.dts= yes
|
||||
|
@ -140,6 +152,7 @@ CONFIGURE_ARGS+= --enable-dca=no
|
|||
.endif
|
||||
|
||||
## VAAPI support
|
||||
PLIST_VARS+= vaapi
|
||||
.if !empty(PKG_OPTIONS:Mvaapi)
|
||||
CONFIGURE_ARGS+= --enable-libva
|
||||
PLIST.vaapi= yes
|
||||
|
@ -148,7 +161,18 @@ PLIST.vaapi= yes
|
|||
CONFIGURE_ARGS+= --disable-libva
|
||||
.endif
|
||||
|
||||
## VDPAU support
|
||||
PLIST_VARS+= vdpau
|
||||
.if !empty(PKG_OPTIONS:Mvaapi)
|
||||
CONFIGURE_ARGS+= --enable-vdpau
|
||||
PLIST.vdpau= yes
|
||||
.include "../../multimedia/libvdpau/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-vdpau
|
||||
.endif
|
||||
|
||||
## LIRC support
|
||||
PLIST_VARS+= lirc
|
||||
.if !empty(PKG_OPTIONS:Mlirc)
|
||||
CONFIGURE_ARGS+= --enable-lirc
|
||||
PLIST.lirc= yes
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-share_Makefile.am,v 1.1 2019/07/02 20:52:13 nia Exp $
|
||||
$NetBSD: patch-share_Makefile.am,v 1.2 2020/05/01 13:51:54 nia Exp $
|
||||
|
||||
Remove unportable tar parameters.
|
||||
Allow installing as non-root.
|
||||
|
||||
--- share/Makefile.am.orig 2018-02-06 18:41:06.000000000 +0000
|
||||
--- share/Makefile.am.orig 2020-04-05 13:46:34.000000000 +0000
|
||||
+++ share/Makefile.am
|
||||
@@ -94,7 +94,7 @@ skins2/default.vlt: $(skins2_default_vlt
|
||||
$(AM_V_at)rm -f -- skins2/default.vlt.tmp
|
||||
$(AM_V_GEN)GZIP=--no-name \
|
||||
@@ -97,7 +97,7 @@ skins2/default.vlt: $(skins2_default_vlt
|
||||
GZIP=--no-name \
|
||||
tar cvvzf skins2/default.vlt.tmp \
|
||||
--format=ustar $$tarsort \
|
||||
- --owner=root --group=root --directory="$(srcdir)/skins2" \
|
||||
+ --directory="$(srcdir)/skins2" \
|
||||
default/
|
||||
|
|
Loading…
Reference in a new issue