PR pkg/53086
Fix the configure code that removes spaces in "-L /some/path" etc.
This commit is contained in:
parent
78eba09b6b
commit
1ef250c921
5 changed files with 39 additions and 25 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.118 2017/03/06 16:14:07 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.119 2018/03/12 16:36:44 hans Exp $
|
||||
|
||||
###########################################################################
|
||||
###########################################################################
|
||||
|
@ -31,6 +31,7 @@
|
|||
.include "../../devel/libtool/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/-base-/}
|
||||
PKGREVISION= 1
|
||||
|
||||
COMMENT= Generic shared library support script (the script itself)
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.15 2017/03/06 16:14:07 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2018/03/12 16:36:44 hans Exp $
|
||||
|
||||
###########################################################################
|
||||
###########################################################################
|
||||
|
@ -33,6 +33,7 @@
|
|||
FILESDIR= ${.CURDIR}/../libtool-base/files
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/-fortran-/}
|
||||
PKGREVISION= 1
|
||||
|
||||
COMMENT= Generic shared library support script (the script itself, incl. Fortran)
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.103 2017/03/06 16:14:07 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.104 2018/03/12 16:36:44 hans Exp $
|
||||
|
||||
SHA1 (libtool-2.4.6.tar.gz) = 25b6931265230a06f0fc2146df64c04e5ae6ec33
|
||||
RMD160 (libtool-2.4.6.tar.gz) = 6f4b4c3e89426652da3acffa707f71bb4ccee26a
|
||||
|
@ -7,5 +7,5 @@ Size (libtool-2.4.6.tar.gz) = 1806697 bytes
|
|||
SHA1 (patch-Makefile.in) = 0adb634335acd5fb280c99b5d43ae568018ca0af
|
||||
SHA1 (patch-build-aux_depcomp) = ae6f93ad4fac1df648cfcb62601c72f9ebb30233
|
||||
SHA1 (patch-build-aux_ltmain.sh) = eebdc102cacb1970240abeb4a7310d09d505be02
|
||||
SHA1 (patch-configure) = 818157dd9bf985657a0089a7d887304b71559837
|
||||
SHA1 (patch-configure) = 2cbf275a4de712bc151c5065b62b2bdb37c83188
|
||||
SHA1 (patch-libltdl_configure) = 87535836200547ceb8463a98e86561c2adf1f0ed
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: manual-libtool.m4,v 1.46 2017/03/06 16:14:07 jperkin Exp $
|
||||
$NetBSD: manual-libtool.m4,v 1.47 2018/03/12 16:36:44 hans Exp $
|
||||
|
||||
Support mirbsd/midnightbsd.
|
||||
Handle pkgsrc wrappers.
|
||||
|
@ -439,11 +439,15 @@ Fixup output on various OS.
|
|||
_LT_TAGVAR(archive_cmds, $1)='$CC -shared $pic_flag -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-h $wl$soname -o $lib'
|
||||
_LT_TAGVAR(archive_expsym_cmds, $1)='echo "{ global:" > $lib.exp~cat $export_symbols | $SED -e "s/\(.*\)/\1;/" >> $lib.exp~echo "local: *; };" >> $lib.exp~
|
||||
$CC -shared $pic_flag -nostdlib $wl-M $wl$lib.exp $wl-h $wl$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags~$RM $lib.exp'
|
||||
@@ -7535,6 +7649,7 @@ if AC_TRY_EVAL(ac_compile); then
|
||||
@@ -7534,8 +7648,9 @@ if AC_TRY_EVAL(ac_compile); then
|
||||
-L* | -R* | -l*)
|
||||
# Some compilers place space between "-{L,R}" and the path.
|
||||
# Remove the space.
|
||||
if test x-L = "$p" ||
|
||||
+ test x-l = "$p" ||
|
||||
test x-R = "$p"; then
|
||||
- if test x-L = "$p" ||
|
||||
- test x-R = "$p"; then
|
||||
+ if test x-L = x"$p" ||
|
||||
+ test x-l = x"$p" ||
|
||||
+ test x-R = x"$p"; then
|
||||
prev=$p
|
||||
continue
|
||||
fi
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-configure,v 1.1 2017/03/06 16:14:07 jperkin Exp $
|
||||
$NetBSD: patch-configure,v 1.2 2018/03/12 16:36:44 hans Exp $
|
||||
|
||||
Automatically generated using manual-* patches and bootstrap.
|
||||
DO NOT MODIFY THIS PATCH MANUALLY! YOUR CHANGES WILL BE LOST!
|
||||
|
||||
--- configure.orig 2017-02-02 10:07:28.000000000 +0000
|
||||
--- configure.orig 2018-03-12 10:30:57.156767466 +0000
|
||||
+++ configure
|
||||
@@ -5903,7 +5903,7 @@ else
|
||||
lt_cv_sys_max_cmd_len=8192;
|
||||
|
@ -428,14 +428,18 @@ DO NOT MODIFY THIS PATCH MANUALLY! YOUR CHANGES WILL BE LOST!
|
|||
archive_cmds_CXX='$CC -shared $pic_flag -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-h $wl$soname -o $lib'
|
||||
archive_expsym_cmds_CXX='echo "{ global:" > $lib.exp~cat $export_symbols | $SED -e "s/\(.*\)/\1;/" >> $lib.exp~echo "local: *; };" >> $lib.exp~
|
||||
$CC -shared $pic_flag -nostdlib $wl-M $wl$lib.exp $wl-h $wl$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags~$RM $lib.exp'
|
||||
@@ -16131,6 +16239,7 @@ if { { eval echo "\"\$as_me\":${as_linen
|
||||
@@ -16130,8 +16238,9 @@ if { { eval echo "\"\$as_me\":${as_linen
|
||||
-L* | -R* | -l*)
|
||||
# Some compilers place space between "-{L,R}" and the path.
|
||||
# Remove the space.
|
||||
if test x-L = "$p" ||
|
||||
+ test x-l = "$p" ||
|
||||
test x-R = "$p"; then
|
||||
- if test x-L = "$p" ||
|
||||
- test x-R = "$p"; then
|
||||
+ if test x-L = x"$p" ||
|
||||
+ test x-l = x"$p" ||
|
||||
+ test x-R = x"$p"; then
|
||||
prev=$p
|
||||
continue
|
||||
fi
|
||||
@@ -16311,9 +16420,15 @@ lt_prog_compiler_static_CXX=
|
||||
esac
|
||||
;;
|
||||
|
@ -834,14 +838,18 @@ DO NOT MODIFY THIS PATCH MANUALLY! YOUR CHANGES WILL BE LOST!
|
|||
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
|
||||
shlibpath_var=LD_LIBRARY_PATH
|
||||
shlibpath_overrides_runpath=yes
|
||||
@@ -21450,6 +21674,7 @@ if { { eval echo "\"\$as_me\":${as_linen
|
||||
@@ -21449,8 +21673,9 @@ if { { eval echo "\"\$as_me\":${as_linen
|
||||
-L* | -R* | -l*)
|
||||
# Some compilers place space between "-{L,R}" and the path.
|
||||
# Remove the space.
|
||||
if test x-L = "$p" ||
|
||||
+ test x-l = "$p" ||
|
||||
test x-R = "$p"; then
|
||||
- if test x-L = "$p" ||
|
||||
- test x-R = "$p"; then
|
||||
+ if test x-L = x"$p" ||
|
||||
+ test x-l = x"$p" ||
|
||||
+ test x-R = x"$p"; then
|
||||
prev=$p
|
||||
continue
|
||||
fi
|
||||
@@ -21604,9 +21829,16 @@ lt_prog_compiler_static_FC=
|
||||
;;
|
||||
|
||||
|
|
Loading…
Reference in a new issue