Don't define extern int errno, just depend on errno.h for it.

This commit is contained in:
joerg 2005-11-07 12:55:06 +00:00
parent 72b9049b3f
commit 1f04365514
2 changed files with 14 additions and 6 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.7 2005/10/07 17:15:40 joerg Exp $
$NetBSD: distinfo,v 1.8 2005/11/07 12:55:06 joerg Exp $
SHA1 (dact-0.8.3.tar.gz) = 850aec889be4174e9f42a3314bf29b1fc5181090
RMD160 (dact-0.8.3.tar.gz) = 2778e64d3c456fc63b1739b31773f7ff2d84ee9c
Size (dact-0.8.3.tar.gz) = 84301 bytes
SHA1 (patch-aa) = f0040ac3f13305a33943407759d52454dd6d7d37
SHA1 (patch-ab) = 75235c19ea8fbfac87eebcbe88dd9273136c08c5
SHA1 (patch-ac) = 0eb282401de47dab92bc4df2723300ace1f00b4b
SHA1 (patch-ac) = 240ef0959be3fc0f3dbf2d9a67b31d7b03d5c642
SHA1 (patch-ad) = b26314007903508ae6af6d283ad3eb2523869bf9
SHA1 (patch-ae) = d297c3c616d34db8ff7e62db5462739cb3740b4d

View file

@ -1,8 +1,16 @@
$NetBSD: patch-ac,v 1.1 2005/10/07 17:15:40 joerg Exp $
$NetBSD: patch-ac,v 1.2 2005/11/07 12:55:06 joerg Exp $
--- net.c.orig 2005-10-07 19:06:20.000000000 +0200
--- net.c.orig 2001-09-07 20:29:03.000000000 +0000
+++ net.c
@@ -85,7 +85,7 @@ int open_net(const char *pathname, int f
@@ -22,7 +22,6 @@
#include "parse.h"
#include "crc.h"
-extern int errno;
char *dact_urls[256];
/*
@@ -85,7 +84,7 @@ int open_net(const char *pathname, int f
mode_t mode;
va_start(args, flags);
@ -11,7 +19,7 @@ $NetBSD: patch-ac,v 1.1 2005/10/07 17:15:40 joerg Exp $
va_end(args);
if (!parse_url(pathname,scheme,username,password,host,&port,file)) {
@@ -292,7 +292,7 @@ int open_net(const char *pathname, int f
@@ -292,7 +291,7 @@ int open_net(const char *pathname, int f
mode_t mode;
va_start(args, flags);