Add httpfile, a secure HTTP server derived from publicfile.
- removed ftpd - added "Content-Encoding: gzip" - added more 'default' filetypes - case insensitive filetype checking - upgraded alloc library, added memory limit - added request timeout - added basic authentication as a simple protection against robots - added 301 redirect for directories - added range support
This commit is contained in:
parent
8f52ceaa4f
commit
1f40118ea0
5 changed files with 80 additions and 0 deletions
11
www/httpfile/DESCR
Normal file
11
www/httpfile/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
httpfile is a secure HTTP server derived from publicfile-0.52:
|
||||
|
||||
- removed ftpd
|
||||
- added "Content-Encoding: gzip"
|
||||
- added more 'default' filetypes
|
||||
- case insensitive filetype checking
|
||||
- upgraded alloc library, added memory limit
|
||||
- added request timeout
|
||||
- added basic authentication as a simple protection against robots
|
||||
- added 301 redirect for directories
|
||||
- added range support
|
16
www/httpfile/Makefile
Normal file
16
www/httpfile/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1 2021/10/21 20:38:35 schmonz Exp $
|
||||
|
||||
DISTNAME= httpfile-20151206
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${HOMEPAGE}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= schmonz@NetBSD.org
|
||||
HOMEPAGE= https://mojzis.com/software/httpfile/
|
||||
COMMENT= Secure HTTP server derived from publicfile
|
||||
LICENSE= djb-nonlicense
|
||||
|
||||
DJB_BUILD_TARGETS= install instcheck
|
||||
|
||||
.include "../../mk/djbware.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
8
www/httpfile/PLIST
Normal file
8
www/httpfile/PLIST
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2021/10/21 20:38:35 schmonz Exp $
|
||||
bin/httpfile-access
|
||||
bin/httpfile-conf
|
||||
bin/httpfile-getmtime
|
||||
bin/httpfile-gzip
|
||||
bin/httpfile-httpd
|
||||
bin/httpfile-setlock
|
||||
bin/httpfile-setmtime
|
6
www/httpfile/distinfo
Normal file
6
www/httpfile/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2021/10/21 20:38:35 schmonz Exp $
|
||||
|
||||
RMD160 (httpfile-20151206.tar.bz2) = 9f83a89d47ca7d12cb80025ea178bff31823a81a
|
||||
SHA512 (httpfile-20151206.tar.bz2) = 1768a647f16026e8a928432bd21a6a8673d5993b8a913375a91fa0f62aac382bd32efc13cebc31bf275b298883d083f2485d4fe1a74f87907b29ceb721677d00
|
||||
Size (httpfile-20151206.tar.bz2) = 29502 bytes
|
||||
SHA1 (patch-Makefile) = 3739cf9cec613dbd9b823b9bca15b3e656497bb8
|
39
www/httpfile/patches/patch-Makefile
Normal file
39
www/httpfile/patches/patch-Makefile
Normal file
|
@ -0,0 +1,39 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2021/10/21 20:38:35 schmonz Exp $
|
||||
|
||||
DESTDIR support.
|
||||
|
||||
--- Makefile.orig 2013-11-24 14:38:10.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -757,6 +757,14 @@ auto-str: \
|
||||
load auto-str.o library.a
|
||||
./load auto-str library.a
|
||||
|
||||
+auto_destdir.c: \
|
||||
+auto-str conf-destdir
|
||||
+ ./auto-str auto_home `head -1 conf-destdir` > auto_destdir.c
|
||||
+
|
||||
+auto_destdir.o: \
|
||||
+compile auto_destdir.c
|
||||
+ ./compile auto_destdir.c
|
||||
+
|
||||
auto_home.c: \
|
||||
auto-str conf-home
|
||||
./auto-str auto_home `head -1 conf-home` > auto_home.c
|
||||
@@ -770,13 +778,12 @@ load httpfile-conf.o auto_home.o library
|
||||
./load httpfile-conf auto_home.o library.a
|
||||
|
||||
install: \
|
||||
-load install.o auto_home.o library.a
|
||||
- ./load install auto_home.o library.a
|
||||
- ./install
|
||||
+load install.o auto_destdir.o library.a
|
||||
+ ./load install auto_destdir.o library.a
|
||||
|
||||
instcheck: \
|
||||
-load instcheck.o auto_home.o library.a
|
||||
- ./load instcheck auto_home.o library.a
|
||||
+load instcheck.o auto_destdir.o library.a
|
||||
+ ./load instcheck auto_destdir.o library.a
|
||||
|
||||
httpfile-gzip: \
|
||||
warn-auto.sh httpfile-gzip.sh conf-home
|
Loading…
Reference in a new issue