Update alpine to 0.99nb1 - do not ^M and similar to toupper(). Avoids

potential crash on selecting files to attach on some machines
This commit is contained in:
abs 2007-05-17 21:58:58 +00:00
parent 78a2d5eabc
commit 1f43cff805
3 changed files with 19 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/05/03 12:11:37 abs Exp $
# $NetBSD: Makefile,v 1.2 2007/05/17 21:58:58 abs Exp $
#
DISTNAME= alpine-0.99
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cac.washington.edu/alpine/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2007/05/03 12:11:37 abs Exp $
$NetBSD: distinfo,v 1.2 2007/05/17 21:58:58 abs Exp $
SHA1 (alpine-0.99.tar.bz2) = 240f2b3d5229714ab1e7cc1ef3a4339dfaccf2e7
RMD160 (alpine-0.99.tar.bz2) = a896213860badede88500e746f9186310b4d1364
Size (alpine-0.99.tar.bz2) = 4920156 bytes
SHA1 (patch-aa) = 1269dcd9b9a86980ac02facc65ec5beb6dd45221
SHA1 (patch-ab) = f0f4d6c8017cbb5bda8d46d7cb62b323c6e3a8d7

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1 2007/05/17 21:58:58 abs Exp $
--- pico/browse.c.orig 2007-03-07 23:16:56.000000000 +0000
+++ pico/browse.c
@@ -1399,8 +1399,8 @@ FileBrowse(char *dir, size_t dirlen, cha
case (CTRL|'M'):
Selected:
- if((toupper(new_c) == 'S' && (gmode&MDBRONLY))
- || (toupper(new_c) == 'V' && !(gmode&MDBRONLY)))
+ if(((new_c == 'S' || new_c == 's') && (gmode&MDBRONLY))
+ || ((new_c == 'V' || new_c == 'v') && !(gmode&MDBRONLY)))
goto Default;
if(gmp->current->mode == FIODIR){