Use stdlib.h instead of malloc.h, which is nonstandard.

This commit is contained in:
minskim 2007-06-23 08:26:44 +00:00
parent 7afa15017c
commit 1f59c2f2f8
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.13 2007/03/07 18:37:33 joerg Exp $
$NetBSD: distinfo,v 1.14 2007/06/23 08:26:44 minskim Exp $
SHA1 (smalltalk-2.1.9.tar.gz) = e068f993d2fba93138e68c23c73e357541ade416
RMD160 (smalltalk-2.1.9.tar.gz) = fdee6fb13b5663bffcae5df7c57c0a5096e621c2
@ -6,3 +6,4 @@ Size (smalltalk-2.1.9.tar.gz) = 3354139 bytes
SHA1 (patch-aa) = 84d2cd463aee940ca123c5de2aab43d6a1d25582
SHA1 (patch-ab) = 43421fda6d712d581f10bb37c3e79b9203e51757
SHA1 (patch-ac) = 3d32486364a86d2face58749a4862324a9ca4008
SHA1 (patch-ad) = 4b3a92aebb4af36b54be426adeb69945a5e9dcb6

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2007/06/23 08:26:44 minskim Exp $
--- examples/gdbm.c.orig 2003-05-27 10:41:20.000000000 -0700
+++ examples/gdbm.c
@@ -34,7 +34,7 @@
#include "gstpub.h"
#include <gdbm.h>
-#include <malloc.h>
+#include <stdlib.h>
/*
GDBM_FILE gdbm_open(name, block_size, flags, mode, fatal_func);