Update to 1.5.0. From the changelog:

- Added support for Rio Nitrus.
- Updated mp3 and id3 parsers.
- Removed macosx and usbdevfs drivers. libusb is now the standard driver.
- Several small bugfixes.

pkgsrc patches for DragonFly carried forward. Builds and runs on
OS X but untested (I haven't had a Rio for years). 1.4.7 was broken
in Krister's NetBSD 4.0_BETA2/i386 bulk build; perhaps this will
help.
This commit is contained in:
schmonz 2007-01-06 04:21:24 +00:00
parent 617685d893
commit 1fca6d8469
8 changed files with 40 additions and 59 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.20 2005/12/07 17:35:37 joerg Exp $
# $NetBSD: Makefile,v 1.21 2007/01/06 04:21:24 schmonz Exp $
#
DISTNAME= rioutil-1.4.7
DISTNAME= rioutil-1.5.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=rioutil/}

View file

@ -1,11 +1,9 @@
$NetBSD: distinfo,v 1.9 2005/12/07 17:35:37 joerg Exp $
$NetBSD: distinfo,v 1.10 2007/01/06 04:21:24 schmonz Exp $
SHA1 (rioutil-1.4.7.tar.gz) = 956a75ce2f23fa0dfd62a4c1facbd1994b88cde6
RMD160 (rioutil-1.4.7.tar.gz) = 8578338b2b77d3cc9477bc92a6bb8c28b4cf434e
Size (rioutil-1.4.7.tar.gz) = 406844 bytes
SHA1 (patch-aa) = 6932aee6f2fe76209e65d90e5dd5afb61bb5428b
SHA1 (patch-ab) = 903135b95b821af8b056805f46e801ef37236e1e
SHA1 (patch-ac) = 21c13d418b10c173e893365a10de40b4b1f5cc16
SHA1 (patch-ad) = 3f92420ad40f48953ed3b313dc9452e6d31c9533
SHA1 (patch-ae) = e803dca42db9f6ebf7af436d722646a223ed0b7b
SHA1 (patch-af) = 1fc20cbf82272fbdc44f6dd909f64347d9927ea4
SHA1 (rioutil-1.5.0.tar.gz) = f775bab0ed7ec456dd5d2826083ca8a5075aa4ec
RMD160 (rioutil-1.5.0.tar.gz) = 2f1db9eb36501aecdb388278d5f7c1876bfebf19
Size (rioutil-1.5.0.tar.gz) = 401244 bytes
SHA1 (patch-aa) = 4783194bc911fc9c9b1ebd9f03a92180cd7a8f77
SHA1 (patch-ab) = d5a206224a24bf9dfd651c003b621dc5cea90a58
SHA1 (patch-ac) = 2ea2f01308a3d3e92fc0fb1b652c1df50dddef01
SHA1 (patch-ae) = 0a0204111364b7da4c64364130062bc004dc804c

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2005/12/07 17:35:37 joerg Exp $
$NetBSD: patch-aa,v 1.4 2007/01/06 04:21:24 schmonz Exp $
--- src/main.c.orig 2005-12-07 17:12:51.000000000 +0000
--- src/main.c.orig 2006-08-08 12:23:08.000000000 -0400
+++ src/main.c
@@ -893,10 +893,10 @@ void usage(void){
@@ -730,10 +730,10 @@ static void usage (void) {
printf(" -d, --delete=<int> delete a track(s)\n\n");
printf(" options:\n");

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.1 2005/12/07 17:35:37 joerg Exp $
$NetBSD: patch-ab,v 1.2 2007/01/06 04:21:24 schmonz Exp $
--- linux_driver/rio_usb.h.orig 2005-12-07 17:17:16.000000000 +0000
--- linux_driver/rio_usb.h.orig 2006-08-07 11:47:28.000000000 -0400
+++ linux_driver/rio_usb.h
@@ -59,7 +59,7 @@ struct RioCommand {
@@ -61,7 +61,7 @@ struct RioCommand {
int timeout;
};

View file

@ -1,8 +1,17 @@
$NetBSD: patch-ac,v 1.1 2005/12/07 17:35:37 joerg Exp $
$NetBSD: patch-ac,v 1.2 2007/01/06 04:21:24 schmonz Exp $
--- librioutil/driver_standard.c.orig 2005-12-07 17:14:39.000000000 +0000
+++ librioutil/driver_standard.c
@@ -33,7 +33,7 @@
--- librioutil/driver_file.c.orig 2006-08-07 11:47:28.000000000 -0400
+++ librioutil/driver_file.c
@@ -32,7 +32,7 @@
char driver_method[] = "device file";
/* Duplicated from rio_usb.h */
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
#define RIO_RECV_COMMAND _IOWR('U', 201, struct RioCommand)
#else
#define RIO_RECV_COMMAND 0x2
@@ -42,7 +42,7 @@ char driver_method[] = "device file";
#ifdef linux
#include <linux/usb.h>
#define RIODEVICE "/dev/usb/rio"

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ad,v 1.1 2005/12/07 17:35:37 joerg Exp $
--- include/rio_usb.h.orig 2005-12-07 17:15:13.000000000 +0000
+++ include/rio_usb.h
@@ -54,7 +54,7 @@ struct RioCommand {
int timeout;
};
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
#define RIO_SEND_COMMAND _IOWR('U', 200, struct RioCommand)
#define RIO_RECV_COMMAND _IOWR('U', 201, struct RioCommand)
#else

View file

@ -1,19 +1,19 @@
$NetBSD: patch-ae,v 1.1 2005/12/07 17:35:37 joerg Exp $
$NetBSD: patch-ae,v 1.2 2007/01/06 04:21:24 schmonz Exp $
--- include/rio_internal.h.orig 2005-12-07 17:15:27.000000000 +0000
+++ include/rio_internal.h
@@ -567,7 +567,7 @@ unsigned int crc32_rio (unsigned char *,
--- include/rioi.h.orig 2006-08-04 18:40:49.000000000 -0400
+++ include/rioi.h
@@ -190,7 +190,7 @@ Group ID 0x7c ????
#define bswap_32(x) NXSwapLong(x)
#define bswap_16(x) NXSwapShort(x)
#if defined (__FreeBSD__) || defined(__MacOSX__)
u_int32_t bswap_32(u_int32_t);
-#elif defined (__NetBSD__)
+#elif defined (__NetBSD__) || defined(__DragonFly__)
#define bswap_64(x) bswap64(x)
#define bswap_32(x) bswap32(x)
#endif
@@ -585,6 +585,9 @@ char *basename(char *x);
#include <machine/endian.h>
@@ -203,6 +203,9 @@ Group ID 0x7c ????
#define bswap_32(x) ((x >> 24) | (x & 0x00ff0000) >> 8 | (x & 0x0000ff00) << 8 | (x & 0x000000ff) << 24)
#define bswap_16(x) ((x >> 8) | (x & 0x00ff) << 8)
+#elif defined(__DragonFly__)
+#include <sys/endian.h>

View file

@ -1,13 +0,0 @@
$NetBSD: patch-af,v 1.1 2005/12/07 17:35:37 joerg Exp $
--- librioutil/cksum.c.orig 2005-12-07 17:21:36.000000000 +0000
+++ librioutil/cksum.c
@@ -29,6 +29,8 @@
#ifdef linux
#include <byteswap.h>
#include <endian.h>
+#elif defined(__DragonFly__)
+#include <sys/endian.h>
#elif defined(__FreeBSD__) || defined(__MacOSX__)
#include <machine/endian.h>
#else