Add tk-tkimg version 1.3.20080116
The IMG package by Jan Nijtmans provides the handling of several image formats beyond the standard formats in Tk. The formats supported by Img's are: * BMP * GIF (with transparency, but without LZW, due to patent restrictions) * ico * JPEG * pcx * pixmap * PNG * ppm * postscript * sgi * sun * tga * TIFF * window * XBM * XPM Provided by Emiliano Gavilán in PR pkg/38026.
This commit is contained in:
parent
7cc7f653cd
commit
1fe5f59a8a
8 changed files with 122 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.857 2019/10/28 10:43:57 kamil Exp $
|
||||
# $NetBSD: Makefile,v 1.858 2019/11/10 20:11:30 maya Exp $
|
||||
#
|
||||
|
||||
COMMENT= Graphics tools and libraries
|
||||
|
@ -758,6 +758,7 @@ SUBDIR+= tex-xypic
|
|||
SUBDIR+= tex-xypic-doc
|
||||
SUBDIR+= tgif
|
||||
SUBDIR+= tiff
|
||||
SUBDIR+= tk-tkimg
|
||||
SUBDIR+= tkpiechart
|
||||
SUBDIR+= tuxpaint
|
||||
SUBDIR+= tuxpaint-config
|
||||
|
|
19
graphics/tk-tkimg/DESCR
Normal file
19
graphics/tk-tkimg/DESCR
Normal file
|
@ -0,0 +1,19 @@
|
|||
The IMG package by Jan Nijtmans provides the handling
|
||||
of several image formats beyond the standard formats in Tk.
|
||||
The formats supported by Img's are:
|
||||
* BMP
|
||||
* GIF (with transparency, but without LZW, due to patent restrictions)
|
||||
* ico
|
||||
* JPEG
|
||||
* pcx
|
||||
* pixmap
|
||||
* PNG
|
||||
* ppm
|
||||
* postscript
|
||||
* sgi
|
||||
* sun
|
||||
* tga
|
||||
* TIFF
|
||||
* window
|
||||
* XBM
|
||||
* XPM
|
37
graphics/tk-tkimg/Makefile
Normal file
37
graphics/tk-tkimg/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# $NetBSD: Makefile,v 1.1 2019/11/10 20:11:30 maya Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tkimg-1.3-2008-01-16
|
||||
PKGNAME= tkimg-1.3.20080116
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.flightlab.com/~joe/downloads/
|
||||
|
||||
MAINTAINER= egavilan@eie.fceia.unr.edu.ar
|
||||
HOMEPAGE= http://www.flightlab.com/~joe/downloads/
|
||||
COMMENT= Add support for several image formats to Tk
|
||||
LICENSE= 2-clause-bsd # XXX ? Same as Tcl
|
||||
|
||||
WRKSRC= ${WRKDIR}/tkimg-1.3
|
||||
GNU_CONFIGURE= yes
|
||||
TEST_TARGET= test
|
||||
INSTALLATION_DIRS+= lib/Img1.3.9
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.if ${MACHINE_ARCH} == "sparc64"
|
||||
CONFIGURE_ARGS+= --enable-64bit-vis
|
||||
.else
|
||||
. for plat in ${LP64PLATFORMS}
|
||||
. if ${MACHINE_PLATFORM:M${plat}}
|
||||
CONFIGURE_ARGS+= --enable-64bit
|
||||
. endif
|
||||
. endfor
|
||||
.endif
|
||||
|
||||
.include "../../mk/dlopen.buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../mk/jpeg.buildlink3.mk"
|
||||
.include "../../graphics/tiff/buildlink3.mk"
|
||||
.include "../../x11/tk/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
graphics/tk-tkimg/PLIST
Normal file
3
graphics/tk-tkimg/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2019/11/10 20:11:30 maya Exp $
|
||||
lib/Img1.3.9/Img.so
|
||||
lib/Img1.3.9/pkgIndex.tcl
|
8
graphics/tk-tkimg/distinfo
Normal file
8
graphics/tk-tkimg/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2019/11/10 20:11:30 maya Exp $
|
||||
|
||||
SHA1 (tkimg-1.3-2008-01-16.tar.gz) = 524d497c6b078906f131378d964cfa2fadbe2d46
|
||||
RMD160 (tkimg-1.3-2008-01-16.tar.gz) = 0cdfdd306a6b396591dd98567723c6a7e9a52350
|
||||
SHA512 (tkimg-1.3-2008-01-16.tar.gz) = 7746e94a8de7c4c2bc41cbe7d805669b4161fdecb656b825c44104bc78af6e4c3c9119bdfdde04feb76f4c8bde45e68f5176d5b114a4ef6c860d570046bc8ffb
|
||||
Size (tkimg-1.3-2008-01-16.tar.gz) = 363107 bytes
|
||||
SHA1 (patch-Makefile.in) = c757bb9a8517fe21d48d672bae9e7def08954bc0
|
||||
SHA1 (patch-tkimg.h) = e97be13c3d424fa56bfc1d1181efa1ca9cbca7d0
|
21
graphics/tk-tkimg/options.mk
Normal file
21
graphics/tk-tkimg/options.mk
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: options.mk,v 1.1 2019/11/10 20:11:30 maya Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.tk-tkimg
|
||||
PKG_SUPPORTED_OPTIONS= debug x11
|
||||
PKG_SUGGESTED_OPTIONS+= # blank
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mdebug)
|
||||
CONFIGURE_ARGS+= --enable-symbols
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-symbols
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-x --x-includes=${X11BASE}/include
|
||||
CONFIGURE_ARGS+= --x-libraries=${X11BASE}/lib
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-x
|
||||
.endif
|
17
graphics/tk-tkimg/patches/patch-Makefile.in
Normal file
17
graphics/tk-tkimg/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1 2019/11/10 20:11:30 maya Exp $
|
||||
|
||||
Fix INSTALL_*.
|
||||
|
||||
--- Makefile.in.orig 2005-01-10 23:31:59.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -178,8 +178,8 @@ $(DESTDIR)$(pkglibdir):
|
||||
mkdir -p $(DESTDIR)$(pkglibdir)
|
||||
|
||||
install-package: package $(DESTDIR)$(pkglibdir)
|
||||
- $(INSTALL_DATA) $(PKG_LIB_FILE) $(DESTDIR)$(pkglibdir)/$(PKG_LIB_FILE)
|
||||
- $(INSTALL_DATA) pkgIndex.tcl $(DESTDIR)$(pkglibdir)/$(pkgIndex.tcl)
|
||||
+ $(BSD_INSTALL_LIB) $(PKG_LIB_FILE) $(DESTDIR)$(pkglibdir)/$(PKG_LIB_FILE)
|
||||
+ $(BSD_INSTALL_DATA) pkgIndex.tcl $(DESTDIR)$(pkglibdir)/$(pkgIndex.tcl)
|
||||
|
||||
## Maintain stuff section.
|
||||
#
|
15
graphics/tk-tkimg/patches/patch-tkimg.h
Normal file
15
graphics/tk-tkimg/patches/patch-tkimg.h
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-tkimg.h,v 1.1 2019/11/10 20:11:30 maya Exp $
|
||||
|
||||
Revert version update to make the tests work.
|
||||
|
||||
--- tkimg.h.orig 2005-01-24 19:08:06.000000000 +0000
|
||||
+++ tkimg.h
|
||||
@@ -8,7 +8,7 @@
|
||||
|
||||
#include "tk.h"
|
||||
|
||||
-#define TKIMG_VERSION "1.3.99"
|
||||
+#define TKIMG_VERSION "1.3.9"
|
||||
|
||||
#if BUILD_tkimg
|
||||
# define TKIMGAPI DLLEXPORT
|
Loading…
Reference in a new issue