Fix build on SunOS.
This commit is contained in:
parent
cbabfe9851
commit
2008c87987
5 changed files with 26 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.8 2012/01/24 23:21:23 marino Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2012/02/15 19:46:30 hans Exp $
|
||||
#
|
||||
|
||||
DISTNAME= alsa-utils-1.0.22
|
||||
|
@ -17,6 +17,7 @@ USE_TOOLS= pkg-config gmake bash:run
|
|||
USE_PKGLOCALEDIR= yes
|
||||
USE_NCURSES= yes
|
||||
LDFLAGS.DragonFly= -lm
|
||||
LDFLAGS.SunOS+= -lm -lsocket -lnsl
|
||||
|
||||
REPLACE_BASH= alsaconf/alsaconf.in
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/02/16 18:28:01 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/02/15 19:46:30 hans Exp $
|
||||
|
||||
SHA1 (alsa-utils-1.0.22.tar.bz2) = 3587dc19d9a60ab9bb2bfe2d23491230eae99fe1
|
||||
RMD160 (alsa-utils-1.0.22.tar.bz2) = f9f9c3cc81e9c0d97fd62c3f91424a8f117ca6c3
|
||||
Size (alsa-utils-1.0.22.tar.bz2) = 1075216 bytes
|
||||
SHA1 (patch-aa) = d44e1fb7a27a8002425c90ce00e5f5970e1a1265
|
||||
SHA1 (patch-ab) = b899128edb57bdb3a8b8186b6dd69182a7c1932f
|
||||
SHA1 (patch-ac) = 613414c9683255e1a9ed6c32187a220b151beea2
|
||||
SHA1 (patch-ad) = 0c287dba62636778edab76d977f230626803e5ba
|
||||
SHA1 (patch-ab) = b87bac423c243e7c0dabf1e99cd16ae10f637c31
|
||||
SHA1 (patch-ac) = 5f13043e6f7864bb88b13f0123ce8114995db8be
|
||||
SHA1 (patch-ad) = 1bbc726d59c2aa6b3361a6687c4770e6ffe86660
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.2 2008/12/30 14:44:14 hasso Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2012/02/15 19:46:31 hans Exp $
|
||||
|
||||
--- aplay/aplay.c.orig 2008-12-18 22:21:06.000000000 -0500
|
||||
+++ aplay/aplay.c
|
||||
|
@ -14,7 +14,7 @@ $NetBSD: patch-ab,v 1.2 2008/12/30 14:44:14 hasso Exp $
|
|||
#include "aconfig.h"
|
||||
#include "gettext.h"
|
||||
#include "formats.h"
|
||||
@@ -55,6 +59,17 @@
|
||||
@@ -55,6 +59,22 @@
|
||||
#define LLONG_MAX 9223372036854775807LL
|
||||
#endif
|
||||
|
||||
|
@ -27,6 +27,11 @@ $NetBSD: patch-ab,v 1.2 2008/12/30 14:44:14 hasso Exp $
|
|||
+#define __le32_to_cpu le32toh
|
||||
+#define __be16_to_cpu be16toh
|
||||
+#define __be32_to_cpu be32toh
|
||||
+#elif defined(__sun)
|
||||
+#define __le16_to_cpu LE_16
|
||||
+#define __le32_to_cpu LE_32
|
||||
+#define __be16_to_cpu BE_16
|
||||
+#define __be32_to_cpu BE_32
|
||||
+#endif
|
||||
+
|
||||
#define DEFAULT_FORMAT SND_PCM_FORMAT_U8
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.2 2008/12/30 14:44:14 hasso Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2012/02/15 19:46:31 hans Exp $
|
||||
|
||||
--- aplay/formats.h.orig 2008-12-18 22:21:49.000000000 -0500
|
||||
+++ aplay/formats.h
|
||||
@@ -1,8 +1,15 @@
|
||||
@@ -1,8 +1,20 @@
|
||||
#ifndef FORMATS_H
|
||||
#define FORMATS_H 1
|
||||
|
||||
|
@ -11,6 +11,11 @@ $NetBSD: patch-ac,v 1.2 2008/12/30 14:44:14 hasso Exp $
|
|||
+#define bswap_16 bswap16
|
||||
+#define bswap_32 bswap32
|
||||
+#define bswap_64 bswap64
|
||||
+#elif defined(__sun)
|
||||
+#include <sys/byteorder.h>
|
||||
+#define bswap_16 BSWAP_16
|
||||
+#define bswap_32 BSWAP_32
|
||||
+#define bswap_64 BSWAP_64
|
||||
+#else
|
||||
#include <endian.h>
|
||||
#include <byteswap.h>
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.4 2010/02/16 18:28:01 wiz Exp $
|
||||
$NetBSD: patch-ad,v 1.5 2012/02/15 19:46:31 hans Exp $
|
||||
|
||||
--- speaker-test/speaker-test.c.orig 2009-12-16 15:18:52.000000000 +0000
|
||||
+++ speaker-test/speaker-test.c
|
||||
@@ -44,7 +44,14 @@
|
||||
@@ -44,7 +44,18 @@
|
||||
#include <getopt.h>
|
||||
#include <inttypes.h>
|
||||
#include <ctype.h>
|
||||
|
@ -11,6 +11,10 @@ $NetBSD: patch-ad,v 1.4 2010/02/16 18:28:01 wiz Exp $
|
|||
+#define bswap_16 bswap16
|
||||
+#define bswap_32 bswap32
|
||||
+#define ESTRPIPE EPIPE
|
||||
+#elif defined(__sun)
|
||||
+#include <sys/byteorder.h>
|
||||
+#define bswap_16 BSWAP_16
|
||||
+#define bswap_32 BSWAP_32
|
||||
+#else
|
||||
#include <byteswap.h>
|
||||
+#endif
|
||||
|
|
Loading…
Reference in a new issue