Update to 1.0:
MuPDF 1.0 (2012-04-24) The 1.0 release is here! MuPDF 1.0 RC1 (2012-03-29) The 1.0 release rapidly approaches! This version brings with it a whole host of features, including: Removal of all global variables: we now pass a context pointer through the code freeing us from the use of globals within the library. Multi-threaded operation: while MuPDF does not require a thread library, hooks are in place so that if one is used, significant speedups can be gained from using multiple cores to render. New error handling: a portable exception-like system is used to allow neater handling of errors. This leads to more stability and better resilience to broken files. Public/Private API: the API has undergone a significant revision (required by some of the above changes, plus renaming/revising for clarity and consistency), and has been split into public and private headers. The plan is that the public portion of the API should remain much more static in future. Improved Text Extraction device: a cleaner API to the experimental text extraction device, offering a list of styles, and more cleanly delineated content. Documentation: All public header entry points/structures are now documented and overviews of how to call the library to render pages both in single and multi-threaded mode are given. A new scavenging memory manager; makes much better use of the memory available by freeing cached items 'just in time'. Many, many, bugfixes. This is such a large and significant version that we're doing a release candidate first to allow us to correct any obvious bugs that are found. Please try it and let us know how you get on!
This commit is contained in:
parent
f22bdff36f
commit
2009bd8f62
5 changed files with 82 additions and 87 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.11 2012/03/24 13:31:58 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2012/06/03 22:03:24 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= mupdf-0.9-source
|
||||
PKGNAME= mupdf-0.9
|
||||
DISTNAME= mupdf-1.0-source
|
||||
PKGNAME= ${DISTNAME:S/-source//}
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://ccxvii.net/mupdf/download/ \
|
||||
http://ccxvii.net/mupdf/download/archive/
|
||||
|
@ -12,7 +12,6 @@ HOMEPAGE= http://mupdf.com/
|
|||
COMMENT= Lightweight PDF viewer and toolkit
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
WRKSRC= ${WRKDIR}/mupdf-0.9
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_TOOLS+= pkg-config gmake
|
||||
|
@ -21,12 +20,9 @@ USE_LIBTOOL= yes
|
|||
|
||||
INSTALLATION_DIRS+= bin include lib/pkgconfig
|
||||
INSTALL_MAKE_FLAGS+= prefix=${DESTDIR}${PREFIX}
|
||||
LDFLAGS= -Wl,-rpath,${X11BASE}/lib
|
||||
LDFLAGS= ${COMPILER_RPATH_FLAG}${X11BASE}/lib
|
||||
MAKE_FLAGS+= LDFLAGS=${LDFLAGS:Q}
|
||||
|
||||
pre-build:
|
||||
${MV} ${WRKSRC}/apps/pdfinfo.c ${WRKSRC}/apps/mupdf-pdfinfo.c
|
||||
|
||||
post-build:
|
||||
sed -e "s,@PREFIX@,${PREFIX}," ${FILESDIR}/mupdf.pc > ${WRKSRC}/mupdf.pc
|
||||
|
||||
|
|
|
@ -1,19 +1,18 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2012/03/24 13:31:58 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2012/06/03 22:03:24 wiz Exp $
|
||||
bin/mudraw
|
||||
bin/mupdf
|
||||
bin/mupdf-pdfinfo
|
||||
bin/pdfclean
|
||||
bin/pdfdraw
|
||||
bin/pdfextract
|
||||
bin/pdfshow
|
||||
bin/xpsdraw
|
||||
bin/mupdfclean
|
||||
bin/mupdfextract
|
||||
bin/mupdfinfo
|
||||
bin/mupdfshow
|
||||
include/fitz.h
|
||||
include/memento.h
|
||||
include/mucbz.h
|
||||
include/mupdf.h
|
||||
include/muxps.h
|
||||
lib/libfitz.la
|
||||
lib/libmupdf.la
|
||||
lib/libmuxps.la
|
||||
lib/pkgconfig/mupdf.pc
|
||||
man/man1/mudraw.1
|
||||
man/man1/mupdf.1
|
||||
man/man1/pdfclean.1
|
||||
man/man1/pdfdraw.1
|
||||
man/man1/pdfshow.1
|
||||
man/man1/mupdfclean.1
|
||||
man/man1/mupdfshow.1
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2012/03/24 13:31:58 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.7 2012/06/03 22:03:24 wiz Exp $
|
||||
|
||||
SHA1 (mupdf-0.9-source.tar.gz) = 3a3ba42d19e3211199110e7c782263241cdea8a0
|
||||
RMD160 (mupdf-0.9-source.tar.gz) = 9ba1df205f9f95c7ff4b0a3be224786ad5a65d99
|
||||
Size (mupdf-0.9-source.tar.gz) = 3917075 bytes
|
||||
SHA1 (patch-ab) = 0c296311e6273ed9542e2758f4891a4a2d42a383
|
||||
SHA1 (patch-ac) = 4197e032f084acf09eed21a17e311712afa6cc68
|
||||
SHA1 (mupdf-1.0-source.tar.gz) = c5c4496836cdd4bdf7b2d2344ec045c9508e49e4
|
||||
RMD160 (mupdf-1.0-source.tar.gz) = 7820cf68552d64c52c7d08cdcf5a1965df39bd42
|
||||
Size (mupdf-1.0-source.tar.gz) = 4208530 bytes
|
||||
SHA1 (patch-ab) = daf909badabc04b9da8d386ecc7d4ac124b39903
|
||||
SHA1 (patch-ac) = a832241dc6166091a0a119ac1579348393988b58
|
||||
SHA1 (patch-ae) = d4e5dcee67de682e38bf537d5b93948135af5dd7
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.2 2012/03/24 13:31:58 drochner Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2012/06/03 22:03:24 wiz Exp $
|
||||
|
||||
--- Makerules.orig 2011-09-05 11:55:39.000000000 +0000
|
||||
--- Makerules.orig 2012-04-24 16:41:33.000000000 +0000
|
||||
+++ Makerules
|
||||
@@ -18,31 +18,8 @@ else
|
||||
@@ -20,32 +20,8 @@ else
|
||||
$(error unknown build setting: '$(build)')
|
||||
endif
|
||||
|
||||
|
@ -22,6 +22,7 @@ $NetBSD: patch-ab,v 1.2 2012/03/24 13:31:58 drochner Exp $
|
|||
-SYS_FREETYPE_INC := -I/usr/X11R6/include/freetype2
|
||||
-CFLAGS += -I/usr/X11R6/include
|
||||
-LDFLAGS += -L/usr/X11R6/lib
|
||||
-RANLIB_CMD = ranlib $@
|
||||
-X11_LIBS := -lX11 -lXext
|
||||
-ifeq "$(arch)" "amd64"
|
||||
-CFLAGS += -m64
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.3 2012/03/24 13:31:58 drochner Exp $
|
||||
$NetBSD: patch-ac,v 1.4 2012/06/03 22:03:24 wiz Exp $
|
||||
|
||||
--- Makefile.orig 2011-09-05 11:55:39.000000000 +0000
|
||||
--- Makefile.orig 2012-04-24 16:41:33.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -21,17 +21,9 @@ THIRD_LIBS += $(JPEG_LIB)
|
||||
@@ -24,17 +24,9 @@ THIRD_LIBS += $(JPEG_LIB)
|
||||
THIRD_LIBS += $(OPENJPEG_LIB)
|
||||
THIRD_LIBS += $(ZLIB_LIB)
|
||||
|
||||
|
@ -14,77 +14,76 @@ $NetBSD: patch-ac,v 1.3 2012/03/24 13:31:58 drochner Exp $
|
|||
-QUIET_MKDIR = @ echo ' ' ' ' MKDIR $@ ;
|
||||
-endif
|
||||
-
|
||||
CC_CMD = $(QUIET_CC) $(CC) $(CFLAGS) -o $@ -c $<
|
||||
-CC_CMD = $(QUIET_CC) $(CC) $(CFLAGS) -o $@ -c $<
|
||||
-AR_CMD = $(QUIET_AR) $(AR) cru $@ $^
|
||||
-LINK_CMD = $(QUIET_LINK) $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
|
||||
+CC_CMD = ${LIBTOOL} --mode=compile $(CC) $(CFLAGS) -o $@ -c $<
|
||||
+AR_CMD = ${LIBTOOL} --mode=link $(CC) -o $@ -version-info 0:0:0 -rpath ${PREFIX}/lib $^
|
||||
+LINK_CMD = ${LIBTOOL} --mode=link $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
|
||||
MKDIR_CMD = $(QUIET_MKDIR) mkdir -p $@
|
||||
|
||||
# --- Rules ---
|
||||
@@ -39,40 +31,40 @@ MKDIR_CMD = $(QUIET_MKDIR) mkdir -p $@
|
||||
@@ -47,33 +39,32 @@ MUCBZ_HDR := $(FITZ_HDR) cbz/mucbz.h
|
||||
$(OUT) $(GEN) :
|
||||
$(MKDIR_CMD)
|
||||
|
||||
-$(OUT)/%.a :
|
||||
+$(OUT)/%.la :
|
||||
$(AR_CMD)
|
||||
- $(RANLIB_CMD)
|
||||
|
||||
-$(OUT)/% : $(OUT)/%.o
|
||||
+$(OUT)/% : $(OUT)/%.lo
|
||||
$(LINK_CMD)
|
||||
|
||||
-$(OUT)/%.o : fitz/%.c fitz/fitz.h | $(OUT)
|
||||
- $(CC_CMD)
|
||||
-$(OUT)/%.o : draw/%.c fitz/fitz.h | $(OUT)
|
||||
- $(CC_CMD)
|
||||
-$(OUT)/%.o : pdf/%.c fitz/fitz.h pdf/mupdf.h | $(OUT)
|
||||
- $(CC_CMD)
|
||||
-$(OUT)/%.o : xps/%.c fitz/fitz.h xps/muxps.h | $(OUT)
|
||||
- $(CC_CMD)
|
||||
-$(OUT)/%.o : apps/%.c fitz/fitz.h pdf/mupdf.h xps/muxps.h | $(OUT)
|
||||
- $(CC_CMD)
|
||||
-$(OUT)/%.o : fitz/%.c $(FITZ_HDR) | $(OUT)
|
||||
+$(OUT)/%.lo : fitz/%.c $(FITZ_HDR) | $(OUT)
|
||||
$(CC_CMD)
|
||||
-$(OUT)/%.o : draw/%.c $(FITZ_HDR) | $(OUT)
|
||||
+$(OUT)/%.lo : draw/%.c $(FITZ_HDR) | $(OUT)
|
||||
$(CC_CMD)
|
||||
-$(OUT)/%.o : pdf/%.c $(MUPDF_HDR) | $(OUT)
|
||||
+$(OUT)/%.lo : pdf/%.c $(MUPDF_HDR) | $(OUT)
|
||||
$(CC_CMD)
|
||||
-$(OUT)/%.o : xps/%.c $(MUXPS_HDR) | $(OUT)
|
||||
+$(OUT)/%.lo : xps/%.c $(MUXPS_HDR) | $(OUT)
|
||||
$(CC_CMD)
|
||||
-$(OUT)/%.o : cbz/%.c $(MUCBZ_HDR) | $(OUT)
|
||||
+$(OUT)/%.lo : cbz/%.c $(MUCBZ_HDR) | $(OUT)
|
||||
$(CC_CMD)
|
||||
-$(OUT)/%.o : apps/%.c fitz/fitz.h pdf/mupdf.h xps/muxps.h cbz/mucbz.h | $(OUT)
|
||||
+$(OUT)/%.lo : apps/%.c fitz/fitz.h pdf/mupdf.h xps/muxps.h cbz/mucbz.h | $(OUT)
|
||||
$(CC_CMD)
|
||||
-$(OUT)/%.o : scripts/%.c | $(OUT)
|
||||
- $(CC_CMD)
|
||||
+$(OUT)/%.lo : fitz/%.c fitz/fitz.h | $(OUT)
|
||||
+ libtool --mode=compile $(CC_CMD)
|
||||
+$(OUT)/%.lo : draw/%.c fitz/fitz.h | $(OUT)
|
||||
+ libtool --mode=compile $(CC_CMD)
|
||||
+$(OUT)/%.lo : pdf/%.c fitz/fitz.h pdf/mupdf.h | $(OUT)
|
||||
+ libtool --mode=compile $(CC_CMD)
|
||||
+$(OUT)/%.lo : xps/%.c fitz/fitz.h xps/muxps.h | $(OUT)
|
||||
+ libtool --mode=compile $(CC_CMD)
|
||||
+$(OUT)/%.lo : apps/%.c fitz/fitz.h pdf/mupdf.h xps/muxps.h | $(OUT)
|
||||
+ libtool --mode=compile $(CC_CMD)
|
||||
+$(OUT)/%.lo : scripts/%.c | $(OUT)
|
||||
+ libtool --mode=compile $(CC_CMD)
|
||||
$(CC_CMD)
|
||||
|
||||
-.PRECIOUS : $(OUT)/%.o # Keep intermediates from chained rules
|
||||
+.PRECIOUS : $(OUT)/%.lo # Keep intermediates from chained rules
|
||||
|
||||
# --- Fitz, MuPDF and MuXPS libraries ---
|
||||
# --- Fitz, MuPDF, MuXPS and MuCBZ library ---
|
||||
|
||||
-FITZ_LIB := $(OUT)/libfitz.a
|
||||
-MUPDF_LIB := $(OUT)/libmupdf.a
|
||||
-MUXPS_LIB := $(OUT)/libmuxps.a
|
||||
+FITZ_LIB := $(OUT)/libfitz.la
|
||||
+MUPDF_LIB := $(OUT)/libmupdf.la
|
||||
+MUXPS_LIB := $(OUT)/libmuxps.la
|
||||
|
||||
FITZ_SRC := $(notdir $(wildcard fitz/*.c draw/*.c))
|
||||
MUPDF_SRC := $(notdir $(wildcard pdf/*.c))
|
||||
FITZ_SRC := $(filter-out draw_simple_scale.c, $(FITZ_SRC))
|
||||
@@ -81,10 +72,10 @@ MUPDF_SRC := $(notdir $(wildcard pdf/*.c
|
||||
MUXPS_SRC := $(notdir $(wildcard xps/*.c))
|
||||
MUCBZ_SRC := $(notdir $(wildcard cbz/*.c))
|
||||
|
||||
-$(FITZ_LIB) : $(addprefix $(OUT)/, $(FITZ_SRC:%.c=%.o))
|
||||
-$(MUPDF_LIB) : $(addprefix $(OUT)/, $(MUPDF_SRC:%.c=%.o))
|
||||
-$(MUXPS_LIB) : $(addprefix $(OUT)/, $(MUXPS_SRC:%.c=%.o))
|
||||
-$(FITZ_LIB) : $(addprefix $(OUT)/, $(MUPDF_SRC:%.c=%.o))
|
||||
-$(FITZ_LIB) : $(addprefix $(OUT)/, $(MUXPS_SRC:%.c=%.o))
|
||||
-$(FITZ_LIB) : $(addprefix $(OUT)/, $(MUCBZ_SRC:%.c=%.o))
|
||||
+$(FITZ_LIB) : $(addprefix $(OUT)/, $(FITZ_SRC:%.c=%.lo))
|
||||
+$(MUPDF_LIB) : $(addprefix $(OUT)/, $(MUPDF_SRC:%.c=%.lo))
|
||||
+$(MUXPS_LIB) : $(addprefix $(OUT)/, $(MUXPS_SRC:%.c=%.lo))
|
||||
+$(FITZ_LIB) : $(addprefix $(OUT)/, $(MUPDF_SRC:%.c=%.lo))
|
||||
+$(FITZ_LIB) : $(addprefix $(OUT)/, $(MUXPS_SRC:%.c=%.lo))
|
||||
+$(FITZ_LIB) : $(addprefix $(OUT)/, $(MUCBZ_SRC:%.c=%.lo))
|
||||
|
||||
libs: $(MUXPS_LIB) $(MUPDF_LIB) $(FITZ_LIB) $(THIRD_LIBS)
|
||||
@ echo MuPDF/XPS and underlying libraries built
|
||||
@@ -116,13 +108,13 @@ endif
|
||||
libs: $(FITZ_LIB) $(THIRD_LIBS)
|
||||
|
||||
@@ -127,9 +118,9 @@ endif
|
||||
|
||||
generate: $(CMAP_HDR) $(FONT_HDR)
|
||||
|
||||
|
@ -97,40 +96,40 @@ $NetBSD: patch-ac,v 1.3 2012/03/24 13:31:58 drochner Exp $
|
|||
|
||||
# --- Tools and Apps ---
|
||||
|
||||
-PDF_APPS := $(addprefix $(OUT)/, pdfdraw pdfclean pdfextract pdfinfo pdfshow)
|
||||
+PDF_APPS := $(addprefix $(OUT)/, pdfdraw pdfclean pdfextract mupdf-pdfinfo pdfshow)
|
||||
XPS_APPS := $(addprefix $(OUT)/, xpsdraw)
|
||||
@@ -139,13 +130,13 @@ $(MU_APPS) : $(FITZ_LIB) $(THIRD_LIBS)
|
||||
|
||||
BUSY_SRC := $(notdir $(wildcard apps/mubusy_*.c))
|
||||
BUSY_APP := $(addprefix $(OUT)/, mubusy)
|
||||
-$(BUSY_APP) : $(addprefix $(OUT)/, $(BUSY_SRC:%.c=%.o))
|
||||
+$(BUSY_APP) : $(addprefix $(OUT)/, $(BUSY_SRC:%.c=%.lo))
|
||||
$(BUSY_APP) : $(FITZ_LIB) $(THIRD_LIBS)
|
||||
|
||||
$(PDF_APPS) : $(MUPDF_LIB) $(FITZ_LIB) $(THIRD_LIBS)
|
||||
@@ -131,7 +123,7 @@ $(XPS_APPS) : $(MUXPS_LIB) $(FITZ_LIB) $
|
||||
MUPDF := $(OUT)/mupdf
|
||||
$(MUPDF) : $(MUXPS_LIB) $(MUPDF_LIB) $(FITZ_LIB) $(THIRD_LIBS)
|
||||
ifeq "$(NOX11)" ""
|
||||
MUPDF := $(OUT)/mupdf
|
||||
$(MUPDF) : $(FITZ_LIB) $(THIRD_LIBS)
|
||||
-$(MUPDF) : $(addprefix $(OUT)/, x11_main.o x11_image.o pdfapp.o)
|
||||
+$(MUPDF) : $(addprefix $(OUT)/, x11_main.lo x11_image.lo pdfapp.lo)
|
||||
$(LINK_CMD) $(X11_LIBS)
|
||||
endif
|
||||
|
||||
@@ -141,14 +133,18 @@ prefix ?= /usr/local
|
||||
@@ -165,14 +156,16 @@ prefix ?= /usr/local
|
||||
bindir ?= $(prefix)/bin
|
||||
libdir ?= $(prefix)/lib
|
||||
incdir ?= $(prefix)/include
|
||||
-mandir ?= $(prefix)/share/man
|
||||
+mandir ?= $(prefix)/man
|
||||
|
||||
install: $(MUXPS_LIB) $(MUPDF_LIB) $(FITZ_LIB) $(PDF_APPS) $(XPS_APPS) $(MUPDF)
|
||||
install: $(FITZ_LIB) $(MU_APPS) $(MUPDF)
|
||||
- install -d $(bindir) $(libdir) $(incdir) $(mandir)/man1
|
||||
- install $(MUXPS_LIB) $(MUPDF_LIB) $(FITZ_LIB) $(libdir)
|
||||
- install fitz/fitz.h pdf/mupdf.h xps/muxps.h $(incdir)
|
||||
- install $(PDF_APPS) $(XPS_APPS) $(MUPDF) $(bindir)
|
||||
- install $(FITZ_LIB) $(libdir)
|
||||
- install fitz/memento.h fitz/fitz.h pdf/mupdf.h xps/muxps.h cbz/mucbz.h $(incdir)
|
||||
- install $(MU_APPS) $(MUPDF) $(bindir)
|
||||
- install $(wildcard apps/man/*.1) $(mandir)/man1
|
||||
+ ${BSD_INSTALL_DATA_DIR} $(bindir) $(libdir) $(incdir) $(mandir)/man1
|
||||
+ for f in $(MUXPS_LIB) $(MUPDF_LIB) $(FITZ_LIB); do \
|
||||
+ libtool --mode=install ${BSD_INSTALL_LIB} $$f $(libdir); \
|
||||
+ done
|
||||
+ ${BSD_INSTALL_DATA} fitz/fitz.h pdf/mupdf.h xps/muxps.h $(incdir)
|
||||
+ for f in $(PDF_APPS) $(XPS_APPS) $(MUPDF); do \
|
||||
+ libtool --mode=install ${BSD_INSTALL_PROGRAM} $$f $(bindir); \
|
||||
+ libtool --mode=install ${BSD_INSTALL_LIB} $(FITZ_LIB) $(libdir)
|
||||
+ ${BSD_INSTALL_DATA} fitz/memento.h fitz/fitz.h pdf/mupdf.h xps/muxps.h cbz/mucbz.h $(incdir)
|
||||
+ for f in $(MU_APPS) $(MUPDF); do \
|
||||
+ libtool --mode=install ${BSD_INSTALL_PROGRAM} $$f $(bindir); \
|
||||
+ done
|
||||
+ ${BSD_INSTALL_DATA} $(wildcard apps/man/*.1) $(mandir)/man1
|
||||
|
||||
|
|
Loading…
Reference in a new issue