Fix two problem noted on tech-pkg-ja mailing list.

- Remove Windows specific (and slightly broken) patch file;
  chasen-2.3.3.20030822.patch, originally noted by Makoto Fujiwara.
- Fix crash with SEGV when using "%r" output format, noted by Akio Obata.

Bump PKGREVISION.
This commit is contained in:
taca 2005-08-18 15:37:17 +00:00
parent 7db277aead
commit 2059300631
3 changed files with 21 additions and 8 deletions

View file

@ -1,15 +1,14 @@
# $NetBSD: Makefile,v 1.11 2005/04/11 21:47:33 tv Exp $
# $NetBSD: Makefile,v 1.12 2005/08/18 15:37:17 taca Exp $
#
DISTNAME= chasen-${CHASEN_VERSION}
PKGNAME= chasen-base-${CHASEN_VERSION}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= japanese textproc
MASTER_SITES= http://chasen.aist-nara.ac.jp/stable/chasen/
PATCHFILES= chasen-2.3.3.20030821.patch \
chasen-2.3.3.20030822.patch \
chasen-2.3.3.20031024.patch
chasen-2.3.3.20030822.patch
PATCH_SITES= ${MASTER_SITES}
MAINTAINER= tech-pkg-ja@jp.NetBSD.org

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2005/02/24 14:48:40 agc Exp $
$NetBSD: distinfo,v 1.7 2005/08/18 15:37:17 taca Exp $
SHA1 (chasen-2.3.3.tar.gz) = 711f5717ee284d26aa5616292f7aaffaef11d03a
RMD160 (chasen-2.3.3.tar.gz) = 2f2416f82fb0341023314a4672e442fed86207a9
@ -9,12 +9,10 @@ Size (chasen-2.3.3.20030821.patch) = 3496 bytes
SHA1 (chasen-2.3.3.20030822.patch) = 0728884dcdf6983a3e32774111e7996a43008722
RMD160 (chasen-2.3.3.20030822.patch) = 30c2ff84ad8b68271fcd7656d9972e7392a806f5
Size (chasen-2.3.3.20030822.patch) = 2007 bytes
SHA1 (chasen-2.3.3.20031024.patch) = e53446124c219a883d39f627b243c1ebc241dfd8
RMD160 (chasen-2.3.3.20031024.patch) = 4e22c03a8b5299957fd39ae12569aeb9bcf1d127
Size (chasen-2.3.3.20031024.patch) = 1095 bytes
SHA1 (patch-ai) = 7a9ffd640c275c1361e34591d08c1ce519df5dc7
SHA1 (patch-aj) = 8c440610abaa31b22950ef41149736feefc968e8
SHA1 (patch-ak) = 05afdb444ef6a59cb2f9c86617b6dba8332ac5f3
SHA1 (patch-al) = a1069b648d7c352923dd27a193f93b87b4bf3e8a
SHA1 (patch-am) = 25965ca10b35e564cd0358a1949c7a90a8596b55
SHA1 (patch-an) = e24d8cb3f1ffa9b2b601b417e94f5eb533782aa5
SHA1 (patch-ao) = 0d8c9f054393bef86c0a4c12fac92bc6ff696c2b

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ao,v 1.1 2005/08/18 15:37:17 taca Exp $
--- lib/print.c.orig 2005-08-15 10:50:12.000000000 +0900
+++ lib/print.c
@@ -326,6 +326,11 @@ set_ruby(char *dest, char *midasi, char
int stat = 0;
int plen, maxplen = 0;
+ if (yomi[0] == '\0') {
+ strcpy(d, m);
+ return;
+ }
+
for (;;) {
for (; *y; y += cha_tok_mblen(Cha_tokenizer, y, 4 /* XXX */)) {
if (stat == 0) {