Add DragonFly support. Honour CXXFLAGS. Add _DRAGONFLY_SOURCE on

DragonFly to work around the _POSIX_SOURCE defines, which break
cwchar's ::vfwprintf usage (aka ISO C99 extensions).
This commit is contained in:
joerg 2006-03-01 00:33:30 +00:00
parent bbc97ad3db
commit 20b65ea5c3
12 changed files with 190 additions and 9 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2006/02/14 01:04:32 rillig Exp $
# $NetBSD: Makefile,v 1.3 2006/03/01 00:33:30 joerg Exp $
DISTNAME= Botan-1.4.11
PKGNAME= botan-1.4.11
@ -20,5 +20,13 @@ CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
MAKE_FLAGS+= INSTALL_CMD_EXEC=${INSTALL_PROGRAM:Q}
MAKE_FLAGS+= INSTALL_CMD_DATA=${INSTALL_DATA:Q}
MAKE_FLAGS+= LIB_OPT=${CXXFLAGS:Q}
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "DragonFly"
CXXFLAGS+= -D_DRAGONFLY_SOURCE
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST.DragonFly,v 1.1 2006/03/01 00:33:30 joerg Exp $
include/botan/es_ftw.h

View file

@ -1,7 +1,15 @@
$NetBSD: distinfo,v 1.2 2006/02/05 01:30:55 rillig Exp $
$NetBSD: distinfo,v 1.3 2006/03/01 00:33:30 joerg Exp $
SHA1 (Botan-1.4.11.tbz) = 508605c1debaae78db201afb6c87fa93c25e4432
RMD160 (Botan-1.4.11.tbz) = bafca4a73f6acbf4f1bb3f2cb35727e2ebdce3d4
Size (Botan-1.4.11.tbz) = 1660829 bytes
SHA1 (patch-aa) = cb5632f73ff5ee99bce0ae066d24e31f8877c0e9
SHA1 (patch-aa) = 5b39d48f201c40fea5f3c1b7b2c801506189bed0
SHA1 (patch-ab) = 478d91bce78f484fb8ba2d23ceecb462728b29db
SHA1 (patch-ac) = 0981448664141b3effaf3e88f5f2317d70ebc786
SHA1 (patch-ad) = feff04fc7383bb86df12e187a5788a0b867c47d7
SHA1 (patch-ae) = 658808ae00b2a35d649a62578e400e840ab9e0a8
SHA1 (patch-af) = 5ed516dd5a746ed94447e880c2f07fc50d8230a8
SHA1 (patch-ag) = 8e847a4159ef99d28ec57cf4643d7ecacb8ba353
SHA1 (patch-ah) = ff07d2f7b921feb64430351192cc9315452d0687
SHA1 (patch-ai) = f7f79ccf61ddbd868a317a63e1d8a377a13ce160
SHA1 (patch-aj) = f842e4a39eddd517312a9f7ae57391e330c48a3f

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.2 2006/02/05 01:30:55 rillig Exp $
$NetBSD: patch-aa,v 1.3 2006/03/01 00:33:30 joerg Exp $
--- configure.pl.orig 2006-01-01 02:02:28.000000000 +0100
+++ configure.pl 2006-02-05 01:59:57.000000000 +0100
--- configure.pl.orig 2006-01-01 01:02:28.000000000 +0000
+++ configure.pl
@@ -74,7 +74,6 @@ my %DOCS = (
'deprecated.txt' => $DOC_DIR,
'license.txt' => $DOC_DIR,
@ -10,7 +10,66 @@ $NetBSD: patch-aa,v 1.2 2006/02/05 01:30:55 rillig Exp $
'thanks.txt' => $DOC_DIR,
'todo.txt' => $DOC_DIR
);
@@ -1696,12 +1695,6 @@ sub guess_triple
@@ -278,6 +277,7 @@ my %OS_SUPPORTS_ARCH = (
'darwin' => [ 'ia32', 'ppc', 'ppc64', ],
'freebsd' => [ 'alpha', 'amd64', 'ia32', 'ia64', 'powerpc', 'sparc64',
],
+ 'dragonfly' => [ 'amd64', 'ia32', 'ia64' ],
'hpux' => [ 'hppa', 'ia64', ],
'irix' => [ 'mips32', 'mips64', ],
'linux' => [ 'alpha', 'amd64', 'arm', 'hppa', 'ia32', 'ia64', 'm68k',
@@ -298,6 +298,7 @@ my %OS_SUPPORTS_SHARED = (
'beos' => [ 'all', ],
'darwin' => [ 'all', ],
'freebsd' => [ 'all', ],
+ 'dragonfly' => [ 'all', ],
'hpux' => [ 'all', ],
'irix' => [ 'all', ],
'linux' => [ 'all', ],
@@ -314,6 +315,7 @@ my %OS_TYPE = (
'cygwin' => 'unix',
'darwin' => 'unix',
'freebsd' => 'unix',
+ 'dragonfly' => 'unix',
'hpux' => 'unix',
'irix' => 'unix',
'linux' => 'unix',
@@ -387,6 +389,9 @@ my %INSTALL_INFO = (
'freebsd' => {
'group' => 'wheel',
},
+ 'dragonfly' => {
+ 'group' => 'wheel',
+ },
'netbsd' => {
'group' => 'wheel',
},
@@ -406,7 +411,7 @@ my %CC_SUPPORTS_OS = (
'bcc' => [ 'windows', ],
'compaq' => [ 'linux', 'tru64', ],
'ekopath' => [ 'linux', ],
- 'gcc' => [ 'aix', 'beos', 'cygwin', 'darwin', 'freebsd', 'hpux', 'irix',
+ 'gcc' => [ 'aix', 'beos', 'cygwin', 'dragonfly', 'darwin', 'freebsd', 'hpux', 'irix',
'linux', 'netbsd', 'openbsd', 'qnx', 'solaris', 'tru64',
'windows', ],
'hpcc' => [ 'hpux', ],
@@ -663,6 +668,7 @@ my %CC_ABI_FLAGS = (
'gcc' => {
'amd64' => '-m64',
'freebsd' => '-pthread',
+ 'dragonfly' => '-pthread',
'mips32' => '-mabi=n32',
'mips64' => '-mabi=64',
'netbsd' => '-pthread',
@@ -772,6 +778,7 @@ my %REALNAME = (
'darwin' => 'Darwin / MacOS X',
'ekopath' => 'PathScale EKOPath C++',
'freebsd' => 'FreeBSD',
+ 'dragonfly' => 'DragonFly',
'gcc' => 'GNU C++',
'hpcc' => 'HP-UX C++',
'hppa' => 'HP-PA',
@@ -1696,12 +1703,6 @@ sub guess_triple
my @CCS = ('gcc', 'icc', 'compaq', 'kai'); # Skips several, oh well...
# First try the CC enviornmental variable, if it's set
@ -23,7 +82,7 @@ $NetBSD: patch-aa,v 1.2 2006/02/05 01:30:55 rillig Exp $
my $cc = '';
foreach (@CCS)
@@ -2040,8 +2033,12 @@ sub print_unix_makefile {
@@ -2040,8 +2041,12 @@ sub print_unix_makefile {
my $link_to = "-lm";
foreach my $lib (@{ $lib_list })
{
@ -36,7 +95,7 @@ $NetBSD: patch-aa,v 1.2 2006/02/05 01:30:55 rillig Exp $
##################################################
# Generate a few variables #
@@ -2279,12 +2276,12 @@ $__TAB__\@for i in \$(HEADERS); do \\
@@ -2279,12 +2284,12 @@ $__TAB__\@for i in \$(HEADERS); do \\
$__TAB__ \$(INSTALL_CMD_DATA) \$\$i \$(HEADERDIR); \\
$__TAB__ done
$__TAB__\@\$(INSTALL_CMD_DATA) \$(STATIC_LIB) \$(LIBDIR)

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/es_egd/es_egd.orig 2006-02-27 01:30:24.000000000 +0000
+++ modules/es_egd/es_egd
@@ -14,6 +14,7 @@ qnx -> socket
aix
cygwin
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/es_ftw/es_ftw.orig 2006-02-27 01:30:36.000000000 +0000
+++ modules/es_ftw/es_ftw
@@ -9,6 +9,7 @@ add_file es_ftw.cpp
aix
cygwin
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/es_unix/es_unix.orig 2006-02-27 01:31:09.000000000 +0000
+++ modules/es_unix/es_unix
@@ -14,6 +14,7 @@ aix
beos
cygwin
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/fd_unix/fd_unix.orig 2006-02-27 01:31:16.000000000 +0000
+++ modules/fd_unix/fd_unix
@@ -10,6 +10,7 @@ aix
beos
cygwin
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ag,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/ml_unix/ml_unix.orig 2006-02-27 01:31:51.000000000 +0000
+++ modules/ml_unix/ml_unix
@@ -5,6 +5,7 @@ replace_file mlock.cpp
<os>
aix
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ah,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/mux_pthr/mux_pthr.orig 2006-02-27 01:32:23.000000000 +0000
+++ modules/mux_pthr/mux_pthr
@@ -6,13 +6,14 @@ add_file mux_pthr.cpp
add_file mux_pthr.h
<libs>
-all!qnx,freebsd,openbsd,netbsd -> pthread
+all!qnx,freebsd,openbsd,netbsd,dragonfly -> pthread
</libs>
<os>
aix
cygwin
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ai,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/tm_unix/tm_unix.orig 2006-02-27 01:32:48.000000000 +0000
+++ modules/tm_unix/tm_unix
@@ -10,6 +10,7 @@ aix
beos
cygwin
darwin
+dragonfly
freebsd
hpux
irix

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aj,v 1.1 2006/03/01 00:33:30 joerg Exp $
--- modules/alloc_mmap/alloc_mmap.orig 2006-03-01 00:19:15.000000000 +0000
+++ modules/alloc_mmap/alloc_mmap
@@ -8,6 +8,7 @@ add_file mmap_mem.h
<os>
linux
freebsd
+dragonfly
openbsd
netbsd
solaris