musicpd: update to 0.21.5.
ver 0.21.5 (2019/02/22) * protocol - fix deadlock in "albumart" command - fix "tagtypes disable" command * database - simple: fix assertion failure - fix assertion failures with mount points * storage - udisks: fix "AlreadyMounted" error - udisks: use relative path from mount URI - fix memory leak * input - buffer: fix crash bug when playing remote WAV file * tags - ape: map "Album Artist" * output - shout: add support for TLS * mixer - pulse: add "scale_volume" setting
This commit is contained in:
parent
3f3bdc35d8
commit
20e6d46b68
4 changed files with 8 additions and 40 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.179 2019/01/05 12:43:46 triaxx Exp $
|
||||
# $NetBSD: Makefile,v 1.180 2019/02/24 15:32:06 wiz Exp $
|
||||
|
||||
DISTNAME= mpd-0.21.4
|
||||
DISTNAME= mpd-0.21.5
|
||||
PKGNAME= ${DISTNAME:S/mpd/musicpd/}
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.musicpd.org/download/mpd/0.21/
|
||||
|
@ -37,7 +37,7 @@ SUBST_CLASSES+= paths
|
|||
SUBST_STAGE.paths= pre-configure
|
||||
SUBST_FILES.paths= mpd.conf
|
||||
SUBST_MESSAGE.paths= Fixing path to sound device in example config.
|
||||
SUBST_SED.paths= -e 's,@DEVOSSAUDIO@,${DEVOSSAUDIO},'
|
||||
SUBST_VARS.paths+= DEVOSSAUDIO
|
||||
|
||||
SUBST_CLASSES+= sphinx
|
||||
SUBST_STAGE.sphinx= pre-configure
|
||||
|
|
|
@ -1,9 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.94 2019/01/15 10:04:53 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.95 2019/02/24 15:32:06 wiz Exp $
|
||||
|
||||
SHA1 (mpd-0.21.4.tar.xz) = ae5370bc90209e0f5d955094a83cee37d9ca15d9
|
||||
RMD160 (mpd-0.21.4.tar.xz) = 0af583f0f79d70d7eb39bf61baebae8120a173c2
|
||||
SHA512 (mpd-0.21.4.tar.xz) = 454fde206f98f89a58ac773037963ac895ee6ce3e7d1032c49b980a3bfbbb69782a62900a5c09e4b39f24b2d1bcd380d7b520935563dd3b8d02f701389389ca7
|
||||
Size (mpd-0.21.4.tar.xz) = 663648 bytes
|
||||
SHA1 (patch-src_db_VHelper.cxx) = eeb94684a0a7d6dabfdd753964095524f61bd442
|
||||
SHA1 (patch-src_decoder_plugins_AudiofileDecoderPlugin.cxx) = 3151ae41740a6ed342e108b79a2b97c995aac4f3
|
||||
SHA1 (mpd-0.21.5.tar.xz) = 0ebfd24393fe1c941c3771fde279fc253874bbc8
|
||||
RMD160 (mpd-0.21.5.tar.xz) = e043485a14abb846ae06f1f9f78e9e48d23bc623
|
||||
SHA512 (mpd-0.21.5.tar.xz) = b3a938f43cd554e0e761890ca7ea910e21b8f98f54f5bfceb0efcbef4df46db0d110d1bbc24a233021b463e3424d6246c1013f5a6ebdfc85a418008d49ced7a4
|
||||
Size (mpd-0.21.5.tar.xz) = 667624 bytes
|
||||
SHA1 (patch-src_net_IPv6Address.hxx) = c9e9a5676451e6834fcef359266d37fc15f079e6
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_db_VHelper.cxx,v 1.1 2019/01/15 10:04:53 wiz Exp $
|
||||
|
||||
../src/db/VHelper.cxx:61:17: error: use of undeclared identifier 'strtol'
|
||||
https://github.com/MusicPlayerDaemon/MPD/issues/456
|
||||
|
||||
--- src/db/VHelper.cxx.orig 2019-01-04 18:22:21.000000000 +0000
|
||||
+++ src/db/VHelper.cxx
|
||||
@@ -23,6 +23,7 @@
|
||||
#include "song/Filter.hxx"
|
||||
|
||||
#include <assert.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
DatabaseVisitorHelper::DatabaseVisitorHelper(const DatabaseSelection &_selection,
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_decoder_plugins_AudiofileDecoderPlugin.cxx,v 1.1 2019/01/15 10:04:53 wiz Exp $
|
||||
|
||||
../src/decoder/plugins/AudiofileDecoderPlugin.cxx:131:39: error: use of undeclared identifier 'malloc'; did you mean 'tzalloc'?
|
||||
https://github.com/MusicPlayerDaemon/MPD/issues/456
|
||||
|
||||
--- src/decoder/plugins/AudiofileDecoderPlugin.cxx.orig 2019-01-04 18:22:21.000000000 +0000
|
||||
+++ src/decoder/plugins/AudiofileDecoderPlugin.cxx
|
||||
@@ -33,6 +33,7 @@
|
||||
|
||||
#include <assert.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
static constexpr Domain audiofile_domain("audiofile");
|
||||
|
Loading…
Reference in a new issue