Use CXX as C++ compiler. Remove messed up compile test using
non-existing file.
This commit is contained in:
parent
a1e579f6ec
commit
211cb13a34
3 changed files with 24 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.19 2012/10/31 11:17:07 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2014/12/25 17:39:58 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= its4-1.1.1
|
||||
|
@ -13,6 +13,7 @@ LICENSE= no-commercial-use
|
|||
|
||||
WRKSRC= ${WRKDIR}/its4
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --with-cpp=${CXX:Q}
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
|
||||
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/its4
|
||||
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/02/23 22:24:16 agc Exp $
|
||||
$NetBSD: distinfo,v 1.5 2014/12/25 17:39:58 joerg Exp $
|
||||
|
||||
SHA1 (its4-1.1.1.tgz) = e4f53d50b3e58bda892088b15454493c3f07624b
|
||||
RMD160 (its4-1.1.1.tgz) = 4f1c16d678126f6ea6e10f0a31e5fa14e7cd852c
|
||||
Size (its4-1.1.1.tgz) = 59870 bytes
|
||||
SHA1 (patch-aa) = be67edcb8ca7859d9e2571b4e228bef5140e84cd
|
||||
SHA1 (patch-configure) = 25fd9b0fbce09b7ff8adf5259d3e53bffaa2e083
|
||||
|
|
20
devel/its4/patches/patch-configure
Normal file
20
devel/its4/patches/patch-configure
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-configure,v 1.1 2014/12/25 17:39:58 joerg Exp $
|
||||
|
||||
--- configure.orig 2014-12-23 20:56:39.000000000 +0000
|
||||
+++ configure
|
||||
@@ -120,15 +120,6 @@ cat >tmp.c <<EOF
|
||||
#include <iostream.h>
|
||||
int main(){return 0;}
|
||||
EOF
|
||||
-if test -n "${CC}"; then
|
||||
- printf %s "Checking for user-supplied C++... " 1>&5
|
||||
- if `${CC} tmp.c 2>/dev/null` 2>/dev/null; then
|
||||
- echo "yes" 1>&5
|
||||
- else
|
||||
- echo "no" 1>&5
|
||||
- CC=
|
||||
- fi
|
||||
-fi
|
||||
if test -z "${CC}"; then
|
||||
printf %s "Looking for a C++ compiler... " 1>&5
|
||||
if `g++ tmp.c 2>/dev/null` 2>/dev/null; then
|
Loading…
Reference in a new issue