Update to elinks-0.11.3:

- without-x doesn't make sense, remove option
- depend on libiconv and libidn
- quarantine to prevent changes to the normal LOCALEDIR -- this is
  a stupid, non-standard version of gettext for no good reason
- fix mremap on NetBSD

Upstream changes:
- various crashes fixed
- fix use after free
- fix large file support for FTP listenings
- automatic HTML detection

Submitted by Blair Sadewitz, consider switching to links, please.
This commit is contained in:
joerg 2007-08-09 13:03:21 +00:00
parent 5dade59f67
commit 2165a2f763
5 changed files with 67 additions and 32 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.32 2007/06/21 15:52:15 jlam Exp $
# $NetBSD: Makefile,v 1.33 2007/08/09 13:03:21 joerg Exp $
DISTNAME= elinks-0.11.2
PKGREVISION= 1
DISTNAME= elinks-0.11.3
CATEGORIES= www
MASTER_SITES= http://elinks.or.cz/download/
EXTRACT_SUFX= .tar.bz2
@ -10,18 +9,21 @@ MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://elinks.or.cz/
COMMENT= Extended/Enhanced Links
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= gmake
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/${PKGBASE}
CONFIGURE_ARGS+= --without-x
CONFIGURE_ARGS+= --enable-256-colors
.include "options.mk"
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libidn/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../lang/lua/buildlink3.mk"

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.19 2007/06/21 15:52:15 jlam Exp $
$NetBSD: distinfo,v 1.20 2007/08/09 13:03:21 joerg Exp $
SHA1 (elinks-0.11.2.tar.bz2) = 47669c38e1e5ebb35015a9a9a8f9c898821bd408
RMD160 (elinks-0.11.2.tar.bz2) = a9d938cfdfa71be282b7596e1fed5797f2efd6a5
Size (elinks-0.11.2.tar.bz2) = 2497270 bytes
SHA1 (patch-aa) = 53bf21217d63989e62f8050219135a9a7482cecf
SHA1 (elinks-0.11.3.tar.bz2) = e4d8b0edd5fa4ec4310662242f0b5cf32864ed11
RMD160 (elinks-0.11.3.tar.bz2) = 936f0cd4dbc69f70c329cf0ef5d7acd722652b6e
Size (elinks-0.11.3.tar.bz2) = 2516793 bytes
SHA1 (patch-aa) = d396437d47a7162e0414368ac55b513b33b0f7cd
SHA1 (patch-ab) = b08b2c8a9148e69ab18eb8577f95672cd707cdf3
SHA1 (patch-ac) = f7dc18652782a5ad0768a5693a69bcadc6e5754d
SHA1 (patch-ad) = 3378dc9415533234fe98a038831cd5208c85f0aa
SHA1 (patch-ae) = 566ac2d8900c0f64414eb7b9164fd3b8557046fd

View file

@ -1,9 +1,9 @@
# $NetBSD: options.mk,v 1.5 2007/01/26 23:43:02 joerg Exp $
# $NetBSD: options.mk,v 1.6 2007/08/09 13:03:21 joerg Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.elinks
PKG_SUPPORTED_OPTIONS+= bittorrent nntp spidermonkey finger gopher
PKG_SUPPORTED_OPTIONS+= inet6 x11 elinks-fastmem elinks-exmode expat
PKG_SUPPORTED_OPTIONS+= elinks-html-highlight elinks-root-exec ssl
PKG_SUPPORTED_OPTIONS+= elinks-html-highlight elinks-root-exec
PKG_OPTIONS_GROUP.tls= gnutls ssl
PKG_OPTIONS_REQUIRED_GROUPS= tls
PKG_SUGGESTED_OPTIONS= ssl

View file

@ -1,17 +1,26 @@
$NetBSD: patch-aa,v 1.6 2007/06/21 15:52:16 jlam Exp $
$NetBSD: patch-aa,v 1.7 2007/08/09 13:03:21 joerg Exp $
--- configure.orig 2006-11-19 08:46:47.000000000 -0500
--- configure.orig 2007-04-15 16:51:12.000000000 -0400
+++ configure
@@ -907,7 +907,7 @@ Optional Packages:
--without-openssl disable OpenSSL support
--with-openssl=DIR enable OpenSSL support (default)
--with-x use the X Window System
- --with-libiconv=DIR search for libiconv in DIR/include and DIR/lib
+ --with-libiconv-prefix=DIR search for libiconv in DIR/include and DIR/lib
Some influential environment variables:
CC C compiler command
@@ -2959,7 +2959,7 @@ _ACEOF
echo > config.asciidoc-unsafe.txt
- if "$ASCIIDOC" --unsafe config.asciidoc-unsafe.txt >&/dev/null; then
+ if "$ASCIIDOC" --unsafe config.asciidoc-unsafe.txt 1>/dev/null 2>&1; then
- if "$ASCIIDOC" --unsafe config.asciidoc-unsafe.txt >/dev/null 2>/dev/null; then
+ if "$ASCIIDOC" --unsafe config.asciidoc-unsafe.txt >/dev/null 2>&1 > /dev/null; then
ASCIIDOC_FLAGS=--unsafe
fi
rm config.asciidoc-unsafe.*
@@ -17578,7 +17578,7 @@ if test -z "$disable_lua"; then
@@ -17564,7 +17564,7 @@ if test -z "$disable_lua"; then
for luadir in "$withval" "" /usr /usr/local; do
for suffix in "" 50 51; do
if test "$cf_result" = no; then
@ -20,22 +29,19 @@ $NetBSD: patch-aa,v 1.6 2007/06/21 15:52:16 jlam Exp $
if test ! -z "$luadir"; then
LUA_LIBS="-L$luadir/lib $LUA_LIBS"
@@ -17602,10 +17602,10 @@ int
main ()
{
lua_State *L = lua_open();
- lua_baselibopen(L);
- lua_mathlibopen(L);
- lua_strlibopen(L);
- lua_tablibopen(L);
+ luaopen_base(L);
+ luaopen_math(L);
+ luaopen_string(L);
+ luaopen_table(L);
lua_pushboolean(L, 1);
lua_close(L);
;
@@ -23243,7 +23243,7 @@ _ACEOF
@@ -20479,9 +20479,9 @@ done
-# Check whether --with-libiconv or --without-libiconv was given.
+# Check whether --with-libiconv-prefix or --without-libiconv-prefix was given.
if test "${with_libiconv+set}" = set; then
- withval="$with_libiconv"
+ withval="$with_libiconv_prefix"
for dir in `echo "$withval" | tr : ' '`; do
if test -d $dir/include; then CPPFLAGS="$CPPFLAGS -I$dir/include"; fi
@@ -23231,7 +23231,7 @@ _ACEOF
# Create LIBDIR #define for config.h

View file

@ -0,0 +1,26 @@
$NetBSD: patch-ae,v 1.1 2007/08/09 13:03:21 joerg Exp $
--- src/util/memory.c.orig 2007-04-15 16:51:03.000000000 -0400
+++ src/util/memory.c
@@ -20,6 +20,12 @@
#include "util/error.h"
#include "util/memory.h"
+#if defined(__NetBSD__)
+# define MREMAP(p, oldsz, newsz, f) mremap(p, oldsz, p, newsz, f)
+# define MREMAP_MAYMOVE 0
+#else
+# define MREMAP(p, oldsz, newsz, f) mremap(p, oldsz, newsz, f)
+#endif
#if !defined(DEBUG_MEMLEAK) && !defined(CONFIG_FASTMEM)
@@ -167,7 +173,7 @@ mem_mmap_realloc(void *p, size_t old_siz
if (new_size) {
#ifdef HAVE_MREMAP
- void *p2 = mremap(p, round_size(old_size), round_size(new_size), MREMAP_MAYMOVE);
+ void *p2 = MREMAP(p, round_size(old_size), round_size(new_size), MREMAP_MAYMOVE);
if (p2 != MAP_FAILED)
return p2;