Fix openssl breakage so this package can now progress to flex breakage.
This commit is contained in:
parent
fcb4d23923
commit
218bc14b92
2 changed files with 17 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.17 2010/01/29 19:12:10 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.18 2011/12/19 13:58:33 wiz Exp $
|
||||
|
||||
SHA1 (opencm-0.1.2alpha8-2-src.tgz) = 2befad488fd7b73f961f7f6a771acdcee921a20d
|
||||
RMD160 (opencm-0.1.2alpha8-2-src.tgz) = 2ec1b4c317bd90723bccd73a4245c464c337bd9d
|
||||
|
@ -11,3 +11,4 @@ SHA1 (patch-ae) = 17caf47d93ec763248792994a3cca3869a8cd8ac
|
|||
SHA1 (patch-af) = 63194a7f9530ccf3ac7f0d91b94d717295c61f0b
|
||||
SHA1 (patch-ag) = 603fddc1fb526e70fc194280c387084270d62180
|
||||
SHA1 (patch-ah) = 1d29db6a5c7ff2d1c7ddc7fcbd5309b35a3f9407
|
||||
SHA1 (patch-src_common_PubKey.c) = 3febe96d04b7c3f6ed47cbe75edd41f8334590c3
|
||||
|
|
15
devel/opencm/patches/patch-src_common_PubKey.c
Normal file
15
devel/opencm/patches/patch-src_common_PubKey.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_common_PubKey.c,v 1.1 2011/12/19 13:58:34 wiz Exp $
|
||||
|
||||
Adapt for changes in openssl.
|
||||
|
||||
--- src/common/PubKey.c.orig 2003-06-19 01:55:04.000000000 +0000
|
||||
+++ src/common/PubKey.c
|
||||
@@ -289,7 +289,7 @@ pubkey_GetEmail(PubKey *pk)
|
||||
case pk_X509:
|
||||
{
|
||||
X509 *x = pk->keys.x509_cert;
|
||||
- STACK* emails;
|
||||
+ STACK_OF(OPENSSL_STRING)* emails;
|
||||
const char* email = 0;
|
||||
|
||||
emails = X509_get1_email(x);
|
Loading…
Reference in a new issue