Remove obsoleted patches (that were not applied anyway, because they were
no longer present in files/patch-sum)
This commit is contained in:
parent
e2752c3046
commit
2191bede37
2 changed files with 0 additions and 72 deletions
|
@ -1,59 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.4 1999/11/14 20:45:09 tron Exp $
|
||||
|
||||
--- applets/battery/read-battery.c.orig Tue Aug 24 21:41:15 1999
|
||||
+++ applets/battery/read-battery.c Sun Nov 14 21:24:09 1999
|
||||
@@ -185,7 +185,7 @@
|
||||
close(fd);
|
||||
return TRUE;
|
||||
|
||||
-#elif defined(__NetBSD__) || defined(__OpenBSD__)
|
||||
+#elif defined(__NetBSD_APM__) || defined(__OpenBSD__)
|
||||
struct apm_power_info aip;
|
||||
int fd;
|
||||
|
||||
@@ -221,7 +221,44 @@
|
||||
close(fd);
|
||||
return TRUE;
|
||||
|
||||
-#else /* ! ( __linux__ || __FreeBSD__) */
|
||||
+#elif defined(__NetBSD_APM__)
|
||||
+
|
||||
+ struct apm_power_info aip;
|
||||
+ int fd;
|
||||
+
|
||||
+ fd = open(APMDEV, O_RDONLY);
|
||||
+ if (fd == -1)
|
||||
+ {
|
||||
+ g_error (_("Cannot open /dev/apm; can't get data."));
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+
|
||||
+ if (ioctl(fd, APM_IOC_GETPOWER, &aip) == -1) {
|
||||
+ g_error(_("ioctl failed on /dev/apm."));
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+
|
||||
+ *hours_remaining = aip.minutes_left / 60;
|
||||
+ aip.minutes_left %= 60;
|
||||
+ *minutes_remaining = aip.minutes_left;
|
||||
+
|
||||
+ /* if APM is not turned on */
|
||||
+ if (aip.battery_state == APM_BATT_UNKNOWN)
|
||||
+ {
|
||||
+ g_error(_("APM battery state unknown! Cannot read battery charge information."));
|
||||
+ }
|
||||
+ if (aip.ac_state == APM_AC_UNKNOWN)
|
||||
+ {
|
||||
+ g_error(_("APM ac state is unknown! Cannot read battery charge information."));
|
||||
+ }
|
||||
+
|
||||
+ *ac_online = aip.ac_state == APM_AC_ON;
|
||||
+ *percentage = aip.battery_life;
|
||||
+
|
||||
+ close(fd);
|
||||
+ return TRUE;
|
||||
+
|
||||
+#else /* ! ( __linux__ || __FreeBSD__ || __NetBSD_APM__ ) */
|
||||
|
||||
/* Assume always connected to power. */
|
||||
*ac_online = 1;
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.1 1999/09/03 02:00:09 jlam Exp $
|
||||
|
||||
--- applets/mixer/Makefile.in.orig Mon Jul 19 19:02:48 1999
|
||||
+++ applets/mixer/Makefile.in Thu Sep 2 20:18:08 1999
|
||||
@@ -162,7 +162,7 @@
|
||||
mixer_applet_SOURCES = mixer.c vslider.c vslider.h hslider.c hslider.h lamp-small.xpm lamp-small-red.xpm
|
||||
|
||||
|
||||
-mixer_applet_LDADD = ../../panel/libpanel_applet.la $(GNOME_LIBDIR) $(ORB_LIBS) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
|
||||
+mixer_applet_LDADD = ../../panel/libpanel_applet.la $(GNOME_LIBDIR) $(ORB_LIBS) $(ESD_LIBS) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
|
||||
|
||||
|
||||
EXTRA_DIST = mixer_applet.desktop mixer_applet.gnorba
|
Loading…
Reference in a new issue