Use system version of strcasecmp on DragonFly, prototype conflicts

and it doesn't make much sense either.
This commit is contained in:
joerg 2006-01-08 17:55:31 +00:00
parent ea96b794fb
commit 21db667705
2 changed files with 24 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2005/02/24 09:59:20 agc Exp $
$NetBSD: distinfo,v 1.4 2006/01/08 17:55:31 joerg Exp $
SHA1 (autorespond-2.0.5.tar.gz) = 9bdd160e93e886932b7679e915d72dca90d8de6a
RMD160 (autorespond-2.0.5.tar.gz) = c86f56d02ac1f609605a4349a59b4293eff2ca15
Size (autorespond-2.0.5.tar.gz) = 9707 bytes
SHA1 (patch-aa) = d426dbedcb0fa62dd81fc77eb6c908c55f8b3023

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1 2006/01/08 17:55:31 joerg Exp $
--- autorespond.c.orig 2006-01-08 17:51:50.000000000 +0000
+++ autorespond.c
@@ -372,7 +372,7 @@ void read_headers( FILE *fp )
}
-
+#if !defined(__DragonFly__)
/*********************************************************
** find string in string - ignore case **/
@@ -398,7 +398,7 @@ char *strcasestr( char *_s1, char *_s2 )
else
return _s1 + (ptr - s1);
}
-
+#endif