Update to 1.2.0.

Patch provided by Matthew Luckie (maintainer) in PR pkg/29752.

* Yahoo file receiving and buddy icon receiving work again.
* Limit animated buddy icon frame rates to 10 frames per second (Nathan Conrad)
* Fix a bug where portions of your account configuration would fail to be
  read correctly if you set a proxy user name or password containing invalid
  XML characters such as < and > (Bastien Durel)
* Yahoo! privacy improvements (Bleeter)
This commit is contained in:
jmmv 2005-03-22 09:47:47 +00:00
parent 7c2a1e4bc5
commit 21dbe50860
3 changed files with 36 additions and 7 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.81 2005/03/18 18:56:04 jmmv Exp $
# $NetBSD: Makefile,v 1.82 2005/03/22 09:47:47 jmmv Exp $
DISTNAME= gaim-1.1.4
PKGREVISION= 1
DISTNAME= gaim-1.2.0
CATEGORIES= chat x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gaim/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.61 2005/03/18 18:56:04 jmmv Exp $
$NetBSD: distinfo,v 1.62 2005/03/22 09:47:47 jmmv Exp $
SHA1 (gaim-1.1.4.tar.bz2) = ef4061f2f7413b18c4ea59da10b9f0837df20054
RMD160 (gaim-1.1.4.tar.bz2) = eb254b2d63108cd65c5237bea922900a4ba72fbf
Size (gaim-1.1.4.tar.bz2) = 5195580 bytes
SHA1 (gaim-1.2.0.tar.bz2) = 6aa42c56a1c7dae34a831006ecd4f02dd1fe13a6
RMD160 (gaim-1.2.0.tar.bz2) = e860058814c97db362e087526ca197746f4fd365
Size (gaim-1.2.0.tar.bz2) = 5200934 bytes
SHA1 (patch-aa) = 555c394dbb4cd9ef4fea621d30ce72baae309067
SHA1 (patch-ab) = b9758039c9b39006db6d3211099786e2614cbe5d
SHA1 (patch-ad) = 21ffc478343793ce065c75a24ed0cf58b0677359

View file

@ -0,0 +1,29 @@
$NetBSD: patch-ab,v 1.14 2005/03/22 09:47:47 jmmv Exp $
--- src/protocols/yahoo/yahoochat.c.orig Mon Mar 21 20:00:56 2005
+++ src/protocols/yahoo/yahoochat.c Mon Mar 21 20:03:09 2005
@@ -342,9 +342,12 @@
void yahoo_process_chat_join(GaimConnection *gc, struct yahoo_packet *pkt)
{
struct yahoo_data *yd = (struct yahoo_data *) gc->proto_data;
+ GaimAccount *account;
GaimConversation *c = NULL;
+ GaimConversationUiOps *ops;
GSList *l;
GList *members = NULL;
+ GList *roomies = NULL;
char *room = NULL;
char *topic = NULL;
char *someid, *someotherid, *somebase64orhashosomething, *somenegativenumber;
@@ -443,10 +446,8 @@
yahoo_chat_add_users(GAIM_CONV_CHAT(c), members);
}
- GList *roomies=NULL;
- GaimConversationUiOps *ops;
ops = gaim_conversation_get_ui_ops(c);
- GaimAccount *account = gaim_connection_get_account(gc);
+ account = gaim_connection_get_account(gc);
for (l = account->deny; l != NULL; l = l->next) {
for (roomies = members; roomies; roomies = roomies->next) {
if (!gaim_utf8_strcasecmp((char *)l->data, roomies->data)) {