Add forgotten patches to allow zlib 1.2.3 and rename libutil to

libmyutil.
This commit is contained in:
joerg 2014-12-18 12:26:51 +00:00
parent 9a14aa35dc
commit 21e0ea169f
4 changed files with 78 additions and 0 deletions

View file

@ -0,0 +1,22 @@
$NetBSD: patch-Makefile.local,v 1.1 2014/12/18 12:26:51 joerg Exp $
--- Makefile.local.orig 2014-12-15 20:14:52.000000000 +0000
+++ Makefile.local
@@ -46,7 +46,7 @@ PV_FILE=bindings/python/notmuch/version.
# Smash together user's values with our extra values
FINAL_CFLAGS = -DNOTMUCH_VERSION=$(VERSION) $(CPPFLAGS) $(CFLAGS) $(WARN_CFLAGS) $(extra_cflags) $(CONFIGURE_CFLAGS)
FINAL_CXXFLAGS = $(CPPFLAGS) $(CXXFLAGS) $(WARN_CXXFLAGS) $(extra_cflags) $(extra_cxxflags) $(CONFIGURE_CXXFLAGS)
-FINAL_NOTMUCH_LDFLAGS = $(LDFLAGS) -Lutil -lutil -Llib -lnotmuch
+FINAL_NOTMUCH_LDFLAGS = $(LDFLAGS) -Lutil -lmyutil -Llib -lnotmuch
ifeq ($(LIBDIR_IN_LDCONFIG),0)
FINAL_NOTMUCH_LDFLAGS += $(RPATH_LDFLAGS)
endif
@@ -297,7 +297,7 @@ notmuch_client_modules = $(notmuch_clien
notmuch.o: version.stamp
-notmuch: $(notmuch_client_modules) lib/libnotmuch.a util/libutil.a parse-time-string/libparse-time-string.a
+notmuch: $(notmuch_client_modules) lib/libnotmuch.a util/libmyutil.a parse-time-string/libparse-time-string.a
$(call quiet,CXX $(CFLAGS)) $^ $(FINAL_LIBNOTMUCH_LDFLAGS) -o $@
notmuch-shared: $(notmuch_client_modules) lib/$(LINKER_NAME)

View file

@ -0,0 +1,24 @@
$NetBSD: patch-notmuch-dump.c,v 1.1 2014/12/18 12:26:51 joerg Exp $
Avoid depending on very recent zlib.
--- notmuch-dump.c.orig 2014-12-15 20:12:50.000000000 +0000
+++ notmuch-dump.c
@@ -177,7 +177,7 @@ notmuch_database_dump (notmuch_database_
}
}
- if (gzclose_w (output) != Z_OK) {
+ if (gzclose(output) != Z_OK) {
fprintf (stderr, "Error closing %s: %s\n", name_for_error,
gzerror (output, NULL));
ret = EXIT_FAILURE;
@@ -196,7 +196,7 @@ notmuch_database_dump (notmuch_database_
}
DONE:
if (ret != EXIT_SUCCESS && output)
- (void) gzclose_w (output);
+ (void) gzclose(output);
if (ret != EXIT_SUCCESS && output_file_name)
(void) unlink (tempname);

View file

@ -0,0 +1,15 @@
$NetBSD: patch-notmuch-restore.c,v 1.1 2014/12/18 12:26:51 joerg Exp $
Avoid depending on very recent zlib.
--- notmuch-restore.c.orig 2014-12-15 20:12:30.000000000 +0000
+++ notmuch-restore.c
@@ -312,7 +312,7 @@ notmuch_restore_command (notmuch_config_
if (notmuch)
notmuch_database_destroy (notmuch);
- if (input && gzclose_r (input)) {
+ if (input && gzclose(input)) {
fprintf (stderr, "Error closing %s: %s\n",
name_for_error, gzerror (input, NULL));
ret = EXIT_FAILURE;

View file

@ -0,0 +1,17 @@
$NetBSD: patch-util_Makefile.local,v 1.1 2014/12/18 12:26:51 joerg Exp $
Don't overlap with BSD's libutil.
--- util/Makefile.local.orig 2014-12-15 20:14:25.000000000 +0000
+++ util/Makefile.local
@@ -9,8 +9,8 @@ libutil_c_srcs := $(dir)/xutil.c $(dir)/
libutil_modules := $(libutil_c_srcs:.c=.o)
-$(dir)/libutil.a: $(libutil_modules)
+$(dir)/libmyutil.a: $(libutil_modules)
$(call quiet,AR) rcs $@ $^
SRCS := $(SRCS) $(libutil_c_srcs)
-CLEAN := $(CLEAN) $(libutil_modules) $(dir)/libutil.a
+CLEAN := $(CLEAN) $(libutil_modules) $(dir)/libmyutil.a