Update from version 1.5.0 to 1.6.0.

Pkgsrc changes:
 o Remove two patches which have been included upstream.

Upstream changes:

- Functionality
  + Added a fixed-size structure allocator to the Garbage Collector
  + Added a "lazy" mode to the PObj and Fixed-Size memory allocators
  + Added a profiling runcore, which generates Callgrind-compatible output
  + Added lexical subsystem opcodes: find_dynamic_lex, store_dynamic_lex
  + Converted Contexts to garbage-collectable PMC structures
  + Created a new Context API
  + Enhanced the PMC allocator to automatically allocate ATTR structures
- Performance
  + Optimized opcodes to cache the current Context for subsequent lookups
  + Reduced string comparisons in VTABLE_isa
- Maintenance and cleanup
  + Began proper encapsulation of STRING API
  + Unified all PMC destruction functions
  + Unified Continuation PMC and Parrot_cont structure
  + Unified Sub PMC and Parrot_sub structure
  + Removed PMC_EXT structure
  + Removed PMC_Sync from PMC
  + Removed UnionVal from PMC structure
- Bugfix
  + Fixed several stack-walking bugs in Garbage Collector code
  + Fixed bug when copying a NULL STRING, now returns empty STRING struct
- Tests
  + Converted several Perl5 tests to PIR
  + Expanded test coverage of NameSpace PMC
- Compilers
  + Made Parrot Compiler Toolkit available in the base install
This commit is contained in:
he 2009-09-20 10:57:04 +00:00
parent 61837126fa
commit 21f607f04c
5 changed files with 14 additions and 68 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.21 2009/08/28 16:48:41 he Exp $
# $NetBSD: Makefile,v 1.22 2009/09/20 10:57:04 he Exp $
#
VERSION= 1.5.0
VERSION= 1.6.0
RTYPE= devel
DISTNAME= parrot-${VERSION}
CATEGORIES= lang

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2009/08/28 16:48:41 he Exp $
@comment $NetBSD: PLIST,v 1.9 2009/09/20 10:57:04 he Exp $
bin/parrot
bin/parrot_config
bin/parrot_debugger
@ -17,6 +17,7 @@ include/parrot/${PKGVERSION}/parrot/cclass.h
include/parrot/${PKGVERSION}/parrot/charset.h
include/parrot/${PKGVERSION}/parrot/compiler.h
include/parrot/${PKGVERSION}/parrot/config.h
include/parrot/${PKGVERSION}/parrot/context.h
include/parrot/${PKGVERSION}/parrot/core_pmcs.h
include/parrot/${PKGVERSION}/parrot/core_types.h
include/parrot/${PKGVERSION}/parrot/datatypes.h
@ -69,8 +70,8 @@ include/parrot/${PKGVERSION}/parrot/platform_interface.h
include/parrot/${PKGVERSION}/parrot/pmc.h
include/parrot/${PKGVERSION}/parrot/pmc_freeze.h
include/parrot/${PKGVERSION}/parrot/pobj.h
include/parrot/${PKGVERSION}/parrot/register.h
include/parrot/${PKGVERSION}/parrot/runcore_api.h
include/parrot/${PKGVERSION}/parrot/runcore_profiling.h
include/parrot/${PKGVERSION}/parrot/runcore_trace.h
include/parrot/${PKGVERSION}/parrot/scheduler.h
include/parrot/${PKGVERSION}/parrot/scheduler_private.h
@ -181,6 +182,10 @@ lib/parrot/${PKGVERSION}/library/PGE/Text.pbc
lib/parrot/${PKGVERSION}/library/PGE/Text.pir
lib/parrot/${PKGVERSION}/library/PGE/Util.pbc
lib/parrot/${PKGVERSION}/library/PGE/Util.pir
lib/parrot/${PKGVERSION}/library/PCT.pbc
lib/parrot/${PKGVERSION}/library/PCT/Grammar.pbc
lib/parrot/${PKGVERSION}/library/PCT/HLLCompiler.pbc
lib/parrot/${PKGVERSION}/library/PCT/PAST.pbc
lib/parrot/${PKGVERSION}/library/Parrot/Coroutine.pbc
lib/parrot/${PKGVERSION}/library/Parrot/Coroutine.pir
lib/parrot/${PKGVERSION}/library/Parrot/Exception.pbc
@ -205,6 +210,7 @@ lib/parrot/${PKGVERSION}/library/SDL/Rect.pir
lib/parrot/${PKGVERSION}/library/SDL/Sprite.pir
lib/parrot/${PKGVERSION}/library/SDL/StopWatch.pir
lib/parrot/${PKGVERSION}/library/SDL/Surface.pir
lib/parrot/${PKGVERSION}/library/SQLite3.pir
lib/parrot/${PKGVERSION}/library/Stream/Base.pbc
lib/parrot/${PKGVERSION}/library/Stream/Base.pir
lib/parrot/${PKGVERSION}/library/Stream/Combiner.pbc

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.15 2009/08/26 21:44:43 he Exp $
$NetBSD: distinfo,v 1.16 2009/09/20 10:57:04 he Exp $
SHA1 (parrot-1.5.0.tar.gz) = 5b79135f8b75ca54ff9c99eb3a32773489f8dd8d
RMD160 (parrot-1.5.0.tar.gz) = 4e4e2e774ba9ecf0f21d29ce56ad54dd21afe56a
Size (parrot-1.5.0.tar.gz) = 3961887 bytes
SHA1 (parrot-1.6.0.tar.gz) = 2258c3a0da32ed8c1ce55ee460e81a841d06a2c1
RMD160 (parrot-1.6.0.tar.gz) = ca5907643a9e972971daac51afd1b95a30103fa5
Size (parrot-1.6.0.tar.gz) = 3977952 bytes
SHA1 (patch-ad) = 9002a7ca55f8f960bea669e383431b3eeb83a878
SHA1 (patch-ae) = 72e4752112dab2f0b72ede5c45b77fd5b5554606
SHA1 (patch-af) = b65e915473887785fad48663f9682f8c14d634d9
SHA1 (patch-ag) = 254acf93b4d3709b22f8ece06d495b8a5f2a34d4

View file

@ -1,32 +0,0 @@
$NetBSD: patch-af,v 1.1 2009/08/26 21:44:43 he Exp $
Initialization of the math library version needs to be done
this way instead, ref. patch-ag
--- config/gen/platform/netbsd/misc.c.orig 2009-07-08 02:19:09.000000000 +0200
+++ config/gen/platform/netbsd/misc.c
@@ -26,17 +26,23 @@ Miscellaneous helper functions that are
=item C<void Parrot_platform_init_code(void)>
Initialize Parrot for the NetBSD platform.
-So far only turns off SIGFPE for Alpha.
+So far turns off SIGFPE for Alpha, and
+ensures IEEE floating-point semantics from
+the math library.
=cut
*/
#include <signal.h>
+#include <math.h>
void
Parrot_platform_init_code(void)
{
+
+ _LIB_VERSION = _IEEE_; /* force IEEE math semantics and behaviour */
+
#if defined(__alpha__)
signal(SIGFPE, SIG_IGN);
#endif

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ag,v 1.1 2009/08/26 21:44:43 he Exp $
Doing a static initialization causes this to be a local variable
in this object file. This does not override the library version
which is stored in a variable in the math library(!)
Instead, we need to initialize _LIB_VERSION in code, ref.
patch-af.
--- config/gen/platform/netbsd/math.c.orig 2009-07-08 02:19:09.000000000 +0200
+++ config/gen/platform/netbsd/math.c
@@ -22,14 +22,8 @@ math stuff
*/
-/*
- * force atan2() to use IEEE behavior
- */
-
#include <math.h>
-_LIB_VERSION_TYPE _LIB_VERSION = _IEEE_;
-
#if DOUBLE_SIZE == 2 * INT_SIZE
/*