Fixed "extra qualification" error message from g++4.
This commit is contained in:
parent
233a9844cb
commit
21ffa00cae
2 changed files with 33 additions and 1 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2007/03/24 00:03:30 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.7 2007/10/10 10:28:05 rillig Exp $
|
||||
|
||||
SHA1 (gsmlib-1.10.tar.gz) = 0f329f6185c0dd5221f85ee0af7d95dea23bed8f
|
||||
RMD160 (gsmlib-1.10.tar.gz) = 8abd1cdb4b61ddbb6fffd3a4100edcc0f079b845
|
||||
Size (gsmlib-1.10.tar.gz) = 474591 bytes
|
||||
SHA1 (patch-aa) = 9b86282d92c91bdc017f6966471de4b3621cf8b5
|
||||
SHA1 (patch-ab) = 3bfec0d0a3d82c7918e25bc46e83387203b5782b
|
||||
SHA1 (patch-ac) = aec51370b72ef60c086c3407b889bb54a720e07f
|
||||
|
|
31
comms/gsmlib/patches/patch-ac
Normal file
31
comms/gsmlib/patches/patch-ac
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ac,v 1.1 2007/10/10 10:28:05 rillig Exp $
|
||||
|
||||
--- gsmlib/gsm_me_ta.h.orig 2002-10-03 09:46:22.000000000 +0000
|
||||
+++ gsmlib/gsm_me_ta.h 2007-10-10 10:23:07.000000000 +0000
|
||||
@@ -291,8 +291,8 @@ namespace gsmlib
|
||||
// 3 disable phone receive RF circuits only
|
||||
// 4 disable phone both transmit and receive RF circuits
|
||||
// 5...127 implementation-defined
|
||||
- int MeTa::getFunctionalityLevel() throw(GsmException);
|
||||
- void MeTa::setFunctionalityLevel(int level) throw(GsmException);
|
||||
+ int getFunctionalityLevel() throw(GsmException);
|
||||
+ void setFunctionalityLevel(int level) throw(GsmException);
|
||||
|
||||
// return battery charge status (+CBC):
|
||||
// 0 ME is powered by the battery
|
||||
@@ -386,13 +386,13 @@ namespace gsmlib
|
||||
void setCallWaitingLockStatus(FacilityClass cl,
|
||||
bool lock)throw(GsmException);
|
||||
|
||||
- void MeTa::setCLIRPresentation(bool enable) throw(GsmException);
|
||||
+ void setCLIRPresentation(bool enable) throw(GsmException);
|
||||
//(+CLIR)
|
||||
|
||||
// 0:according to the subscription of the CLIR service
|
||||
// 1:CLIR invocation
|
||||
// 2:CLIR suppression
|
||||
- int MeTa::getCLIRPresentation() throw(GsmException);
|
||||
+ int getCLIRPresentation() throw(GsmException);
|
||||
|
||||
friend class Phonebook;
|
||||
friend class SMSStore;
|
Loading…
Reference in a new issue