Add xfpt 0.09
xfpt is a program that reads a marked-up ASCII source file, and converts it into XML. It was written with DocBook XML in mind, but can also be used for other forms of XML. Unlike AsciiDoc, xfpt does not try to produce XML from a document that is also usable as a freestanding ASCII document. The input for xfpt is very definitely "marked up". This makes it less ambiguous for large and/or complicated documents. xfpt is also much faster than AsciiDoc because it is written in C and does not rely on pattern matching.
This commit is contained in:
parent
19d3ce0ef5
commit
22072d146a
5 changed files with 80 additions and 0 deletions
8
textproc/xfpt/DESCR
Normal file
8
textproc/xfpt/DESCR
Normal file
|
@ -0,0 +1,8 @@
|
|||
xfpt is a program that reads a marked-up ASCII source file, and
|
||||
converts it into XML. It was written with DocBook XML in mind, but
|
||||
can also be used for other forms of XML. Unlike AsciiDoc, xfpt does
|
||||
not try to produce XML from a document that is also usable as a
|
||||
freestanding ASCII document. The input for xfpt is very definitely
|
||||
"marked up". This makes it less ambiguous for large and/or complicated
|
||||
documents. xfpt is also much faster than AsciiDoc because it is
|
||||
written in C and does not rely on pattern matching.
|
19
textproc/xfpt/Makefile
Normal file
19
textproc/xfpt/Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.1 2018/06/15 13:08:52 prlw1 Exp $
|
||||
|
||||
DISTNAME= xfpt-0.09
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/wordprocessing/unix/xfpt/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= prlw1@cam.ac.uk
|
||||
HOMEPAGE= https://github.com/Exim/exim/wiki/XpftDocs
|
||||
COMMENT= Converts simple plain text markup into DocBook XML
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAKE_ENV+= SHELL=${SH}
|
||||
|
||||
BUILD_TARGET= build
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
textproc/xfpt/PLIST
Normal file
5
textproc/xfpt/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2018/06/15 13:08:52 prlw1 Exp $
|
||||
bin/xfpt
|
||||
man/man1/xfpt.1
|
||||
share/xfpt/stdflags
|
||||
share/xfpt/stdmacs
|
7
textproc/xfpt/distinfo
Normal file
7
textproc/xfpt/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2018/06/15 13:08:52 prlw1 Exp $
|
||||
|
||||
SHA1 (xfpt-0.09.tar.bz2) = f556d54b9e4491dedcb5ece7b45244b13c09cce1
|
||||
RMD160 (xfpt-0.09.tar.bz2) = 656edeb5fd5126f04260b53d3025826230ea6ccc
|
||||
SHA512 (xfpt-0.09.tar.bz2) = 1e38f5708045e90ee89bc014bb065fde65baf8e9146e0d785a73fb679708e5fc9e6be6c3277697f20053706040544ea46dc539efb55bc66f569044e71afc4f2c
|
||||
Size (xfpt-0.09.tar.bz2) = 143944 bytes
|
||||
SHA1 (patch-Makefile.in) = 468e75cd7d3ba2c5280ee2f65329873fc8a08c13
|
41
textproc/xfpt/patches/patch-Makefile.in
Normal file
41
textproc/xfpt/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,41 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1 2018/06/15 13:08:52 prlw1 Exp $
|
||||
|
||||
Add destdir support.
|
||||
|
||||
--- Makefile.in.orig 2012-05-18 08:15:54.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -13,9 +13,10 @@ LFLAGS=@LFLAGS@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
|
||||
-BINDIR=@prefix@/bin
|
||||
-DATADIR=@prefix@/share/xfpt
|
||||
-MANDIR=@prefix@/man
|
||||
+prefix = @prefix@
|
||||
+BINDIR = @prefix@/bin
|
||||
+DATADIR = @datadir@/xfpt
|
||||
+MANDIR = @mandir@
|
||||
|
||||
# BINDIR is the directory in which the commands are installed.
|
||||
# DATADIR is the directory in which the include styles are installed.
|
||||
@@ -48,13 +49,13 @@ distclean:; rm Makefile config.cache
|
||||
test:; cd testing; runtest
|
||||
|
||||
install: build
|
||||
- $(mkinstalldirs) $(BINDIR)
|
||||
- $(mkinstalldirs) $(DATADIR)
|
||||
- $(mkinstalldirs) $(MANDIR)
|
||||
- $(mkinstalldirs) $(MANDIR)/man1
|
||||
- $(INSTALL) src/xfpt $(BINDIR)/xfpt
|
||||
- $(INSTALL_DATA) share/* $(DATADIR)
|
||||
- $(INSTALL_DATA) doc/xfpt.1 $(MANDIR)/man1
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(BINDIR)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(DATADIR)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(MANDIR)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(MANDIR)/man1
|
||||
+ $(INSTALL) src/xfpt $(DESTDIR)$(BINDIR)/xfpt
|
||||
+ $(INSTALL_DATA) share/* $(DESTDIR)$(DATADIR)
|
||||
+ $(INSTALL_DATA) doc/xfpt.1 $(DESTDIR)$(MANDIR)/man1
|
||||
|
||||
uninstall:; rm -rf \
|
||||
$(BINDIR)/xfpt \
|
Loading…
Reference in a new issue