Update to KDE SC 4.8.0.

remove kdeedu4
This commit is contained in:
markd 2012-03-20 08:56:16 +00:00
parent 3c3677c544
commit 22079d1a96
12 changed files with 0 additions and 4030 deletions

View file

@ -1,21 +0,0 @@
Edu{tainment,cation} tools for the KDE integrated X11 desktop:
* blinken: the KDE version of the well-known game Simon Says
* kalgebra: mathematics: editor and plotting
* kalzium: periodic table of elements
* kanagram: an anagram game
* kbruch: fraction excercise trainer
* kgeography: geography learning program
* khangman: hangman game. The child should guess a word letter by letter.
* kig: interactive geometry
* kiten: japanese reference tool
* klettres: helps child to learn the alphabet and to read some syllables
* kmplot: mathematical function plotter
* kpercentage: math application to improve skills in calculating percentages
* kstars: desktop planetarium
* ktouch: program for learning touch typing
* kturtle: educational programming environment
* kwordquiz: a powerful way to master new vocabularies
* marble: a virtual globe
* parley: vocabulary trainer
* step: a physics simulator

View file

@ -1,44 +0,0 @@
# $NetBSD: Makefile,v 1.23 2012/03/15 11:53:31 obache Exp $
DISTNAME= kdeedu-${_KDE_VERSION}
PKGREVISION= 6
CATEGORIES= misc
COMMENT= Edu{tainment,cation} tools for the KDE integrated X11 desktop
.include "../../meta-pkgs/kde4/Makefile.kde4"
# BUILD_MAKE_FLAGS+= VERBOSE=1
CMAKE_ARGS+= -DBUILD_kmplot:BOOL=OFF
CMAKE_ARGS+= -DWITH_SBIG:BOOL=OFF
CMAKE_ARGS+= -DWITH_R:BOOL=OFF
# CMAKE_ARGS+= -DWITH_PyKDE4:BOOL=OFF # "sip: MarblePlacemarkModel is undefined"
#XXX detection does not work reliably
CMAKE_ARGS+= -DWITH_BoostPython:BOOL=OFF
# eigen2.0.4 tries to use _M_erase_at_end - not defined.
CMAKE_ARGS+= -DBUILD_step:BOOL=OFF
USE_GNU_READLINE= yes
BROKEN_READLINE_DETECTION= yes
REPLACE_PYTHON+= kig/pykig/pykig.py
.include "../../meta-pkgs/kde4/kde4.mk"
#.include "../../lang/python/application.mk"
#.include "../../devel/boost-python/buildlink3.mk"
.include "../../devel/cfitsio/buildlink3.mk"
.include "../../devel/libusb/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../lang/python/application.mk"
#BUILDLINK_API_DEPENDS.eigen2+= eigen2>=2.0.3
#.include "../../math/eigen2/buildlink3.mk"
.include "../../print/libspectre/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/kdelibs4/buildlink3.mk"
.include "../../x11/kdebase-runtime4/buildlink3.mk"
.include "../../x11/kdebase-workspace4/buildlink3.mk"
.include "../../x11/kdebindings4-python/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,15 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.13 2012/03/03 00:12:33 wiz Exp $
BUILDLINK_TREE+= kdeedu4
.if !defined(KDEEDU4_BUILDLINK3_MK)
KDEEDU4_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.kdeedu4+= kdeedu4>=4.1.1
BUILDLINK_ABI_DEPENDS.kdeedu4?= kdeedu4>=4.5.5nb5
BUILDLINK_PKGSRCDIR.kdeedu4?= ../../misc/kdeedu4
.include "../../x11/kdelibs4/buildlink3.mk"
.endif # KDEEDU4_BUILDLINK3_MK
BUILDLINK_TREE+= -kdeedu4

View file

@ -1,12 +0,0 @@
$NetBSD: distinfo,v 1.14 2011/01/23 07:55:13 markd Exp $
SHA1 (kdeedu-4.5.5.tar.bz2) = c43db1c4689b18b7eda12810f05d9d3ca12055c2
RMD160 (kdeedu-4.5.5.tar.bz2) = 98837a2944fe4f31f6b8c17dbe5a1b02b8a55bea
Size (kdeedu-4.5.5.tar.bz2) = 65714124 bytes
SHA1 (patch-aa) = 5e2f12e2c70e438524ace2d238c9119dd36695ed
SHA1 (patch-ab) = 2ff0e901376e5a01abc26799049eb738b3eb2fd8
SHA1 (patch-ae) = 412adfe31664db087e66ce73428ee775dff858d3
SHA1 (patch-af) = 0a8691662dee0950102bdd5c688a545a98834226
SHA1 (patch-an) = 46ffc8f0602586eadffe8c772e7b5cb4a69f62e3
SHA1 (patch-ao) = e283188c1cc6e2ab76c66332c2c93c19a32052c3
SHA1 (patch-ap) = 8e9e64b89f855d9cb1ebfc52145e90effc838673

View file

@ -1,16 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/10/02 20:51:26 markd Exp $
--- kig/objects/circle_type.cc.orig 2007-12-10 00:02:17.000000000 +1300
+++ kig/objects/circle_type.cc
@@ -27,6 +27,11 @@
#include <klocale.h>
+#ifdef __NetBSD__
+#define fmin(a,b) ((a) < (b) ? (a) : (b))
+#define fmax(a,b) ((a) > (b) ? (a) : (b))
+#endif
+
static const char constructcirclethroughpointstat[] = I18N_NOOP( "Construct a circle through this point" );
static const char constructcirclewithcenterstat[] = I18N_NOOP( "Construct a circle with this center" );

View file

@ -1,30 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/10/02 20:51:26 markd Exp $
--- kmplot/kmplot/parser.cpp.orig 2008-11-29 04:33:54.000000000 +1300
+++ kmplot/kmplot/parser.cpp
@@ -102,9 +102,13 @@ ScalarFunction Parser::scalarFunctions[
{"floor", 0, floor}, // round down to nearest integer
{"ceil", 0, ceil}, // round up to nearest integer
{"round", 0, round}, // round to nearest integer
+#ifndef __NetBSD__
{"gamma", 0, tgamma}, // gamma function
+#endif
{"lgamma", 0, lgamma}, // log-gamma function
+#ifndef __NetBSD__
{"factorial", 0, factorial}, // factorial
+#endif
{"erfc", 0, lerfc}, // error function
{"erf", 0, lerf}, // complementary error function
@@ -1340,9 +1344,11 @@ double larcsin(double x) {
double larctan(double x) {
return atan(x) / Parser::radiansPerAngleUnit();
}
+#ifndef __NetBSD__
double factorial( double x ) {
return tgamma(x+1);
}
+#endif
double legendre0( double ) {
return 1.0;
}

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 2009/10/02 20:51:26 markd Exp $
--- kalgebra/src/graph2d.cpp.orig 2007-12-15 07:19:44.000000000 +1300
+++ kalgebra/src/graph2d.cpp
@@ -86,6 +86,11 @@ void Graph2D::drawAxes(QPainter *f, Axe
//EO write coords
}
+#ifdef __NetBSD__
+#define fmin(a,b) ((a)<(b)?(a):(b))
+#define fmax(a,b) ((a)>(b)?(a):(b))
+#endif
+
void Graph2D::drawPolarAxes(QPainter *w)
{
QPen ceixos;

View file

@ -1,15 +0,0 @@
$NetBSD: patch-af,v 1.1.1.1 2009/10/02 20:51:26 markd Exp $
Need to fix this (back) for linux.
--- cmake/modules/FindReadline.cmake.orig 2007-12-16 08:48:08.000000000 +1300
+++ cmake/modules/FindReadline.cmake
@@ -7,7 +7,7 @@ else(READLINE_INCLUDE_DIR AND READLINE_L
)
FIND_LIBRARY(READLINE_LIBRARY NAMES readline)
- FIND_LIBRARY(NCURSES_LIBRARY NAMES ncurses )
+ FIND_LIBRARY(NCURSES_LIBRARY NAMES termcap )
include(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(Readline DEFAULT_MSG NCURSES_LIBRARY READLINE_INCLUDE_DIR READLINE_LIBRARY )

View file

@ -1,15 +0,0 @@
$NetBSD: patch-an,v 1.1.1.1 2009/10/02 20:51:26 markd Exp $
--- step/stepcore/world.h.orig 2009-06-10 04:08:28.000000000 +1200
+++ step/stepcore/world.h
@@ -23,6 +23,10 @@
#ifndef STEPCORE_WORLD_H
#define STEPCORE_WORLD_H
+#ifdef __NetBSD__
+#define fmin(a,b) ((a) < (b) ? (a) : (b))
+#endif
+
#include "types.h"
#include "util.h"
#include "object.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ao,v 1.2 2010/10/25 20:55:25 markd Exp $
--- kig/objects/object_factory.cc.orig 2010-06-08 10:11:01.000000000 +0000
+++ kig/objects/object_factory.cc
@@ -41,6 +41,10 @@
#include <limits>
#include <iterator>
+#ifdef __NetBSD__
+#define fmin(a,b) ((a) < (b) ? (a) : (b))
+#endif
+
ObjectHolder* ObjectFactory::fixedPoint( const Coordinate& c ) const
{
ObjectHolder* o = new ObjectHolder( fixedPointCalcer( c ) );

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ap,v 1.1 2011/01/10 11:16:34 markd Exp $
--- kstars/kstars/htmesh/SkipListElement.h.orig 2010-06-08 10:11:38.000000000 +0000
+++ kstars/kstars/htmesh/SkipListElement.h
@@ -22,7 +22,7 @@
#ifdef _WIN32
#define KEY_MAX _I64_MAX
#else
-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || ( defined(__SUNPRO_CC) && defined(__sun) )
+# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || ( defined(__SUNPRO_CC) && defined(__sun) )
# define KEY_MAX LLONG_MAX
# else
# define KEY_MAX LONG_LONG_MAX