Update to 2.4.9. From Leonardo Taccari in PR 49920.
WebKitGTK+ 2.4.9 released! This is a bug fix release in the stable 2.4 series. What’s new in the WebKitGTK+ 2.4.9 release? o Check TLS errors as soon as they are set in the SoupMessage to prevent any data from being sent to the server in case of invalid certificate. o Clear the GObject DOM bindings internal cache when frames are destroyed or web view contents are updated. o Add HighDPI support for non-accelerated compositing contents. o Fix some transfer annotations used in GObject DOM bindings. o Use latin1 instead of UTF-8 for HTTP header values. o Fix synchronous loads when maximum connection limits are reached. o Fix a crash ScrollView::contentsToWindow() when GtkPluginWidget doesn’t have a parent. o Fix a memory leak in webkit_web_policy_decision_new. o Fix g_closure_unref runtime warning. o Fix a crash due to empty drag image during drag and drop. o Fix rendering of scrollbars with GTK+ >= 3.16. o Fix the build on mingw32/msys. o Fix the build with WebKit2 disabled. o Fix the build with accelerated compositing disabled. o Fix clang version check in configure. o Fix the build with recent versions of GLib that have GMutexLocker. o Fix the build for Linux/MIPS64EL.
This commit is contained in:
parent
4a035e8da2
commit
220ac87ea6
4 changed files with 18 additions and 36 deletions
|
@ -1,6 +1,5 @@
|
|||
# $NetBSD: Makefile,v 1.89 2015/04/25 14:25:02 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.90 2015/05/28 05:30:51 wiz Exp $
|
||||
|
||||
PKGREVISION= 2
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/webkitgtk/webkit-gtk/}
|
||||
|
|
|
@ -1,13 +1,14 @@
|
|||
# $NetBSD: Makefile.common,v 1.40 2015/03/31 15:55:44 joerg Exp $
|
||||
# $NetBSD: Makefile.common,v 1.41 2015/05/28 05:30:51 wiz Exp $
|
||||
# used by www/webkit-gtk/Makefile
|
||||
|
||||
DISTNAME= webkitgtk-2.4.8
|
||||
DISTNAME= webkitgtk-2.4.9
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.webkitgtk.org/releases/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.webkitgtk.org/
|
||||
LICENSE= 2-clause-bsd AND gnu-lgpl-v2
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../../www/webkit-gtk/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../www/webkit-gtk/patches
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.74 2015/03/24 14:30:29 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.75 2015/05/28 05:30:51 wiz Exp $
|
||||
|
||||
SHA1 (webkitgtk-2.4.8.tar.xz) = 44c6bbe52108297126830525619c1df047886a6f
|
||||
RMD160 (webkitgtk-2.4.8.tar.xz) = 24f812f3989baa67e165c1076923020c37df9501
|
||||
Size (webkitgtk-2.4.8.tar.xz) = 9827632 bytes
|
||||
SHA1 (webkitgtk-2.4.9.tar.xz) = fbe02db8a4f01a70e7cdf0d16f8a18463e18b104
|
||||
RMD160 (webkitgtk-2.4.9.tar.xz) = 122468435539d69665d5206ae266fb36ff2d86c2
|
||||
Size (webkitgtk-2.4.9.tar.xz) = 9840740 bytes
|
||||
SHA1 (patch-Source_JavaScriptCore_ForwardingHeaders_JavaScriptCore_JSCallbackFunction.h) = 79122450435eb12a57086d18e5410eec131c33b2
|
||||
SHA1 (patch-Source_JavaScriptCore_assembler_ARMAssembler.h) = 2ff343ac53b14af0692754a44059e7d2ea969b96
|
||||
SHA1 (patch-Source_JavaScriptCore_assembler_MacroAssemblerARM.cpp) = 69221390dd5fdac55abf341c5ae3a03267e38ae6
|
||||
|
@ -18,4 +18,4 @@ SHA1 (patch-ai) = 8e174c68e4ba06fdd6edd64fd6df3328faf9055f
|
|||
SHA1 (patch-aj) = d35a4b26e2104cdf7f3be81b020aabb4779dfaad
|
||||
SHA1 (patch-ak) = 477fd5c05abee8f47842a6ad5aba00e3e4628c45
|
||||
SHA1 (patch-am) = e0a350feb14d739010000e3887971bd535a647a7
|
||||
SHA1 (patch-configure) = a64ca0729ab3011e64045b683aed63f89811a4a0
|
||||
SHA1 (patch-configure) = 19f28160d9da63d98dac4eadbb30f5e8250ffcbe
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
||||
$NetBSD: patch-configure,v 1.8 2015/05/28 05:30:51 wiz Exp $
|
||||
|
||||
--- configure.orig 2014-07-08 09:44:12.000000000 +0000
|
||||
--- configure.orig 2015-05-20 09:29:21.000000000 +0000
|
||||
+++ configure
|
||||
@@ -4703,7 +4703,7 @@ else
|
||||
@@ -4709,7 +4709,7 @@ else
|
||||
We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
since some C++ compilers masquerading as C compilers
|
||||
incorrectly reject 9223372036854775807. */
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
|||
int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
&& LARGE_OFF_T % 2147483647 == 1)
|
||||
? 1 : -1];
|
||||
@@ -4749,7 +4749,7 @@ else
|
||||
@@ -4755,7 +4755,7 @@ else
|
||||
We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
since some C++ compilers masquerading as C compilers
|
||||
incorrectly reject 9223372036854775807. */
|
||||
|
@ -20,7 +20,7 @@ $NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
|||
int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
&& LARGE_OFF_T % 2147483647 == 1)
|
||||
? 1 : -1];
|
||||
@@ -4773,7 +4773,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
@@ -4779,7 +4779,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
since some C++ compilers masquerading as C compilers
|
||||
incorrectly reject 9223372036854775807. */
|
||||
|
@ -29,7 +29,7 @@ $NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
|||
int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
&& LARGE_OFF_T % 2147483647 == 1)
|
||||
? 1 : -1];
|
||||
@@ -4818,7 +4818,7 @@ else
|
||||
@@ -4824,7 +4824,7 @@ else
|
||||
We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
since some C++ compilers masquerading as C compilers
|
||||
incorrectly reject 9223372036854775807. */
|
||||
|
@ -38,7 +38,7 @@ $NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
|||
int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
&& LARGE_OFF_T % 2147483647 == 1)
|
||||
? 1 : -1];
|
||||
@@ -4842,7 +4842,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
@@ -4848,7 +4848,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
since some C++ compilers masquerading as C compilers
|
||||
incorrectly reject 9223372036854775807. */
|
||||
|
@ -47,25 +47,7 @@ $NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
|||
int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
&& LARGE_OFF_T % 2147483647 == 1)
|
||||
? 1 : -1];
|
||||
@@ -4909,7 +4909,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
-#if !(defined(__clang__) && __clang_major__ >= 3 && __clang_minor__ >= 3)
|
||||
+#if !(defined(__clang__) && __clang_major__ >= 3 && (__clang_major__ > 3 || __clang_minor__ >= 3))
|
||||
#error Not a supported Clang compiler
|
||||
#endif
|
||||
|
||||
@@ -4967,7 +4967,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
-#if !(defined(__clang__) && __clang_major__ >= 3 && __clang_minor__ >= 3)
|
||||
+#if !(defined(__clang__) && __clang_major__ >= 3 && (__clang_major__ > 3 || __clang_minor__ >= 3))
|
||||
#error Not a supported Clang++ compiler
|
||||
#endif
|
||||
|
||||
@@ -17312,10 +17312,13 @@ int
|
||||
@@ -17318,10 +17318,13 @@ int
|
||||
main ()
|
||||
{
|
||||
unsigned int major, minor, micro;
|
||||
|
@ -80,7 +62,7 @@ $NetBSD: patch-configure,v 1.7 2014/08/21 04:51:08 dbj Exp $
|
|||
printf("%s, bad version string\n", "$min_glib_version");
|
||||
exit(1);
|
||||
}
|
||||
@@ -21110,7 +21113,7 @@ fi
|
||||
@@ -21217,7 +21220,7 @@ fi
|
||||
|
||||
|
||||
# On some Linux/Unix platforms, shm_* may only be available if linking against librt
|
||||
|
|
Loading…
Reference in a new issue