Import nghttp2-1.0.1 as www/nghttp2.
nghttp2 is an implementation of HTTP/2 and its header compression algorithm HPACK in C.
This commit is contained in:
parent
606c38fdd6
commit
2228730ef3
7 changed files with 139 additions and 0 deletions
1
www/nghttp2/DESCR
Normal file
1
www/nghttp2/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
nghttp2 is an implementation of HTTP/2 in C.
|
27
www/nghttp2/Makefile
Normal file
27
www/nghttp2/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.1 2015/06/03 11:53:53 fhajny Exp $
|
||||
|
||||
DISTNAME= nghttp2-1.0.1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=tatsuhiro-t/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://nghttp2.org/
|
||||
COMMENT= Implementation of HTTP/2 in C
|
||||
LICENSE= mit
|
||||
|
||||
GITHUB_RELEASE= v${PKGVERSION_NOREV}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
PKGCONFIG_OVERRIDE+= lib/libnghttp2.pc.in
|
||||
PKGCONFIG_OVERRIDE+= src/libnghttp2_asio.pc.in
|
||||
|
||||
CONFIGURE_ARGS+= --disable-examples
|
||||
CONFIGURE_ARGS+= --disable-python-bindings
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
22
www/nghttp2/PLIST
Normal file
22
www/nghttp2/PLIST
Normal file
|
@ -0,0 +1,22 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2015/06/03 11:53:53 fhajny Exp $
|
||||
${PLIST.tools}bin/deflatehd
|
||||
${PLIST.tools}bin/h2load
|
||||
${PLIST.tools}bin/inflatehd
|
||||
${PLIST.tools}bin/nghttp
|
||||
${PLIST.tools}bin/nghttpd
|
||||
${PLIST.tools}bin/nghttpx
|
||||
${PLIST.asio}include/nghttp2/asio_http2.h
|
||||
${PLIST.asio}include/nghttp2/asio_http2_client.h
|
||||
${PLIST.asio}include/nghttp2/asio_http2_server.h
|
||||
include/nghttp2/nghttp2.h
|
||||
include/nghttp2/nghttp2ver.h
|
||||
lib/libnghttp2.la
|
||||
${PLIST.asio}lib/libnghttp2_asio.la
|
||||
lib/pkgconfig/libnghttp2.pc
|
||||
${PLIST.asio}lib/pkgconfig/libnghttp2_asio.pc
|
||||
man/man1/h2load.1
|
||||
man/man1/nghttp.1
|
||||
man/man1/nghttpd.1
|
||||
man/man1/nghttpx.1
|
||||
share/doc/nghttp2/README.rst
|
||||
share/nghttp2/fetch-ocsp-response
|
21
www/nghttp2/buildlink3.mk
Normal file
21
www/nghttp2/buildlink3.mk
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2015/06/03 11:53:53 fhajny Exp $
|
||||
|
||||
BUILDLINK_TREE+= nghttp2
|
||||
|
||||
.if !defined(NGHTTP2_BUILDLINK3_MK)
|
||||
NGHTTP2_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.nghttp2+= nghttp2>=1.0.0
|
||||
BUILDLINK_ABI_DEPENDS.nghttp2+= nghttp2>=1.0.0
|
||||
BUILDLINK_PKGSRCDIR.nghttp2?= ../../www/nghttp2
|
||||
|
||||
pkgbase := nghttp2
|
||||
.include "../../mk/pkg-build-options.mk"
|
||||
|
||||
.if !empty(PKG_BUILD_OPTIONS.nghttp2:Mnghttp2-asio)
|
||||
. include "../../devel/boost-libs/buildlink3.mk"
|
||||
. include "../../security/openssl/buildlink3.mk"
|
||||
.endif
|
||||
.endif # NGHTTP2_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -nghttp2
|
6
www/nghttp2/distinfo
Normal file
6
www/nghttp2/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2015/06/03 11:53:53 fhajny Exp $
|
||||
|
||||
SHA1 (nghttp2-1.0.1.tar.gz) = 6dc5a07e8f5a0351ca388e5d30c0978fe0530fee
|
||||
RMD160 (nghttp2-1.0.1.tar.gz) = e6b7fa4d2502506b7cef6967b4e88a490a5e238d
|
||||
Size (nghttp2-1.0.1.tar.gz) = 1350918 bytes
|
||||
SHA1 (patch-configure) = 7a776cad97a6590d3bbef93ffee6815341719f46
|
47
www/nghttp2/options.mk
Normal file
47
www/nghttp2/options.mk
Normal file
|
@ -0,0 +1,47 @@
|
|||
# $NetBSD: options.mk,v 1.1 2015/06/03 11:53:53 fhajny Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.nghttp2
|
||||
PKG_SUPPORTED_OPTIONS= nghttp2-asio nghttp2-tools
|
||||
PKG_SUGGESTED_OPTIONS= #
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= asio tools
|
||||
|
||||
###
|
||||
### Build the ASIO C++ library
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mnghttp2-asio)
|
||||
# Requires emplace() for associative containers, introduced in gcc 4.8.0
|
||||
GCC_REQD+= 4.8
|
||||
CONFIGURE_ARGS+= --enable-asio-lib
|
||||
CONFIGURE_ARGS+= --with-boost=${BUILDLINK_PREFIX.boost-libs}
|
||||
CONFIGURE_ARGS+= --with-boost-asio --with-boost-system --with-boost-thread
|
||||
PLIST.asio= yes
|
||||
.include "../../devel/boost-libs/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-boost=no
|
||||
.endif
|
||||
|
||||
###
|
||||
### Build apps and tools
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mnghttp2-tools)
|
||||
# Requires emplace() for associative containers, introduced in gcc 4.8.0
|
||||
GCC_REQD+= 4.8
|
||||
CONFIGURE_ARGS+= --enable-app
|
||||
CONFIGURE_ARGS+= --enable-hpack-tools
|
||||
CONFIGURE_ARGS+= --with-spdylay
|
||||
PLIST.tools= yes
|
||||
.include "../../devel/libev/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../textproc/jansson/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../www/spdylay/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-app
|
||||
CONFIGURE_ARGS+= --disable-hpack-tools
|
||||
CONFIGURE_ARGS+= --without-spdylay
|
||||
.endif
|
15
www/nghttp2/patches/patch-configure
Normal file
15
www/nghttp2/patches/patch-configure
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-configure,v 1.1 2015/06/03 11:53:53 fhajny Exp $
|
||||
|
||||
Portability.
|
||||
|
||||
--- configure.orig 2015-05-24 10:28:58.000000000 +0000
|
||||
+++ configure
|
||||
@@ -18634,7 +18634,7 @@ else
|
||||
$as_echo "yes" >&6; }
|
||||
have_jansson=yes
|
||||
fi
|
||||
-if test "x${have_jansson}" == "xyes"; then
|
||||
+if test "x${have_jansson}" = "xyes"; then
|
||||
|
||||
$as_echo "#define HAVE_JANSSON 1" >>confdefs.h
|
||||
|
Loading…
Reference in a new issue