PR 54310: fix out of bounds memory write, analyzed and fix provided
by Harold Gutch. Already reported upstream. Bump pkg revision.
This commit is contained in:
parent
21f7444a7d
commit
223db659b8
3 changed files with 20 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.253 2020/10/04 20:39:25 thorpej Exp $
|
||||
# $NetBSD: Makefile,v 1.254 2020/10/10 16:29:21 martin Exp $
|
||||
|
||||
DISTNAME= qemu-5.1.0
|
||||
PKGREVISION= 6
|
||||
PKGREVISION= 7
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= https://download.qemu.org/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.164 2020/10/04 20:39:25 thorpej Exp $
|
||||
$NetBSD: distinfo,v 1.165 2020/10/10 16:29:21 martin Exp $
|
||||
|
||||
SHA1 (palcode-clipper) = e25ae10a10e0801e47b62b9ee2d10c8ccb4ee940
|
||||
RMD160 (palcode-clipper) = a637f1cc38dabfdff36e3f02b6dd02d7c63cb8db
|
||||
|
@ -23,6 +23,7 @@ SHA1 (patch-hw_core_uboot__image.h) = 17eef02349343c5fcfb7a4069cb6f8fd11efcb59
|
|||
SHA1 (patch-hw_display_omap__dss.c) = 6b13242f28e32346bc70548c216c578d98fd3420
|
||||
SHA1 (patch-hw_net_etraxfs__eth.c) = e5dd1661d60dbcd27b332403e0843500ba9544bc
|
||||
SHA1 (patch-hw_net_xilinx__axienet.c) = ebcd2676d64ce6f31e4a8c976d4fdf530ad5e8b7
|
||||
SHA1 (patch-hw_pci-host_sabre.c) = 75c076757ed96fc9f89cb0159f00c6cedcb39a27
|
||||
SHA1 (patch-hw_rtc_mc146818rtc.c) = cc7a3b28010966b65b7a16db756226ac2669f310
|
||||
SHA1 (patch-hw_scsi_scsi-disk.c) = fdbf2f962a6dcb1a115a7f8a5b8790ff9295fb33
|
||||
SHA1 (patch-hw_usb_dev-mtp.c) = 0f9034fb3904e5d5e3b98d24b94e054181687d95
|
||||
|
|
16
emulators/qemu/patches/patch-hw_pci-host_sabre.c
Normal file
16
emulators/qemu/patches/patch-hw_pci-host_sabre.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-hw_pci-host_sabre.c,v 1.1 2020/10/10 16:29:21 martin Exp $
|
||||
|
||||
Legacy OBIO IRQs on sabre have numbers between 32 and 64, so raise
|
||||
number of IRQs to 64. Fixes PR 54310.
|
||||
|
||||
--- hw/pci-host/sabre.c.orig 2020-08-11 21:17:15.000000000 +0200
|
||||
+++ hw/pci-host/sabre.c 2020-10-10 17:37:52.445284000 +0200
|
||||
@@ -396,7 +396,7 @@
|
||||
pci_sabre_set_irq, pci_sabre_map_irq, s,
|
||||
&s->pci_mmio,
|
||||
&s->pci_ioport,
|
||||
- 0, 32, TYPE_PCI_BUS);
|
||||
+ 0, 64, TYPE_PCI_BUS);
|
||||
|
||||
pci_create_simple(phb->bus, 0, TYPE_SABRE_PCI_DEVICE);
|
||||
|
Loading…
Reference in a new issue