Traceroute-nanog is based on the Van Jacobson/BSD traceroute and has
additional features like AS lookup, TOS support, microsecond timestamps, path MTU discovery, parallel probing and others.
This commit is contained in:
parent
3998d489e6
commit
22753ae205
5 changed files with 99 additions and 0 deletions
3
net/traceroute-nanog/DESCR
Normal file
3
net/traceroute-nanog/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
Traceroute-nanog is based on the Van Jacobson/BSD traceroute and has
|
||||
additional features like AS lookup, TOS support, microsecond timestamps,
|
||||
path MTU discovery, parallel probing and others.
|
62
net/traceroute-nanog/Makefile
Normal file
62
net/traceroute-nanog/Makefile
Normal file
|
@ -0,0 +1,62 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/03/14 18:19:22 pettai Exp $
|
||||
|
||||
DISTNAME= traceroute-nanog-6.4.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.login.com/pub/software/traceroute/
|
||||
MASTER_SITES+= http://gd.tuwien.ac.at/infosys/network/tools/traceroute/
|
||||
DISTFILES= traceroute.c
|
||||
DIST_SUBDIR= traceroute-nanog
|
||||
|
||||
# for the man page:
|
||||
PATCH_SITES= ${MASTER_SITE_DEBIAN:=pool/main/t/traceroute-nanog/}
|
||||
PATCHFILES= traceroute-nanog_6.3.10-2.diff.gz
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
COMMENT= Traceroute implementation with extend features
|
||||
MAINTAINER= schwarz@NetBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
NO_CONFIGURE= YES
|
||||
USE_FEATURES+= snprintf
|
||||
|
||||
TRN_EXTRALIBS=
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.if empty(PKGSRC_COMPILER:Mgcc*)
|
||||
CPPFLAGS+= -D__attribute__=
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
.if ${OS_VERSION} >= 5.0
|
||||
.if ${OS_VERSION} != 5.4
|
||||
CPPFLAGS+= -DSOLARIS
|
||||
TRN_EXTRALIBS+= -lresolv -lsocket -lnsl
|
||||
.endif
|
||||
.if ${LOWER_ARCH} == "i386"
|
||||
CPPFLAGS+= -DBYTESWAP_IP_LEN
|
||||
.endif
|
||||
.endif
|
||||
.elif ${OPSYS} == "Linux"
|
||||
TRN_EXTRALIBS+= -lresolv
|
||||
CPPFLAGS+= -DSTRING
|
||||
.elif ${OPSYS} == "FreeBSD"
|
||||
CPPFLAGS+= -DSTRING
|
||||
.elif ${OPSYS} == "Darwin"
|
||||
CPPFLAGS+= -DBIND_8_COMPAT -DRA_SERVICE=\"nicname\"
|
||||
.elif !empty(LOWER_OPSYS:Mirix5*)
|
||||
CPPFLAGS+= -Dsocklen_t=int
|
||||
.endif
|
||||
|
||||
INSTALLATION_DIRS= sbin ${PKGMANDIR}/man8
|
||||
|
||||
do-extract:
|
||||
${CP} ${DISTDIR}/${DIST_SUBDIR}/traceroute.c ${WRKSRC}
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${CC} ${CPPFLAGS} ${CFLAGS} traceroute.c -o traceroute-nanog ${LDFLAGS} -lm ${TRN_EXTRALIBS}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/traceroute-nanog ${DESTDIR}${PREFIX}/sbin
|
||||
${INSTALL_MAN} ${WRKDIR}/traceroute-nanog-6.3.10/debian/traceroute-nanog.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
net/traceroute-nanog/PLIST
Normal file
3
net/traceroute-nanog/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/03/14 18:19:22 pettai Exp $
|
||||
sbin/traceroute-nanog
|
||||
man/man8/traceroute-nanog.8
|
9
net/traceroute-nanog/distinfo
Normal file
9
net/traceroute-nanog/distinfo
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/03/14 18:19:22 pettai Exp $
|
||||
|
||||
SHA1 (traceroute-nanog/traceroute-nanog_6.3.10-2.diff.gz) = 80c45e405eed93e29d036f759ea39b6f9f2e3da1
|
||||
RMD160 (traceroute-nanog/traceroute-nanog_6.3.10-2.diff.gz) = ed24a3f466448829d397a7034bc5dc1611d243db
|
||||
Size (traceroute-nanog/traceroute-nanog_6.3.10-2.diff.gz) = 16699 bytes
|
||||
SHA1 (traceroute-nanog/traceroute.c) = f7a160f95488c2c8aa976d168944fc6d0514792b
|
||||
RMD160 (traceroute-nanog/traceroute.c) = 07d5c0b2da83d2444c337cd7a791e33e2e3d4226
|
||||
Size (traceroute-nanog/traceroute.c) = 107519 bytes
|
||||
SHA1 (patch-aa) = f400adc5be4c7f3a3fda54f65a66f02dbd61431b
|
22
net/traceroute-nanog/patches/patch-aa
Normal file
22
net/traceroute-nanog/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/03/14 18:19:22 pettai Exp $
|
||||
|
||||
--- traceroute.c.orig 2006-05-06 11:10:00.000000000 +0000
|
||||
+++ traceroute.c
|
||||
@@ -750,17 +750,6 @@ void cksum(u_int16_t *, int, volatile u_
|
||||
#undef IP_HDRINCL
|
||||
#endif
|
||||
|
||||
-#ifndef vms
|
||||
-extern int errno;
|
||||
-#endif
|
||||
-
|
||||
-extern char *inet_ntoa();
|
||||
-extern u_long inet_addr();
|
||||
-
|
||||
-#ifndef ULTRIX43
|
||||
-char *index(const char *string, int character);
|
||||
-#endif
|
||||
-
|
||||
#ifdef V630
|
||||
#ifndef __linux__
|
||||
void halt(); /* signal handler */
|
Loading…
Reference in a new issue