Remove streamripper-current, used for updating streamripper.
This commit is contained in:
parent
ef29230470
commit
2275a6185f
10 changed files with 3 additions and 97 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.518 2015/01/17 00:16:40 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.519 2015/02/19 00:21:55 wiz Exp $
|
||||
#
|
||||
|
||||
COMMENT= Audio tools
|
||||
|
@ -434,7 +434,6 @@ SUBDIR+= splay
|
|||
SUBDIR+= sptk
|
||||
SUBDIR+= squeezeboxserver
|
||||
SUBDIR+= streamripper
|
||||
SUBDIR+= streamripper-current
|
||||
SUBDIR+= streamtuner
|
||||
SUBDIR+= sweep
|
||||
SUBDIR+= taglib
|
||||
|
|
|
@ -1,5 +0,0 @@
|
|||
Using information which a SHOUTcast server can optionally send, this program
|
||||
breaks an audio stream into "tracks," stores them in separate files as they
|
||||
arrive, and names the files by appending ".mp3" to the name of the track.
|
||||
The tracks can be listened to at the user's leisure with an MPEG Layer 3
|
||||
audio player.
|
|
@ -1,25 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.7 2012/10/02 23:48:10 asau Exp $
|
||||
#
|
||||
|
||||
DISTNAME= streamripper-1.64.3
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=streamripper/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://streamripper.sourceforge.net/
|
||||
COMMENT= Splits SHOUTcast stream into tracks
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --without-included-libmad
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PTHREAD_OPTS+= require
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../audio/libmad/buildlink3.mk"
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,3 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
bin/streamripper
|
||||
man/man1/streamripper.1
|
|
@ -1,8 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.2 2012/02/15 22:55:16 hans Exp $
|
||||
|
||||
SHA1 (streamripper-1.64.3.tar.gz) = 08dff7b4e48e16ad581e0b28fb77bdcddeeee0bb
|
||||
RMD160 (streamripper-1.64.3.tar.gz) = d0d5d18fc7e5086bb768e6a51e566e16f0ced730
|
||||
Size (streamripper-1.64.3.tar.gz) = 857175 bytes
|
||||
SHA1 (patch-ac) = b22e18723d4888d78f0e5e01e0db40f010b15f96
|
||||
SHA1 (patch-ad) = 583dbf02c8adf75eccdfea8c0e8aa181e89256de
|
||||
SHA1 (patch-lib_ripstream.c) = 4cc71c5d58cec36711d9c90a327dea9f466cec2a
|
|
@ -1,14 +0,0 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.streamripper
|
||||
PKG_SUPPORTED_OPTIONS= ogg
|
||||
PKG_SUGGESTED_OPTIONS= ogg
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mogg)
|
||||
. include "../../audio/libvorbis/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-ogg=${BUILDLINK_PREFIX.libvorbis}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-ogg
|
||||
.endif
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
--- lib/argv.c.orig 2007-08-14 17:33:03.000000000 +0200
|
||||
+++ lib/argv.c
|
||||
@@ -33,7 +33,7 @@ void freeargv (char **vector);
|
||||
|
||||
/* Routines imported from standard C runtime libraries. */
|
||||
|
||||
-#ifdef ANSI_PROTOTYPES
|
||||
+#if 1
|
||||
|
||||
#include <stddef.h>
|
||||
#include <string.h>
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
--- ./lib/mchar.c.orig 2008-12-11 05:48:39.000000000 +0100
|
||||
+++ ./lib/mchar.c
|
||||
@@ -48,7 +48,7 @@
|
||||
#define vsnprintf _vsnprintf
|
||||
// #define vswprintf _vsnwprintf
|
||||
#else
|
||||
- #define ICONV_WCHAR "WCHAR_T"
|
||||
+ #define ICONV_WCHAR "ucs-4"
|
||||
/* This prototype is missing in some systems */
|
||||
// int vswprintf (wchar_t * ws, size_t n, const wchar_t * format, va_list arg);
|
||||
#endif
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-lib_ripstream.c,v 1.1 2012/02/15 22:55:16 hans Exp $
|
||||
|
||||
--- lib/ripstream.c.orig 2008-12-27 15:32:07.000000000 +0100
|
||||
+++ lib/ripstream.c 2012-01-11 21:38:08.772278869 +0100
|
||||
@@ -731,7 +731,7 @@ write_id3v2_frame(RIP_MANAGER_INFO* rmi,
|
||||
char bigbuf[HEADER_SIZE] = "";
|
||||
ID3V2frame id3v2frame;
|
||||
#ifndef WIN32
|
||||
- __uint32_t framesize = 0;
|
||||
+ uint32_t framesize = 0;
|
||||
#else
|
||||
unsigned long int framesize = 0;
|
||||
#endif
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES-2015,v 1.959 2015/02/19 00:20:57 wiz Exp $
|
||||
$NetBSD: CHANGES-2015,v 1.960 2015/02/19 00:21:55 wiz Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2015:
|
||||
|
||||
|
@ -1403,3 +1403,4 @@ Changes to the packages collection and infrastructure in 2015:
|
|||
Updated meta-pkgs/bulk-large to 20150218 [jperkin 2015-02-18]
|
||||
Updated sysutils/estd to 0.11 [wiz 2015-02-19]
|
||||
Updated audio/streamripper to 1.64.6 [wiz 2015-02-19]
|
||||
Removed audio/streamripper-current successor audio/streamripper [wiz 2015-02-19]
|
||||
|
|
Loading…
Reference in a new issue