Added a patch that fixes the interpreter path of the installed Python

scripts. Bumped PKGREVISION.
This commit is contained in:
rillig 2006-10-04 21:07:52 +00:00
parent 089e4defb8
commit 2276cdf10a
3 changed files with 20 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.33 2006/08/26 15:32:29 joerg Exp $ # $NetBSD: Makefile,v 1.34 2006/10/04 21:07:52 rillig Exp $
# #
DISTNAME= Python-2.1.3 DISTNAME= Python-2.1.3
PKGNAME= python21-2.1.3 PKGNAME= python21-2.1.3
PKGREVISION= 14 PKGREVISION= 15
CATEGORIES= lang python CATEGORIES= lang python
MASTER_SITES= ftp://ftp.python.org/pub/python/2.1.3/ MASTER_SITES= ftp://ftp.python.org/pub/python/2.1.3/
EXTRACT_SUFX= .tgz EXTRACT_SUFX= .tgz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.24 2006/04/13 02:26:54 joerg Exp $ $NetBSD: distinfo,v 1.25 2006/10/04 21:07:52 rillig Exp $
SHA1 (Python-2.1.3.tgz) = 7042a5c5fd60d334c0ac227885d68a4c305713b4 SHA1 (Python-2.1.3.tgz) = 7042a5c5fd60d334c0ac227885d68a4c305713b4
RMD160 (Python-2.1.3.tgz) = d7216480cf884507d97bf7932767871977fc1ccc RMD160 (Python-2.1.3.tgz) = d7216480cf884507d97bf7932767871977fc1ccc
@ -21,3 +21,4 @@ SHA1 (patch-bf) = 5a4f05c563d46c66485780c8dd8badac624c4f49
SHA1 (patch-bg) = 2e0733e66681582d36b1470dce50c8e8b43cd083 SHA1 (patch-bg) = 2e0733e66681582d36b1470dce50c8e8b43cd083
SHA1 (patch-bh) = fa0d154bc5e1ccb1d59b2902aa61df8c91d52b2d SHA1 (patch-bh) = fa0d154bc5e1ccb1d59b2902aa61df8c91d52b2d
SHA1 (patch-bi) = 19e9e7ecba296b6fd955087f0dad85c52dfee058 SHA1 (patch-bi) = 19e9e7ecba296b6fd955087f0dad85c52dfee058
SHA1 (patch-bj) = 6b860ee6fca483f7360930935d4759fe6c93bdee

View file

@ -0,0 +1,16 @@
$NetBSD: patch-bj,v 1.1 2006/10/04 21:07:52 rillig Exp $
Without this patch, some Python scripts had their interpreter changed to
python2.1None instead of python2.1.
--- Lib/distutils/command/build_scripts.py.orig 2001-07-30 11:56:31.000000000 +0200
+++ Lib/distutils/command/build_scripts.py 2006-10-04 22:59:10.000000000 +0200
@@ -83,6 +83,8 @@ class build_scripts (Command):
if match:
adjust = 1
post_interp = match.group(1)
+ if post_interp == None:
+ post_interp = ""
if adjust:
self.announce("copying and adjusting %s -> %s" %