Update py-sphinx to 1.0.8.

While here,
* fixes egg-info `requires' information for python>2.6, with bump dependency on
  py-docutils with egg-info.

Release 1.0.8 (Sep 23, 2011)
============================

* #627: Fix tracebacks for AttributeErrors in autosummary generation.

* Fix the ``abbr`` role when the abbreviation has newlines in it.

* #727: Fix the links to search results with custom object types.

* #648: Fix line numbers reported in warnings about undefined
  references.

* #696, #666: Fix C++ array definitions and template arguments
  that are not type names.

* #633: Allow footnotes in section headers in LaTeX output.

* #616: Allow keywords to be linked via intersphinx.

* #613: Allow Unicode characters in production list token names.

* #720: Add dummy visitors for graphviz nodes for text and man.

* #704: Fix image file duplication bug.

* #677: Fix parsing of multiple signatures in C++ domain.

* #637: Ignore Emacs lock files when looking for source files.

* #544: Allow .pyw extension for importable modules in autodoc.

* #700: Use ``$(MAKE)`` in quickstart-generated Makefiles.

* #734: Make sidebar search box width consistent in browsers.

* #644: Fix spacing of centered figures in HTML output.

* #767: Safely encode SphinxError messages when printing them to
  sys.stderr.

* #611: Fix LaTeX output error with a document with no sections but
  a link target.

* Correctly treat built-in method descriptors as methods in autodoc.

* #706: Stop monkeypatching the Python textwrap module.

* #657: viewcode now works correctly with source files that have
  non-ASCII encoding.

* #669: Respect the ``noindex`` flag option in py:module directives.

* #675: Fix IndexErrors when including nonexisting lines with
  :rst:dir:`literalinclude`.

* #676: Respect custom function/method parameter separator strings.

* #682: Fix JS incompatibility with jQuery >= 1.5.

* #693: Fix double encoding done when writing HTMLHelp .hhk files.

* #647: Do not apply SmartyPants in parsed-literal blocks.

* C++ domain now supports array definitions.
This commit is contained in:
obache 2011-10-05 07:53:27 +00:00
parent 5a415fc40f
commit 22b32314ab
3 changed files with 7 additions and 23 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.9 2011/03/23 11:41:49 adam Exp $
# $NetBSD: Makefile,v 1.10 2011/10/05 07:53:27 obache Exp $
DISTNAME= Sphinx-1.0.7
DISTNAME= Sphinx-1.0.8
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES= textproc python
MASTER_SITES= http://pypi.python.org/packages/source/S/Sphinx/
@ -12,7 +12,7 @@ LICENSE= modified-bsd
PKG_DESTDIR_SUPPORT= user-destdir
DEPENDS+= ${PYPKGPREFIX}-docutils>=0.5:../../textproc/py-docutils
DEPENDS+= ${PYPKGPREFIX}-docutils>=0.8.1:../../textproc/py-docutils
DEPENDS+= ${PYPKGPREFIX}-jinja2>=2.2:../../textproc/py-jinja2
DEPENDS+= ${PYPKGPREFIX}-pygments>=0.8:../../textproc/py-pygments

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.7 2011/03/23 11:41:49 adam Exp $
$NetBSD: distinfo,v 1.8 2011/10/05 07:53:27 obache Exp $
SHA1 (Sphinx-1.0.7.tar.gz) = b231438a51a84d53679a226ab2036ec62bb14fd5
RMD160 (Sphinx-1.0.7.tar.gz) = e3c622dec2a971158bfe8bc7faee493f722199c8
Size (Sphinx-1.0.7.tar.gz) = 2285875 bytes
SHA1 (patch-aa) = f41f5104f535a14e82e868b261832cc98a2ac609
SHA1 (Sphinx-1.0.8.tar.gz) = 0301700e51f9610b6e2bc3df06ec97a8d80883d5
RMD160 (Sphinx-1.0.8.tar.gz) = 3d09880012f7dc26268923a3e0b13e8ab1250ae4
Size (Sphinx-1.0.8.tar.gz) = 2289041 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.2 2009/08/05 10:41:18 markd Exp $
pkgsrc's docutils doesn't install an egg-info
--- setup.py.orig 2008-11-24 07:12:48.000000000 +1300
+++ setup.py
@@ -42,7 +42,7 @@ if sys.version_info < (2, 4):
print 'ERROR: Sphinx requires at least Python 2.4 to run.'
sys.exit(1)
-if sys.version_info < (2, 5):
+if sys.version_info < (2, 7):
# Python 2.4's distutils doesn't automatically install an egg-info,
# so an existing docutils install won't be detected -- in that case,
# remove the dependency from setup.py