Remove ruby-fox -- the package version only supports the ancient 1.0.x

series, and the latest available version is for 1.2.x, while the stable
fox releases are at 1.4.x.
This commit is contained in:
wiz 2005-07-25 14:15:08 +00:00
parent 301c5a240f
commit 22d5a54962
7 changed files with 1 additions and 309 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.399 2005/07/23 21:34:55 wiz Exp $
# $NetBSD: Makefile,v 1.400 2005/07/25 14:15:08 wiz Exp $
#
COMMENT= Packages to support the X window system
@ -193,7 +193,6 @@ SUBDIR+= qwt
SUBDIR+= randrext
SUBDIR+= render
SUBDIR+= rep-gtk
SUBDIR+= ruby-fox
SUBDIR+= ruby-gtk
SUBDIR+= ruby-tcltklib
SUBDIR+= ruby-tk

View file

@ -1 +0,0 @@
Ruby extension module to use FOX GUI library.

View file

@ -1,48 +0,0 @@
# $NetBSD: Makefile,v 1.25 2005/06/01 18:03:30 jlam Exp $
DISTNAME= FXRuby-1.0.29
PKGNAME= ${RUBY_PKGPREFIX}-fox-1.0.29
PKGREVISION= 3
CATEGORIES= x11 ruby
MASTER_SITES= http://rubyforge.org/frs/download.php/983/ \
${MASTER_SITE_SOURCEFORGE:=fxruby/}
MAINTAINER= sakamoto@NetBSD.org
HOMEPAGE= http://www.fxruby.org/
COMMENT= Ruby interface to FOX GUI library
DEPENDS+= ${RUBY_PKGPREFIX}-opengl>=0.32:../../graphics/ruby-opengl
RUBY_HAS_ARCHLIB= yes
USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
WRKDIST= ${WRKDIR}/${DISTNAME}
WRKSRC= ${WRKDIST}/ext/fox
CONFIGURE_ARGS+= --with-fox-include=${BUILDLINK_PREFIX.fox}/include/fox
CONFIGURE_ARGS+= --with-opengl-include=${BUILDLINK_PREFIX.Mesa}/include/GL
CONFIGURE_ARGS+= --with-fox-lib=${BUILDLINK_PREFIX.fox}/lib
post-install:
${INSTALL_DATA_DIR} ${RUBY_SITELIBDIR}/fox
${INSTALL_DATA} ${WRKDIST}/lib/fox/*.rb ${RUBY_SITELIBDIR}/fox
${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/fox
${INSTALL_DATA} ${WRKDIST}/examples/README ${WRKDIST}/examples/*.rb \
${RUBY_EXAMPLESDIR}/fox
${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/fox/icons
${INSTALL_DATA} ${WRKDIST}/examples/icons/* \
${RUBY_EXAMPLESDIR}/fox/icons
${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/fox/textedit
${INSTALL_DATA} ${WRKDIST}/examples/textedit/* \
${RUBY_EXAMPLESDIR}/fox/textedit
${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/fox ${RUBY_DOCDIR}/fox/images
${INSTALL_DATA} ${WRKDIST}/doc/*.html ${RUBY_DOCDIR}/fox
${INSTALL_DATA} ${WRKDIST}/doc/images/* ${RUBY_DOCDIR}/fox/images
.include "../../graphics/Mesa/buildlink3.mk"
.include "../../x11/fox/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../lang/ruby/modules.mk"
.include "../../mk/x11.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,207 +0,0 @@
@comment $NetBSD: PLIST,v 1.4 2004/12/04 17:20:47 taca Exp $
${RUBY_DOCDIR}/fox/apes02.html
${RUBY_DOCDIR}/fox/apes03.html
${RUBY_DOCDIR}/fox/book.html
${RUBY_DOCDIR}/fox/build.html
${RUBY_DOCDIR}/fox/ch02s02.html
${RUBY_DOCDIR}/fox/ch02s03.html
${RUBY_DOCDIR}/fox/ch02s04.html
${RUBY_DOCDIR}/fox/ch02s05.html
${RUBY_DOCDIR}/fox/ch03s02.html
${RUBY_DOCDIR}/fox/ch03s03.html
${RUBY_DOCDIR}/fox/ch03s04.html
${RUBY_DOCDIR}/fox/ch04s02.html
${RUBY_DOCDIR}/fox/ch04s03.html
${RUBY_DOCDIR}/fox/changes.html
${RUBY_DOCDIR}/fox/clipboardtut.html
${RUBY_DOCDIR}/fox/cvs.html
${RUBY_DOCDIR}/fox/differences.html
${RUBY_DOCDIR}/fox/dragdroptut.html
${RUBY_DOCDIR}/fox/events.html
${RUBY_DOCDIR}/fox/examples.html
${RUBY_DOCDIR}/fox/goals.html
${RUBY_DOCDIR}/fox/images/babelfish.png
${RUBY_DOCDIR}/fox/images/browser.png
${RUBY_DOCDIR}/fox/images/button.png
${RUBY_DOCDIR}/fox/images/call-chain-example.png
${RUBY_DOCDIR}/fox/images/colordialog.png
${RUBY_DOCDIR}/fox/images/datatarget.png
${RUBY_DOCDIR}/fox/images/dialog.png
${RUBY_DOCDIR}/fox/images/dilbert.png
${RUBY_DOCDIR}/fox/images/dirlist.png
${RUBY_DOCDIR}/fox/images/dropsite-droprejected.png
${RUBY_DOCDIR}/fox/images/foursplit.png
${RUBY_DOCDIR}/fox/images/gltest.png
${RUBY_DOCDIR}/fox/images/glviewer.png
${RUBY_DOCDIR}/fox/images/groupbox.png
${RUBY_DOCDIR}/fox/images/header.png
${RUBY_DOCDIR}/fox/images/hello-with-button.png
${RUBY_DOCDIR}/fox/images/hello-with-icon-1.png
${RUBY_DOCDIR}/fox/images/hello-with-icon-2.png
${RUBY_DOCDIR}/fox/images/hello-with-icon-3.png
${RUBY_DOCDIR}/fox/images/hello-with-tooltip.png
${RUBY_DOCDIR}/fox/images/hello-without-button.png
${RUBY_DOCDIR}/fox/images/hello.png
${RUBY_DOCDIR}/fox/images/hello2.png
${RUBY_DOCDIR}/fox/images/iconlist-bigicons.png
${RUBY_DOCDIR}/fox/images/iconlist-details.png
${RUBY_DOCDIR}/fox/images/image.png
${RUBY_DOCDIR}/fox/images/imageviewer.png
${RUBY_DOCDIR}/fox/images/inheritance.png
${RUBY_DOCDIR}/fox/images/mditest.png
${RUBY_DOCDIR}/fox/images/raabrowser.png
${RUBY_DOCDIR}/fox/images/scribble.png
${RUBY_DOCDIR}/fox/images/shutter.png
${RUBY_DOCDIR}/fox/images/splitter.png
${RUBY_DOCDIR}/fox/images/tabbook.png
${RUBY_DOCDIR}/fox/images/table.png
${RUBY_DOCDIR}/fox/images/tutorial1.png
${RUBY_DOCDIR}/fox/implementation.html
${RUBY_DOCDIR}/fox/infosources.html
${RUBY_DOCDIR}/fox/library.html
${RUBY_DOCDIR}/fox/opengl.html
${RUBY_DOCDIR}/fox/pt01.html
${RUBY_DOCDIR}/fox/pt02.html
${RUBY_DOCDIR}/fox/scintilla.html
${RUBY_DOCDIR}/fox/todo.html
${RUBY_DOCDIR}/fox/tutorial1.html
${RUBY_EXAMPLESDIR}/fox/RAA.rb
${RUBY_EXAMPLESDIR}/fox/README
${RUBY_EXAMPLESDIR}/fox/babelfish.rb
${RUBY_EXAMPLESDIR}/fox/bounce.rb
${RUBY_EXAMPLESDIR}/fox/browser.rb
${RUBY_EXAMPLESDIR}/fox/button.rb
${RUBY_EXAMPLESDIR}/fox/datatarget.rb
${RUBY_EXAMPLESDIR}/fox/dctest.rb
${RUBY_EXAMPLESDIR}/fox/dialog.rb
${RUBY_EXAMPLESDIR}/fox/dilbert.rb
${RUBY_EXAMPLESDIR}/fox/dirlist.rb
${RUBY_EXAMPLESDIR}/fox/dragdrop.rb
${RUBY_EXAMPLESDIR}/fox/dragsource.rb
${RUBY_EXAMPLESDIR}/fox/dropsite.rb
${RUBY_EXAMPLESDIR}/fox/foursplit.rb
${RUBY_EXAMPLESDIR}/fox/gltest.rb
${RUBY_EXAMPLESDIR}/fox/glviewer.rb
${RUBY_EXAMPLESDIR}/fox/groupbox.rb
${RUBY_EXAMPLESDIR}/fox/header.rb
${RUBY_EXAMPLESDIR}/fox/hello.rb
${RUBY_EXAMPLESDIR}/fox/hello2.rb
${RUBY_EXAMPLESDIR}/fox/iRAA.rb
${RUBY_EXAMPLESDIR}/fox/iconlist.rb
${RUBY_EXAMPLESDIR}/fox/icons/AngryGuyInBunnySuit.ico
${RUBY_EXAMPLESDIR}/fox/icons/FatBot.ico
${RUBY_EXAMPLESDIR}/fox/icons/FlippedySwitch.ico
${RUBY_EXAMPLESDIR}/fox/icons/LeGoon.ico
${RUBY_EXAMPLESDIR}/fox/icons/Net.ico
${RUBY_EXAMPLESDIR}/fox/icons/RedMacOS.ico
${RUBY_EXAMPLESDIR}/fox/icons/SawBlade.ico
${RUBY_EXAMPLESDIR}/fox/icons/backview.png
${RUBY_EXAMPLESDIR}/fox/icons/big.png
${RUBY_EXAMPLESDIR}/fox/icons/bigfolder.png
${RUBY_EXAMPLESDIR}/fox/icons/bigpenguin.png
${RUBY_EXAMPLESDIR}/fox/icons/bottomview.png
${RUBY_EXAMPLESDIR}/fox/icons/camera.png
${RUBY_EXAMPLESDIR}/fox/icons/capbutt.png
${RUBY_EXAMPLESDIR}/fox/icons/capnotlast.png
${RUBY_EXAMPLESDIR}/fox/icons/capproj.png
${RUBY_EXAMPLESDIR}/fox/icons/capround.png
${RUBY_EXAMPLESDIR}/fox/icons/colorpal.png
${RUBY_EXAMPLESDIR}/fox/icons/copy.png
${RUBY_EXAMPLESDIR}/fox/icons/cut.png
${RUBY_EXAMPLESDIR}/fox/icons/delimit.png
${RUBY_EXAMPLESDIR}/fox/icons/dippy.png
${RUBY_EXAMPLESDIR}/fox/icons/double_dash.png
${RUBY_EXAMPLESDIR}/fox/icons/filenew.png
${RUBY_EXAMPLESDIR}/fox/icons/fileopen.png
${RUBY_EXAMPLESDIR}/fox/icons/filesave.png
${RUBY_EXAMPLESDIR}/fox/icons/filesaveas.png
${RUBY_EXAMPLESDIR}/fox/icons/fonts.png
${RUBY_EXAMPLESDIR}/fox/icons/fox.png
${RUBY_EXAMPLESDIR}/fox/icons/foxicon.png
${RUBY_EXAMPLESDIR}/fox/icons/frontview.png
${RUBY_EXAMPLESDIR}/fox/icons/gem_big.png
${RUBY_EXAMPLESDIR}/fox/icons/gem_small.png
${RUBY_EXAMPLESDIR}/fox/icons/hello2.png
${RUBY_EXAMPLESDIR}/fox/icons/help.png
${RUBY_EXAMPLESDIR}/fox/icons/indent.png
${RUBY_EXAMPLESDIR}/fox/icons/jbevel.png
${RUBY_EXAMPLESDIR}/fox/icons/jmiter.png
${RUBY_EXAMPLESDIR}/fox/icons/jround.png
${RUBY_EXAMPLESDIR}/fox/icons/kill.png
${RUBY_EXAMPLESDIR}/fox/icons/leftview.png
${RUBY_EXAMPLESDIR}/fox/icons/light.png
${RUBY_EXAMPLESDIR}/fox/icons/minidoc.png
${RUBY_EXAMPLESDIR}/fox/icons/minifolder.png
${RUBY_EXAMPLESDIR}/fox/icons/minifolderopen.png
${RUBY_EXAMPLESDIR}/fox/icons/newfolder.png
${RUBY_EXAMPLESDIR}/fox/icons/nolight.png
${RUBY_EXAMPLESDIR}/fox/icons/onoff_dash.png
${RUBY_EXAMPLESDIR}/fox/icons/palette.png
${RUBY_EXAMPLESDIR}/fox/icons/parallel.png
${RUBY_EXAMPLESDIR}/fox/icons/paste.png
${RUBY_EXAMPLESDIR}/fox/icons/pattern.png
${RUBY_EXAMPLESDIR}/fox/icons/penguin.png
${RUBY_EXAMPLESDIR}/fox/icons/perspective.png
${RUBY_EXAMPLESDIR}/fox/icons/printicon.png
${RUBY_EXAMPLESDIR}/fox/icons/prop.png
${RUBY_EXAMPLESDIR}/fox/icons/redo.png
${RUBY_EXAMPLESDIR}/fox/icons/rightview.png
${RUBY_EXAMPLESDIR}/fox/icons/saveas.png
${RUBY_EXAMPLESDIR}/fox/icons/shutter1.png
${RUBY_EXAMPLESDIR}/fox/icons/shutter2.png
${RUBY_EXAMPLESDIR}/fox/icons/small.png
${RUBY_EXAMPLESDIR}/fox/icons/smoothlight.png
${RUBY_EXAMPLESDIR}/fox/icons/solid_line.png
${RUBY_EXAMPLESDIR}/fox/icons/tbuplevel.png
${RUBY_EXAMPLESDIR}/fox/icons/topview.png
${RUBY_EXAMPLESDIR}/fox/icons/undo.png
${RUBY_EXAMPLESDIR}/fox/icons/winapp.png
${RUBY_EXAMPLESDIR}/fox/icons/zoom.png
${RUBY_EXAMPLESDIR}/fox/image.rb
${RUBY_EXAMPLESDIR}/fox/imageviewer.rb
${RUBY_EXAMPLESDIR}/fox/inputs.rb
${RUBY_EXAMPLESDIR}/fox/mditest.rb
${RUBY_EXAMPLESDIR}/fox/pig.rb
${RUBY_EXAMPLESDIR}/fox/raabrowser.rb
${RUBY_EXAMPLESDIR}/fox/scintilla-test.rb
${RUBY_EXAMPLESDIR}/fox/scribble-orig.rb
${RUBY_EXAMPLESDIR}/fox/scribble.rb
${RUBY_EXAMPLESDIR}/fox/shutter.rb
${RUBY_EXAMPLESDIR}/fox/splitter.rb
${RUBY_EXAMPLESDIR}/fox/styledtext.rb
${RUBY_EXAMPLESDIR}/fox/tabbook.rb
${RUBY_EXAMPLESDIR}/fox/table.rb
${RUBY_EXAMPLESDIR}/fox/textedit/commands.rb
${RUBY_EXAMPLESDIR}/fox/textedit/helpwindow.rb
${RUBY_EXAMPLESDIR}/fox/textedit/prefdialog.rb
${RUBY_EXAMPLESDIR}/fox/textedit/textedit.rb
${RUBY_SITELIBDIR}/fox/aliases.rb
${RUBY_SITELIBDIR}/fox/calendar.rb
${RUBY_SITELIBDIR}/fox/chore.rb
${RUBY_SITELIBDIR}/fox/colors.rb
${RUBY_SITELIBDIR}/fox/core.rb
${RUBY_SITELIBDIR}/fox/dict.rb
${RUBY_SITELIBDIR}/fox/glgroup.rb
${RUBY_SITELIBDIR}/fox/glshapes.rb
${RUBY_SITELIBDIR}/fox/input.rb
${RUBY_SITELIBDIR}/fox/irb.rb
${RUBY_SITELIBDIR}/fox/iterators.rb
${RUBY_SITELIBDIR}/fox/keys.rb
${RUBY_SITELIBDIR}/fox/missingdep.rb
${RUBY_SITELIBDIR}/fox/pseudokeyboard.rb
${RUBY_SITELIBDIR}/fox/pseudomouse.rb
${RUBY_SITELIBDIR}/fox/responder.rb
${RUBY_SITELIBDIR}/fox/responder2.rb
${RUBY_SITELIBDIR}/fox/scintilla.rb
${RUBY_SITELIBDIR}/fox/settings.rb
${RUBY_SITELIBDIR}/fox/signal.rb
${RUBY_SITELIBDIR}/fox/timeout.rb
${RUBY_SITELIBDIR}/fox/undolist.rb
${RUBY_SITELIBDIR}/fox/version.rb
${RUBY_SITEARCHLIBDIR}/fox.${RUBY_DLEXT}
@dirrm ${RUBY_DOCDIR}/fox/images
@dirrm ${RUBY_DOCDIR}/fox
@dirrm ${RUBY_EXAMPLESDIR}/fox/textedit
@dirrm ${RUBY_EXAMPLESDIR}/fox/icons
@dirrm ${RUBY_EXAMPLESDIR}/fox
@dirrm ${RUBY_SITELIBDIR}/fox

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.5 2005/02/23 17:36:20 wiz Exp $
SHA1 (ruby/FXRuby-1.0.29.tar.gz) = 04bcef90206c579eee9d86e1d89ca396e7548361
RMD160 (ruby/FXRuby-1.0.29.tar.gz) = 998fc178772a5fce6724130f5331dfc3a7b3c2e3
Size (ruby/FXRuby-1.0.29.tar.gz) = 1509394 bytes
SHA1 (patch-aa) = 0a1ff522bf2db62dbf72ef80cace753138bf4db2
SHA1 (patch-ab) = 02e947a0cc9981b0fad34f100a43f667411a2566

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 2003/08/30 02:55:03 taca Exp $
--- extconf.rb.orig 2003-08-30 03:30:47.000000000 +0200
+++ extconf.rb 2003-08-30 03:31:53.000000000 +0200
@@ -115,7 +115,7 @@
def do_unix_setup
$libs = append_library($libs, "stdc++")
-# $libs = append_library($libs, "supc++")
+ $libs = append_library($libs, "gcc")
have_header("sys/time.h")
have_header("signal.h")
have_library("png", "png_create_read_struct")

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ab,v 1.2 2003/08/30 02:55:03 taca Exp $
--- FXRuby.cpp.orig 2003-08-30 03:32:27.000000000 +0200
+++ FXRuby.cpp 2003-08-30 03:34:48.000000000 +0200
@@ -42,6 +42,9 @@
#include <io.h> // for get_osf_handle()
#endif
+#define RB_BPROC(func) ((VALUE (*)(...))func)
+#define RB_RPROC(func) ((VALUE (*)(...))func)
+
#ifdef HAVE_SIGNAL_H
#include <signal.h> // for definitions of SIGINT, etc.
#endif
@@ -1085,12 +1088,12 @@
if(FXRbCatchExceptions){
#ifdef RB_RESCUE2_BROKEN_PROTOTYPE
- retval=rb_rescue2((VALUE(*)()) handle_body, reinterpret_cast<VALUE>(&hArgs),
- (VALUE(*)()) handle_rescue, Qnil,
+ retval=rb_rescue2((VALUE(*)()) RB_BPROC(handle_body), reinterpret_cast<VALUE>(&hArgs),
+ (VALUE(*)()) RB_RPROC(handle_rescue), Qnil,
rb_eStandardError, rb_eNameError, 0);
#else
- retval=rb_rescue2((VALUE(*)(ANYARGS)) handle_body, reinterpret_cast<VALUE>(&hArgs),
- (VALUE(*)(ANYARGS)) handle_rescue, Qnil,
+ retval=rb_rescue2((VALUE(*)(ANYARGS)) RB_BPROC(handle_body), reinterpret_cast<VALUE>(&hArgs),
+ (VALUE(*)(ANYARGS)) RB_RPROC(handle_rescue), Qnil,
rb_eStandardError, rb_eNameError, 0);
#endif
}