Adding net/gkrellm-ping

GKrellM Ping is a gkrellm plugin that watches a given server and can list
 the returned ping time
This commit is contained in:
damon 2001-10-31 00:24:37 +00:00
parent 01fc879287
commit 234b528f31
6 changed files with 63 additions and 0 deletions

20
net/gkrellm-ping/Makefile Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/10/31 00:24:37 damon Exp $
DISTNAME= gkrellmPing-0.2-3
PKGNAME= gkrellm-ping-0.2.3
WRKSRC= ${WRKDIR}/gkrellmPing
CATEGORIES= net sysutils
MASTER_SITES= http://gkrellmping.dweb.ro/downloads/
MAINTAINER= damon@netbsd.org
HOMEPAGE= http://gkrellmping.dweb.ro/
COMMENT= gkrellm ping plugin
DEPENDS+= gkrellm-1.2.*:../../sysutils/gkrellm
USE_GMAKE= #defined
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gkrellmPing.so ${PREFIX}/lib/gkrellm/plugins/
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2001/10/31 00:24:37 damon Exp $
SHA1 (gkrellmPing-0.2-3.tar.gz) = 9e2e6167bce18d66e7ddfa57d60af4ebf2ad39b8
Size (gkrellmPing-0.2-3.tar.gz) = 11901 bytes
SHA1 (patch-aa) = fae58410f1b04a4995cd8e8cf5716ae45937fd86
SHA1 (patch-ab) = 8afc1538f0555b6aaac657a7c6da15e939d9a5ce

View file

@ -0,0 +1,20 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/10/31 00:24:38 damon Exp $
--- Makefile.orig Sat May 19 17:40:38 2001
+++ Makefile
@@ -1,5 +1,5 @@
# Modify INCLUDE to point to gkrellm.h (if it's not in /usr/local/include)
-INCLUDE =
+INCLUDE =${PREFIX}/include
CC = gcc
CFLAGS = -Wall -O2 -fPIC -I$(INCLUDE) \
@@ -7,7 +7,7 @@
LDFLAGS =
TARGET = gkrellmPing
-
+all: $(TARGET).so
$(TARGET).so: $(TARGET).o
$(CC) -shared -Wl $< -o $@

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/10/31 00:24:38 damon Exp $
--- gkrellmPing.c.orig Tue Oct 30 19:01:33 2001
+++ gkrellmPing.c
@@ -32,7 +32,7 @@
#define STYLE_NAME "gkrellmPing"
#define VERSION "0.2-2"
-#define DEF_COMMAND "ping 127.0.0.1 -c 1 | grep round-trip"
+#define DEF_COMMAND "ping -c 1 127.0.0.1 | grep round-trip"
#define DEF_NONE_MSG "Unknown Host"
#define DEF_VIEW_MSG "Ping: %s ms"
#define DEF_SEPS "=/// ;2"

View file

@ -0,0 +1,2 @@
GKrellM Ping is a gkrellm plugin that watches a given server and can list
the returned ping time

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/31 00:24:38 damon Exp $
lib/gkrellm/plugins/gkrellmPing.so