Update to 1.2.0.
Changes: * Add new role ATK_ROLE_APPLICATION [Bill Haneman] * Correct implementation of i18n support [Padraig O'Briain] * Add signal "active-descendant-changed" to AtkObject [Padraig] * Add relation types ATK_RELATION_EMBEDS and ATK_RELATION_EMBEDS_BY [Bill Haneman] * Add atk_hyperlink_is_inline() [Bill] * Add new functions atk_object_add_relationship, atk_object_remove_relationship, atk_role_get_localized_name, atk_action_get_localized_name; add new roles, states and relationships; add text-attributes-changed signal for AtkText interface. [Padraig O'Briain] * Add po directory and update atk_role_get_localized_name() to allow it to return localized name [Padraig] * Add implementtaion of atk_object_factory_get_accessible_type() for AtkNoOpObjectFactory [Padraig] * Add ATK_LAYER_WINDOW {Mark Mc Loughlin] and some translation updates and bug fixes.
This commit is contained in:
parent
1512196acb
commit
2375e2d0a4
4 changed files with 50 additions and 33 deletions
|
@ -1,12 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.11 2002/12/19 13:03:24 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2002/12/24 03:44:18 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= atk-1.0.3
|
||||
PKGREVISION= 2
|
||||
DISTNAME= atk-1.2.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.gtk.org/pub/gtk/v2.0/ \
|
||||
ftp://ftp.cs.umn.edu/pub/gimp/gtk/v2.0/ \
|
||||
${MASTER_SITE_GNOME:=sources/atk/1.0/}
|
||||
MASTER_SITES= ftp://ftp.gtk.org/pub/gtk/v2.2/ \
|
||||
ftp://ftp.cs.umn.edu/pub/gimp/gtk/v2.2/ \
|
||||
${MASTER_SITE_GNOME:=sources/atk/1.2/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
|
@ -17,6 +16,7 @@ USE_BUILDLINK2= yes
|
|||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
PKGCONFIG_OVERRIDE= ${WRKSRC}/atk.pc.in
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2002/12/09 16:01:17 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2002/12/24 03:44:18 wiz Exp $
|
||||
include/atk-1.0/atk/atk-enum-types.h
|
||||
include/atk-1.0/atk/atk.h
|
||||
include/atk-1.0/atk/atkaction.h
|
||||
|
@ -16,6 +16,7 @@ include/atk-1.0/atk/atkobjectfactory.h
|
|||
include/atk-1.0/atk/atkregistry.h
|
||||
include/atk-1.0/atk/atkrelation.h
|
||||
include/atk-1.0/atk/atkrelationset.h
|
||||
include/atk-1.0/atk/atkrelationtype.h
|
||||
include/atk-1.0/atk/atkselection.h
|
||||
include/atk-1.0/atk/atkstate.h
|
||||
include/atk-1.0/atk/atkstateset.h
|
||||
|
@ -27,35 +28,50 @@ include/atk-1.0/atk/atkvalue.h
|
|||
lib/libatk-1.0.a
|
||||
lib/libatk-1.0.la
|
||||
lib/libatk-1.0.so
|
||||
lib/libatk-1.0.so.0
|
||||
lib/libatk-1.0.so.0.3
|
||||
lib/libatk-1.0.so.200
|
||||
lib/libatk-1.0.so.200.0
|
||||
lib/pkgconfig/atk.pc
|
||||
share/gtk-doc/html/atk/atk-atkaction.html
|
||||
share/gtk-doc/html/atk/atk-atkcomponent.html
|
||||
share/gtk-doc/html/atk/atk-atkdocument.html
|
||||
share/gtk-doc/html/atk/atk-atkeditabletext.html
|
||||
share/gtk-doc/html/atk/atk-atkgobjectaccessible.html
|
||||
share/gtk-doc/html/atk/atk-atkhyperlink.html
|
||||
share/gtk-doc/html/atk/atk-atkhypertext.html
|
||||
share/gtk-doc/html/atk/atk-atkimage.html
|
||||
share/gtk-doc/html/atk/atk-atknoopobject.html
|
||||
share/gtk-doc/html/atk/atk-atknoopobjectfactory.html
|
||||
share/gtk-doc/html/atk/atk-atkobject.html
|
||||
share/gtk-doc/html/atk/atk-atkobjectfactory.html
|
||||
share/gtk-doc/html/atk/atk-atkregistry.html
|
||||
share/gtk-doc/html/atk/atk-atkrelation.html
|
||||
share/gtk-doc/html/atk/atk-atkrelationset.html
|
||||
share/gtk-doc/html/atk/atk-atkselection.html
|
||||
share/gtk-doc/html/atk/atk-atkstate.html
|
||||
share/gtk-doc/html/atk/atk-atkstateset.html
|
||||
share/gtk-doc/html/atk/atk-atkstreamablecontent.html
|
||||
share/gtk-doc/html/atk/atk-atktable.html
|
||||
share/gtk-doc/html/atk/atk-atktext.html
|
||||
share/gtk-doc/html/atk/atk-atkutil.html
|
||||
share/gtk-doc/html/atk/atk-atkvalue.html
|
||||
share/gtk-doc/html/atk/atkgobjectaccessible.html
|
||||
share/gtk-doc/html/atk/atkhyperlink.html
|
||||
share/gtk-doc/html/atk/atknoopobject.html
|
||||
share/gtk-doc/html/atk/atknoopobjectfactory.html
|
||||
share/gtk-doc/html/atk/atkobject.html
|
||||
share/gtk-doc/html/atk/atkobjectfactory.html
|
||||
share/gtk-doc/html/atk/atkregistry.html
|
||||
share/gtk-doc/html/atk/atkrelation.html
|
||||
share/gtk-doc/html/atk/atkrelationset.html
|
||||
share/gtk-doc/html/atk/atkstateset.html
|
||||
share/gtk-doc/html/atk/atkutil.html
|
||||
share/gtk-doc/html/atk/atk.html
|
||||
share/gtk-doc/html/atk/book1.html
|
||||
share/gtk-doc/html/atk/index.sgml
|
||||
${PKGLOCALEDIR}/locale/bg/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/en_GB/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/he/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/hu/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/ms/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/no/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/uk/LC_MESSAGES/atk10.mo
|
||||
${PKGLOCALEDIR}/locale/vi/LC_MESSAGES/atk10.mo
|
||||
@dirrm share/gtk-doc/html/atk
|
||||
@unexec ${RMDIR} %D/share/gtk-doc/html 2>/dev/null || ${TRUE}
|
||||
@unexec ${RMDIR} %D/share/gtk-doc 2>/dev/null || ${TRUE}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.9 2002/12/19 13:03:24 grant Exp $
|
||||
$NetBSD: distinfo,v 1.10 2002/12/24 03:44:18 wiz Exp $
|
||||
|
||||
SHA1 (atk-1.0.3.tar.bz2) = 4ee24ceb359352a2e2ed91e253e230e9a41fc752
|
||||
Size (atk-1.0.3.tar.bz2) = 245314 bytes
|
||||
SHA1 (patch-aa) = 12baad6715a485f4dd1e0d3176299552fb275598
|
||||
SHA1 (atk-1.2.0.tar.bz2) = 0aa7fd2f49e953f568ab6b73a73126f731686483
|
||||
Size (atk-1.2.0.tar.bz2) = 285376 bytes
|
||||
SHA1 (patch-aa) = 58d79386a8113c4f57209124dfd00b3bc78da86f
|
||||
|
|
|
@ -1,12 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.3 2002/03/26 12:36:03 rh Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2002/12/24 03:44:20 wiz Exp $
|
||||
|
||||
--- atk/Makefile.in.orig Tue Mar 26 22:18:01 2002
|
||||
--- atk/Makefile.in.orig Fri Dec 20 09:25:11 2002
|
||||
+++ atk/Makefile.in
|
||||
@@ -153,6 +153,7 @@
|
||||
@@ -141,7 +141,7 @@ MAINTAINERCLEANFILES = atkmarshal.c
|
||||
INCLUDES = -I$(top_srcdir) -DG_DISABLE_DEPRECATED @DEP_CFLAGS@ -DATKLOCALEDIR=\""$(atklocaledir)"\"
|
||||
|
||||
LDFLAGS = \
|
||||
-version-info $(LT_VERSION_INFO) \
|
||||
+ -Wl,-R$(libdir) \
|
||||
$(export_symbols) \
|
||||
$(no_undefined) \
|
||||
@DEP_LIBS@
|
||||
|
||||
-LDFLAGS = -version-info $(LT_VERSION_INFO) $(export_symbols) $(no_undefined) @DEP_LIBS@
|
||||
+LDFLAGS = -Wl,-R$(libdir) -version-info $(LT_VERSION_INFO) $(export_symbols) $(no_undefined) @DEP_LIBS@
|
||||
|
||||
|
||||
libatkincludedir = $(includedir)/atk-1.0/atk
|
||||
|
|
Loading…
Reference in a new issue