hugeotp2ocp is no longer huge; print/web2c's otp2ocp has a default

array size much larger than teTeX's.
This commit is contained in:
minskim 2009-07-11 05:24:19 +00:00
parent a832c5f952
commit 2396cccb6b
6 changed files with 1 additions and 88 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.277 2009/07/10 23:47:06 minskim Exp $
# $NetBSD: Makefile,v 1.278 2009/07/11 05:24:19 minskim Exp $
#
COMMENT= Desktop publishing
@ -54,7 +54,6 @@ SUBDIR+= gutenprint-lib
SUBDIR+= gv
SUBDIR+= hpijs
SUBDIR+= html2ps
SUBDIR+= hugeotp2ocp
SUBDIR+= if-psprint
SUBDIR+= ijs
SUBDIR+= img2eps

View file

@ -1,3 +0,0 @@
hugeotp2ocp is a utility that converts OTP files to OCP files used by
Omega. This program can process OTP files requiring more memory than
regular otp2ocp in teTeX can handle.

View file

@ -1,46 +0,0 @@
# $NetBSD: Makefile,v 1.5 2008/02/04 20:10:34 tnn Exp $
DISTNAME= tetex-src-3.0
PKGNAME= ${DISTNAME:S/tetex-src/hugeotp2ocp/}
PKGREVISION= 1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_TEX_CTAN:=systems/unix/teTeX/3.0/distrib/}
MAINTAINER= minskim@NetBSD.org
HOMEPAGE= http://www.tug.org/tetex/
COMMENT= Utility to convert large OTP to OCP
DIST_SUBDIR= teTeX
DISTINFO_FILE= ${.CURDIR}/../../print/teTeX3-bin/distinfo
PATCHDIR= ${.CURDIR}/../../print/teTeX3-bin/patches
GNU_CONFIGURE= yes
BUILD_DIRS= ${WRKSRC}/texk/web2c/lib
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= lex
CONFIGURE_ARGS+= --without-texinfo
CONFIGURE_ARGS+= --without-dialog
CONFIGURE_ARGS+= --without-xdvik
CONFIGURE_ARGS+= --disable-multiplatform
TEX_ACCEPTED= teTeX3
BUILDLINK_DEPMETHOD.teTeX-bin= build
.include "../../mk/tex.buildlink3.mk"
post-configure:
cd ${WRKSRC}/texk/web2c/otps; \
${PATCH} -p0 < ${FILESDIR}/otps.Makefile.patch; \
${PATCH} -p0 < ${FILESDIR}/otps.routines.h.patch
post-build:
cd ${WRKSRC}/texk/web2c/otps; \
${SETENV} ${MAKE_ENV} ${MAKE} otp2ocp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/texk/web2c/otps/otp2ocp \
${PREFIX}/bin/hugeotp2ocp
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/11/17 22:27:05 minskim Exp $
bin/hugeotp2ocp

View file

@ -1,22 +0,0 @@
$NetBSD: otps.Makefile.patch,v 1.1.1.1 2005/11/17 22:27:05 minskim Exp $
--- Makefile.orig 2005-11-17 12:14:16.000000000 -0800
+++ Makefile
@@ -73,7 +73,7 @@ LDFLAGS = -L/Users/msk/pkg/lib $(XLDFLAG
# proglib is for web2c;
# XLOADLIBES is for the installer.
LIBS = -lm
-LOADLIBES = $(proglib) $(kpathsea) $(LIBS) $(XLOADLIBES)
+LOADLIBES = $(proglib) -lkpathsea $(LIBS) $(XLOADLIBES)
# May as well separate linking from compiling, just in case.
CCLD = $(CC)
@@ -212,7 +212,7 @@ $(LEX_OUTPUT_ROOT).c: otp.l
outocp: outocp.o
$(kpathsea_link) outocp.o $(LOADLIBES)
-$(programs): $(proglib) $(kpathsea)
+$(programs): $(proglib)
install-programs: $(programs)
$(SHELL) $(top_srcdir)/../mkinstalldirs $(bindir)

View file

@ -1,13 +0,0 @@
$NetBSD: otps.routines.h.patch,v 1.1.1.1 2005/11/17 22:27:05 minskim Exp $
--- routines.h.orig 2004-09-15 01:14:19.000000000 -0700
+++ routines.h
@@ -102,7 +102,7 @@ extern int no_lefts;
extern void store_alias P2H(string, left);
extern left lookup_alias P1H(string);
-#define ARRAY_SIZE 10000
+#define ARRAY_SIZE 160000
typedef struct {
int length;
char * str;