Fix build problem with ruby18.

Give up to patch gemspec but use pre-generated one.
This commit is contained in:
taca 2011-02-28 15:46:08 +00:00
parent 8334b6ac97
commit 23b522a8e8
7 changed files with 267 additions and 103 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2011/02/21 16:01:17 taca Exp $
# $NetBSD: Makefile,v 1.25 2011/02/28 15:46:08 taca Exp $
DISTNAME= imlib2-ruby-0.5.2
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:S/ruby-//}
@ -20,5 +20,9 @@ pre-configure:
BUILDLINK_API_DEPENDS.imlib2+= imlib2>=1.2.0nb2
# use pre-generated gemspec file to avoid rubygems's incompatibility.
post-extract:
${CP} ${FILESDIR}/gemspec ${WRKDIR}/${DISTNAME}.gemspec
.include "../../graphics/imlib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.6 2010/09/10 06:49:22 taca Exp $
$NetBSD: distinfo,v 1.7 2011/02/28 15:46:08 taca Exp $
SHA1 (imlib2-ruby-0.5.2.gem) = 2d723441dae7630f7bec8c55486333a8efb2dbf1
RMD160 (imlib2-ruby-0.5.2.gem) = ebc3cdbcbefd90d38c6723dc620ed82fa4abff8b
Size (imlib2-ruby-0.5.2.gem) = 119296 bytes
SHA1 (patch-aa) = 7922179aad42bfaf340a85ef7611422696dfdab3
SHA1 (patch-ab) = 04f72f6b839756c00b65feddc8bbec6ac6703642

View file

@ -0,0 +1,80 @@
--- !ruby/object:Gem::Specification
name: imlib2-ruby
version: !ruby/object:Gem::Version
version: 0.5.2
platform: ruby
authors:
- Paul Duncan
autorequire: imlib2
bindir: bin
cert_chain:
date: 2005-06-11
default_executable:
dependencies: []
description: Imlib2 bindings for Ruby.
email: pabs@pablotron.org
executables: []
extensions:
- extconf.rb
extra_rdoc_files: []
files:
- ChangeLog
- AUTHORS
- COPYING
- examples
- MANIFEST
- README
- TODO
- depend
- extconf.rb
- imlib2.c
- imlib2.gemspec
- examples/fonts
- examples/checkerboard.rb
- examples/oo-board.rb
- examples/test_attach.rb
- examples/test_font.rb
- examples/test_imlib2.rb
- examples/test_poly.rb
- examples/images
- examples/fonts/yudit.ttf
- examples/images/bill_gates.jpg
- examples/images/clown.jpg
has_rdoc: true
homepage: http://www.pablotron.org/software/imlib2-ruby/
licenses:
post_install_message:
rdoc_options:
- --title
- Imlib2-Ruby API Documentation
- --webcvs
- http://cvs.pablotron.org/cgi-bin/viewcvs.cgi/imlib2-ruby/
- imlib2.c
- README
- ChangeLog
- AUTHORS
- COPYING
- TODO
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
requirements:
- - ">"
- !ruby/object:Gem::Version
version: 0.0.0
version:
required_rubygems_version:
requirements:
- Imlib2, version 1.2.0 (or newer)
- Ruby, version 1.8.2 (or newer)
rubyforge_project: imlib2-ruby
rubygems_version: 1.3.7
signing_key:
specification_version: 1
summary: Imlib2 bindings for Ruby.
test_files: []

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1 2010/09/10 06:49:22 taca Exp $
Fix gem's name to lower case.
--- ../imlib2-ruby-0.5.2.gemspec.orig 2010-09-09 02:53:49.000000000 +0000
+++ ../imlib2-ruby-0.5.2.gemspec
@@ -1,5 +1,5 @@
--- !ruby/object:Gem::Specification
-name: Imlib2-Ruby
+name: imlib2-ruby
version: !ruby/object:Gem::Version
version: 0.5.2
platform: ruby

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2011/02/21 16:01:23 taca Exp $
# $NetBSD: Makefile,v 1.14 2011/02/28 15:46:38 taca Exp $
DISTNAME= mongrel-1.1.5
PKGREVISION= 2
@ -14,5 +14,9 @@ DEPENDS+= ${RUBY_PKGPREFIX}-gem_plugin>=0.2.3:../../misc/ruby-gem_plugin
CONFLICTS+= ruby[1-9][0-9]-mongrel-[0-9]* mongrel-[0-9]*
# use pre-generated gemspec file to avoid rubygems's incompatibility.
post-extract:
${CP} ${FILESDIR}/gemspec ${WRKDIR}/${DISTNAME}.gemspec
.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"

176
www/mongrel/files/gemspec Normal file
View file

@ -0,0 +1,176 @@
--- !ruby/object:Gem::Specification
name: mongrel
version: !ruby/object:Gem::Version
version: 1.1.5
platform: ruby
authors:
- Zed A. Shaw
autorequire:
bindir: bin
date: 2008-05-22 04:00:00 +00:00
default_executable:
dependencies:
- !ruby/object:Gem::Dependency
name: gem_plugin
version_requirement:
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - ">="
- !ruby/object:Gem::Version
version: 0.2.3
version:
- !ruby/object:Gem::Dependency
name: daemons
version_requirement:
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - ">="
- !ruby/object:Gem::Version
version: 1.0.3
version:
description: A small fast HTTP library and server that runs Rails, Camping, Nitro and Iowa apps.
email: ""
executables:
- mongrel_rails
extensions:
- ext/http11/extconf.rb
extra_rdoc_files:
- CHANGELOG
- COPYING
- lib/mongrel/camping.rb
- lib/mongrel/cgi.rb
- lib/mongrel/command.rb
- lib/mongrel/configurator.rb
- lib/mongrel/const.rb
- lib/mongrel/debug.rb
- lib/mongrel/gems.rb
- lib/mongrel/handlers.rb
- lib/mongrel/header_out.rb
- lib/mongrel/http_request.rb
- lib/mongrel/http_response.rb
- lib/mongrel/init.rb
- lib/mongrel/rails.rb
- lib/mongrel/stats.rb
- lib/mongrel/tcphack.rb
- lib/mongrel/uri_classifier.rb
- lib/mongrel.rb
- LICENSE
- README
files:
- bin/mongrel_rails
- CHANGELOG
- COPYING
- examples/builder.rb
- examples/camping/blog.rb
- examples/camping/README
- examples/camping/tepee.rb
- examples/httpd.conf
- examples/mime.yaml
- examples/mongrel.conf
- examples/mongrel_simple_ctrl.rb
- examples/mongrel_simple_service.rb
- examples/monitrc
- examples/random_thrash.rb
- examples/simpletest.rb
- examples/webrick_compare.rb
- ext/http11/ext_help.h
- ext/http11/extconf.rb
- ext/http11/http11.c
- ext/http11/http11_parser.c
- ext/http11/http11_parser.h
- ext/http11/http11_parser.java.rl
- ext/http11/http11_parser.rl
- ext/http11/http11_parser_common.rl
- ext/http11_java/Http11Service.java
- ext/http11_java/org/jruby/mongrel/Http11.java
- ext/http11_java/org/jruby/mongrel/Http11Parser.java
- lib/mongrel/camping.rb
- lib/mongrel/cgi.rb
- lib/mongrel/command.rb
- lib/mongrel/configurator.rb
- lib/mongrel/const.rb
- lib/mongrel/debug.rb
- lib/mongrel/gems.rb
- lib/mongrel/handlers.rb
- lib/mongrel/header_out.rb
- lib/mongrel/http_request.rb
- lib/mongrel/http_response.rb
- lib/mongrel/init.rb
- lib/mongrel/mime_types.yml
- lib/mongrel/rails.rb
- lib/mongrel/stats.rb
- lib/mongrel/tcphack.rb
- lib/mongrel/uri_classifier.rb
- lib/mongrel.rb
- LICENSE
- Manifest
- mongrel-public_cert.pem
- mongrel.gemspec
- README
- setup.rb
- test/mime.yaml
- test/mongrel.conf
- test/test_cgi_wrapper.rb
- test/test_command.rb
- test/test_conditional.rb
- test/test_configurator.rb
- test/test_debug.rb
- test/test_handlers.rb
- test/test_http11.rb
- test/test_redirect_handler.rb
- test/test_request_progress.rb
- test/test_response.rb
- test/test_stats.rb
- test/test_uriclassifier.rb
- test/test_ws.rb
- test/testhelp.rb
- TODO
- tools/trickletest.rb
has_rdoc: true
homepage: http://mongrel.rubyforge.org
licenses:
post_install_message:
rdoc_options:
- --line-numbers
- --inline-source
- --title
- Mongrel
- --main
- README
require_paths:
- lib
- ext
required_ruby_version: !ruby/object:Gem::Requirement
requirements:
- - ">="
- !ruby/object:Gem::Version
version: 1.8.4
version:
required_rubygems_version: !ruby/object:Gem::Requirement
requirements:
- - ">="
- !ruby/object:Gem::Version
version: "0"
version:
requirements: []
rubyforge_project: mongrel
rubygems_version: 1.3.7
signing_key:
specification_version: 2
summary: A small fast HTTP library and server that runs Rails, Camping, Nitro and Iowa apps.
test_files:
- test/test_cgi_wrapper.rb
- test/test_command.rb
- test/test_conditional.rb
- test/test_configurator.rb
- test/test_debug.rb
- test/test_handlers.rb
- test/test_http11.rb
- test/test_redirect_handler.rb
- test/test_request_progress.rb
- test/test_response.rb
- test/test_stats.rb
- test/test_uriclassifier.rb
- test/test_ws.rb

View file

@ -1,86 +0,0 @@
$NetBSD: patch-ac,v 1.3 2010/09/10 12:27:34 taca Exp $
* Remove certificate. (why?)
* Remove dependency to fastthread and cgi_multipart_eof_fix and make
minimum Ruby's version to 1.8.6. Since these depending packages aren't
needed by Ruby 1.8.6 at least.
--- ../mongrel-1.1.5.gemspec.orig 2010-09-07 00:11:11.000000000 +0000
+++ ../mongrel-1.1.5.gemspec
@@ -7,51 +7,6 @@ authors:
- Zed A. Shaw
autorequire:
bindir: bin
-cert_chain:
-- |
- -----BEGIN CERTIFICATE-----
- MIIDUDCCAjigAwIBAgIBADANBgkqhkiG9w0BAQUFADBOMRwwGgYDVQQDDBNtb25n
- cmVsLWRldmVsb3BtZW50MRkwFwYKCZImiZPyLGQBGRYJcnVieWZvcmdlMRMwEQYK
- CZImiZPyLGQBGRYDb3JnMB4XDTA3MDkxNjEwMzI0OVoXDTA4MDkxNTEwMzI0OVow
- TjEcMBoGA1UEAwwTbW9uZ3JlbC1kZXZlbG9wbWVudDEZMBcGCgmSJomT8ixkARkW
- CXJ1Ynlmb3JnZTETMBEGCgmSJomT8ixkARkWA29yZzCCASIwDQYJKoZIhvcNAQEB
- BQADggEPADCCAQoCggEBAMb9v3B01eOHk3FyypbQgKXzJplUE5P6dXoG+xpPm0Lv
- P7BQmeMncOwqQ7zXpVQU+lTpXtQFTsOE3vL7KnhQFJKGvUAkbh24VFyopu1I0yqF
- mGu4nRqNXGXVj8TvLSj4S1WpSRLAa0acLPNyKhGmoV9+crqQypSjM6XKjBeppifo
- 4eBmWGjiJEYMIJBvJZPJ4rAVDDA8C6CM1m3gMBGNh8ELDhU8HI9AP3dMIkTI2Wx9
- 9xkJwHdroAaS0IFFtYChrwee4FbCF1FHDgoTosMwa47DrLHg4hZ6ojaKwK5QVWEV
- XGb6ju5UqpktnSWF2W+Lvl/K0tI42OH2CAhebT1gEVUCAwEAAaM5MDcwCQYDVR0T
- BAIwADALBgNVHQ8EBAMCBLAwHQYDVR0OBBYEFGHChyMSZ16u9WOzKhgJSQ9lqDc5
- MA0GCSqGSIb3DQEBBQUAA4IBAQA/lfeN2WdB1xN+82tT7vNS4HOjRQw6MUh5yktu
- GQjaGqm0UB+aX0Z9y0B0qpfv9rj7nmIvEGiwBmDepNWYCGuW15JyqpN7QVVnG2xS
- Mrame7VqgjM7A+VGDD5In5LtWbM/CHAATvvFlQ5Ph13YE1EdnVbZ65c+KQv+5sFY
- Q+zEop74d878uaC/SAHHXS46TiXneocaLSYw1CEZs/MAIy+9c4Q5ESbGpgnfg1Ad
- 6lwl7k3hsNHO/+tZzx4HJtOXDI1yAl3+q6T9J0yI3z97EinwvAKhS1eyOI2Y5eeT
- tbQaNYkU127B3l/VNpd8fQm3Jkl/PqCCmDBQjUszFrJEODug
- -----END CERTIFICATE-----
-
-- |
- -----BEGIN CERTIFICATE-----
- MIIDPzCCAiegAwIBAgIBADANBgkqhkiG9w0BAQUFADBOMRwwGgYDVQQDDBNtb25n
- cmVsLWRldmVsb3BtZW50MRkwFwYKCZImiZPyLGQBGRYJcnVieWZvcmdlMRMwEQYK
- CZImiZPyLGQBGRYDb3JnMB4XDTA3MDkxNjEwMzMwMFoXDTA4MDkxNTEwMzMwMFow
- PTENMAsGA1UEAwwEZXZhbjEYMBYGCgmSJomT8ixkARkWCGNsb3VkYnVyMRIwEAYK
- CZImiZPyLGQBGRYCc3QwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDk
- LQijz2fICmev4+9s0WB71WzJFYCUYFQQxqGlenbxWut9dlPSsBbskGjg+UITeOXi
- cTh3MTqAB0i1LJyNOiyvDsAivn7GjKXhVvflp2/npMhBBe83P4HOWqeQBjkk3QJI
- FFNBvqbFLeEXIP+HiqAOiyNHZEVXMepLEJLzGrg3Ly7M7A6L5fK7jDrt8jkm+c+8
- zGquVHV5ohAebGd/vpHMLjpA7lCG5+MBgYZd33rRfNtCxDJMNRgnOu9PsB05+LJn
- MpDKQq3x0SkOf5A+MVOcadNCaAkFflYk3SUcXaXWxu/eCHgqfW1m76RNSp5djpKE
- CgNPK9lGIWpB3CHzDaVNAgMBAAGjOTA3MAkGA1UdEwQCMAAwCwYDVR0PBAQDAgSw
- MB0GA1UdDgQWBBT5aonPfFBdJ5rWFG+8dZwgyB54LjANBgkqhkiG9w0BAQUFAAOC
- AQEAiKbzWgMcvZs/TPwJxr8tJ+7mSGz7+zDkWcbBl8FpQq1DtRcATh1oyTkQT7t+
- rFEBYMmb0FxbbUnojQp8hIFgFkUwFpStwWBL/okLSehntzI2iwjuEtfj4ac9Q3Y2
- uSdbmZqsQTuu+lEUc5C4qLK7YKwToaul+cx7vWxyk1YendcVwRlFLIBqA5cPrwo3
- yyGLTHlRYn2c9PSbM1B63Yg+LqSSAa4QSU3Wv9pNdffVpvwHPVEQpO7ZDo5slQFL
- Gf6+gbD/eZAvhpvmn8JlXb+LxKaFVMs2Yvrk1xOuT76SsPjEGWxkr7jZCIpsYfgQ
- ALN3mi/9z0Mf1YroliUgF0v5Yw==
- -----END CERTIFICATE-----
-
date: 2008-05-22 04:00:00 +00:00
default_executable:
dependencies:
@@ -73,24 +28,6 @@ dependencies:
- !ruby/object:Gem::Version
version: 1.0.3
version:
-- !ruby/object:Gem::Dependency
- name: fastthread
- version_requirement:
- version_requirements: !ruby/object:Gem::Requirement
- requirements:
- - - ">="
- - !ruby/object:Gem::Version
- version: 1.0.1
- version:
-- !ruby/object:Gem::Dependency
- name: cgi_multipart_eof_fix
- version_requirement:
- version_requirements: !ruby/object:Gem::Requirement
- requirements:
- - - ">="
- - !ruby/object:Gem::Version
- version: "2.4"
- version:
description: A small fast HTTP library and server that runs Rails, Camping, Nitro and Iowa apps.
email: ""
executables: