py-mercurial: update to 5.1.2.

1. Mercurial 5.1.2 (2019-10-02)

Regularly scheduled bug fix release.

1.1. extensions

  • phabricator: don't abort if property writing fails during amending

1.2. tests

  • test: allow different result for zstd compression (issue6188)

2. Mercurial 5.1.1 (2019-09-05)

Regularly scheduled bug fix release.

2.1. commands

  • bookmarks: actual fix for race condition deleting bookmark

2.2. core

  • exchange: abort on pushing bookmarks pointing to secret changesets (issue6159)
  • python-zstandard: apply big-endian fix (issue6188)
  • fncache: make debugrebuildfncache not fail on broken fncache

2.3. tests

  • various test runner fixes
  • fixed use of tr --delete for tr(1) portability
This commit is contained in:
wiz 2019-10-10 14:15:10 +00:00
parent 3678362f5b
commit 23c08f916e
4 changed files with 11 additions and 25 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.33 2019/08/18 08:35:47 wiz Exp $
# $NetBSD: Makefile,v 1.34 2019/10/10 14:15:10 wiz Exp $
DISTNAME= mercurial-${VERSION}
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
@ -24,6 +24,9 @@ INSTALLATION_DIRS+= share/doc/mercurial
.include "version.mk"
# Known test failures:
# none as of 5.1.2
# # Ran 812 tests, 77 skipped, 0 failed.
#
# test-narrow-shallow (sometimes):
# https://bz.mercurial-scm.org/show_bug.cgi?id=6150
do-test:

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.79 2019/08/18 08:35:47 wiz Exp $
$NetBSD: distinfo,v 1.80 2019/10/10 14:15:10 wiz Exp $
SHA1 (mercurial-5.1.tar.gz) = 516800a18bb4e81ba6e4ba5d12cc5807d51bcc0a
RMD160 (mercurial-5.1.tar.gz) = 23f05ca435a332a9db0e1f42f4841656d463acdf
SHA512 (mercurial-5.1.tar.gz) = cf7a64a181eeb3dc8f24067ea032fb17504358a9ed08cb50ac041e66ef20426c060d997cb5d30e7582874135b0a351b3e58d7297aaa4e009aabbf562a1ab9fae
Size (mercurial-5.1.tar.gz) = 7283396 bytes
SHA1 (patch-tests_test-merge-combination.t) = 3753d014c17a16c9cdc0fdb0aa11739980fc5d9f
SHA1 (mercurial-5.1.2.tar.gz) = bf16be5d8393af3b6571def319c1dd2900d8aa01
RMD160 (mercurial-5.1.2.tar.gz) = 34185ae58f64452f09d061a9543f0e79a17fa849
SHA512 (mercurial-5.1.2.tar.gz) = a8ce9d9220a5ddf452264801f06e81fe1e699ff700d085e3f82c6877910c6ef0e594203590f198b7b9e31c9a1ed627c8fa2a3a1513d0c5087cf775835a78c408
Size (mercurial-5.1.2.tar.gz) = 7286238 bytes

View file

@ -1,16 +0,0 @@
$NetBSD: patch-tests_test-merge-combination.t,v 1.1 2019/08/18 08:35:47 wiz Exp $
Fix test case on *BSD.
https://phab.mercurial-scm.org/D6729
--- tests/test-merge-combination.t.orig 2019-08-01 16:14:49.000000000 +0000
+++ tests/test-merge-combination.t
@@ -57,7 +57,7 @@ revision. "C" indicates that hg merge ha
> fi
> else expected=a
> fi
- > got=`hg log -r 3 --template '{files}\n' | tr --delete 'e '`
+ > got=`hg log -r 3 --template '{files}\n' | tr -d 'e '`
> if [ "$got" = "$expected" ]
> then echo "$line$conflicts: agree on \"$got\""
> else echo "$line$conflicts: hg said \"$got\", expected \"$expected\""

View file

@ -1,6 +1,6 @@
# $NetBSD: version.mk,v 1.5 2019/09/02 13:19:40 adam Exp $
# $NetBSD: version.mk,v 1.6 2019/10/10 14:15:10 wiz Exp $
VERSION= 5.1
VERSION= 5.1.2
PYTHON_VERSIONS_ACCEPTED= 27 # 5.0 has "beta" support for python 3
# see https://www.mercurial-scm.org/wiki/Python3