add patch from upstream to fix possible buffer overflow in "sami"

subtitle reader
bump PKGREV
This commit is contained in:
drochner 2011-10-18 16:04:35 +00:00
parent b2f5c9dd2e
commit 23f5b8d34a
3 changed files with 20 additions and 11 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.71 2011/07/09 15:51:51 jmcneill Exp $
$NetBSD: distinfo,v 1.72 2011/10/18 16:04:36 drochner Exp $
SHA1 (mplayer/mplayer-20100913.tar.bz2) = 6fd3acb29fa8455636bcd86f9f333da4763daa6d
RMD160 (mplayer/mplayer-20100913.tar.bz2) = 79085d4ebdb824fc34f7bc128070ef11e874897d
@ -9,7 +9,7 @@ SHA1 (patch-ac) = 3d037c96537233cdbda582afdb878dcf3f43e923
SHA1 (patch-ad) = 84ce5a0f5cd8f59831c56b14dd2bc762793427ac
SHA1 (patch-ae) = 7e1f05cd6e09f8755debfff7061dadf0a8ca3a3f
SHA1 (patch-ag) = bef25568c913dcb8535afa51976ce7c94a6af5a2
SHA1 (patch-ah) = 8cbd14c61e74023055770baf27201687aa34fede
SHA1 (patch-ah) = dcfc26ec1422581a03ab200cb95926f6fd896d5b
SHA1 (patch-an) = 3e72fb86abe7ab572f12a4fef002edb623ab6fae
SHA1 (patch-ar) = df7e7cdc6fb8187bbcf0b285afc14d275a51e17a
SHA1 (patch-stream_dvb_tune.c) = b663830ff64ab31488684b1a324da50ab52d68cc

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ah,v 1.4 2010/09/16 18:56:12 wiz Exp $
$NetBSD: patch-ah,v 1.5 2011/10/18 16:04:36 drochner Exp $
--- subreader.c.orig 2010-08-29 11:27:00.000000000 +0000
--- subreader.c.orig 2010-09-11 11:11:10.000000000 +0000
+++ subreader.c
@@ -94,10 +94,10 @@ static int eol(char p) {
@@ -92,10 +92,10 @@ static int eol(char p) {
/* Remove leading and trailing space */
static void trail_space(char *s) {
int i = 0;
@ -15,7 +15,16 @@ $NetBSD: patch-ah,v 1.4 2010/09/16 18:56:12 wiz Exp $
}
static char *stristr(const char *haystack, const char *needle) {
@@ -725,7 +725,7 @@ static subtitle *sub_read_line_pjs(strea
@@ -171,6 +171,8 @@ static subtitle *sub_read_line_sami(stre
break;
case 3: /* get all text until '<' appears */
+ if (p - text >= LINE_LEN)
+ sami_add_line(current, text, &p);
if (*s == '\0') break;
else if (!strncasecmp (s, "<br>", 4)) {
sami_add_line(current, text, &p);
@@ -723,7 +725,7 @@ static subtitle *sub_read_line_pjs(strea
if (!stream_read_line (st, line, LINE_LEN, utf16))
return NULL;
/* skip spaces */
@ -24,7 +33,7 @@ $NetBSD: patch-ah,v 1.4 2010/09/16 18:56:12 wiz Exp $
/* allow empty lines at the end of the file */
if (*s==0)
return NULL;
@@ -778,7 +778,7 @@ static subtitle *sub_read_line_mpsub(str
@@ -776,7 +778,7 @@ static subtitle *sub_read_line_mpsub(str
else return current;
}
p=line;
@ -33,7 +42,7 @@ $NetBSD: patch-ah,v 1.4 2010/09/16 18:56:12 wiz Exp $
if (eol(*p) && num > 0) return current;
if (eol(*p)) return NULL;
@@ -1824,18 +1824,18 @@ char * strreplace( char * in,char * what
@@ -1822,18 +1824,18 @@ char * strreplace( char * in,char * what
static void strcpy_trim(char *d, char *s)
{
// skip leading whitespace
@ -55,7 +64,7 @@ $NetBSD: patch-ah,v 1.4 2010/09/16 18:56:12 wiz Exp $
s++;
}
if (*s == 0) break;
@@ -1874,7 +1874,7 @@ static void strcpy_get_ext(char *d, char
@@ -1872,7 +1874,7 @@ static void strcpy_get_ext(char *d, char
static int whiteonly(char *s)
{
while (*s) {

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.79 2011/07/09 15:51:51 jmcneill Exp $
# $NetBSD: Makefile,v 1.80 2011/10/18 16:04:35 drochner Exp $
PKGNAME= mplayer-${MPLAYER_VERSION}
PKGREVISION= 7
PKGREVISION= 8
COMMENT= Fast, cross-platform movie player