Updated libxkbcommon to 0.7.0.

libxkbcommon 0.7.0 - 2016-11-11
==================

- Added support for different "modes" of calculating consumed modifiers.
  The existing mode, based on the XKB standard, has proven to be
  unintuitive in various shortcut implementations.

  A new mode, based on the calculation used by the GTK toolkit, is added.
  This mode is less eager to declare a modifier as consumed.

- Added a new interactive demo program using the Wayland protocol.
  See the PACKAGING file for the new (optional) test dependencies.

- Fixed a compilation error on GNU Hurd.

- New API:
  enum xkb_consumed_mode
  XKB_CONSUMED_MODE_XKB
  XKB_CONSUMED_MODE_GTK
  xkb_state_key_get_consumed_mods2
  xkb_state_mod_index_is_consumed2
This commit is contained in:
wiz 2016-11-14 14:08:17 +00:00
parent 0e8be431b3
commit 23fd65bb51
3 changed files with 24 additions and 7 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.15 2016/04/14 12:44:32 wiz Exp $
# $NetBSD: Makefile,v 1.16 2016/11/14 14:08:17 wiz Exp $
DISTNAME= libxkbcommon-0.6.1
DISTNAME= libxkbcommon-0.7.0
CATEGORIES= x11
MASTER_SITES= http://xkbcommon.org/download/
EXTRACT_SUFX= .tar.xz

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.8 2016/04/14 12:44:32 wiz Exp $
$NetBSD: distinfo,v 1.9 2016/11/14 14:08:17 wiz Exp $
SHA1 (libxkbcommon-0.6.1.tar.xz) = 85175bd3baa2cb6207beb5ac980568b70e1a6a3d
RMD160 (libxkbcommon-0.6.1.tar.xz) = 296890c6eebaae9a76f705dbd2705579b8ba8055
SHA512 (libxkbcommon-0.6.1.tar.xz) = 5eab309d711ef3f4ce6d98ddd72f7f67fb6374eeea5fa13d37019830847a48a100d5b61b0312787966020c85b180b3ee8a5fd8e7acd3a8a9220ca53dcc411370
Size (libxkbcommon-0.6.1.tar.xz) = 722288 bytes
SHA1 (libxkbcommon-0.7.0.tar.xz) = 48e4df32bac36a265444da8252a15bb256b122b7
RMD160 (libxkbcommon-0.7.0.tar.xz) = 04628f523e0280ac5e7387db65d24f56e299c26a
SHA512 (libxkbcommon-0.7.0.tar.xz) = 0610f4e4d177d5323e6513f90cb3c29cd07bb1680c9d09770411e8b01e64b7fcf77c8a05cf24ce3035ee08435e95619f21cf283f842cc96511a31fe3a194dc70
Size (libxkbcommon-0.7.0.tar.xz) = 621980 bytes
SHA1 (patch-src_utils.h) = 8cd03c2cfe8aadbe8afe266c665c0befe885f4ff

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_utils.h,v 1.1 2016/11/14 14:08:17 wiz Exp $
Fix conflict with NetBSD's popcount.
https://github.com/xkbcommon/libxkbcommon/issues/41
--- src/utils.h.orig 2016-10-31 11:19:02.000000000 +0000
+++ src/utils.h
@@ -179,7 +179,7 @@ msb_pos(uint32_t mask)
}
static inline int
-popcount(uint32_t x)
+popcountu(uint32_t x)
{
int count;
#if defined(HAVE___BUILTIN_POPCOUNT)