mplayer, related packages: update to 1.5

some changes to attempt to make mplayer in pkgsrc less
"absurdly complicated"

  1.5: "Hope" February 27, 2022

    Decoders, demuxers, streams:
    * ffmpeg12vpdau is no longer supported by FFmpeg,
      provide separate ffmpeg1vpdau and ffmpeg2vdpau instead
    * live555 deprecated and disabled by default, will be removed
      in future

    GUI:
    * Fix wrongly sized video window after leaving fullscreen mode
    * Clear screen when switching to fullscreen mode using the x11
      video output driver
    * Command line option -fs is now recognized in addition to the
      GUI option load_fullscreen
    * Use correct visual in OpenGL video output driver for X11
    * Provide a built-in skin so that the GUI can be used even
      without an installed skin
    * Native Language Support, i.e. the GUI language can be changed
      as specified in LC_MESSAGES or LANG
    * Minor bug fixes

    Other:
    * Building on Arm now compiles for the ISA and extensions of the
      host CPU by default. This should avoid issues like builds on
      e.g. Raspbian not using NEON by default.
      Can use --enable-runtime-cpudetection to restore the previous
      behaviour, though full runtime CPU detection is not supported.
    * New configure option --enable-nls for Native Language Support at
      runtime (for the moment only for the GUI and enabled by default
      for it)
    * macOS: Fixes for retina display, sluggish input processing
This commit is contained in:
nia 2022-04-24 15:00:42 +00:00
parent 43deddd9dc
commit 24312fcc60
14 changed files with 90 additions and 200 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.80 2022/03/28 10:45:25 tnn Exp $
# $NetBSD: Makefile,v 1.81 2022/04/24 15:00:42 nia Exp $
.include "Makefile.common"
PKGNAME= mplayer-share-${MPLAYER_VERSION}
PKGREVISION= 15
COMMENT= Documentation used by mplayer and gmplayer
DEPENDS+= mplayer-fonts-[0-9]*:../../fonts/mplayer-fonts

View file

@ -1,24 +0,0 @@
# $NetBSD: Makefile.cflags,v 1.9 2018/05/27 15:27:13 tsutsui Exp $
# This must be included after everything else to truly clear ${CFLAGS}
# in the non-runtime-cpu-detection case. If ${CFLAGS} is non-empty, the
# configure script refuses to add any optimizations at all.
.if !empty(PKG_OPTIONS:Mmplayer-default-cflags)
. if ${MACHINE_ARCH} == "i386" && !empty(PKGSRC_COMPILER:Mgcc)
# Schedule for the typical machine fast enough to run mplayer. This
# is nearly optimal for K6-2 as well. Anything slower will still run
# (but would probably benefit greatly from turning off the run-time
# cpu detection).
. include "../../mk/compiler.mk"
. if !empty(CC_VERSION:Mgcc-[4567]*)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -mtune=pentiumpro
. else
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -mcpu=pentiumpro
. endif
. else
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
. endif
.endif

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.65 2020/06/05 12:17:10 jperkin Exp $
# $NetBSD: Makefile.common,v 1.66 2022/04/24 15:00:42 nia Exp $
# used by multimedia/gmplayer/Makefile
# used by multimedia/mencoder/Makefile
# used by multimedia/mplayer/Makefile
@ -6,7 +6,7 @@
# sysutils/mencvcd uses one file from the tarball, please update
# it when updating this package.
MPLAYER_VERSION= 1.4
MPLAYER_VERSION= 1.5
DISTNAME= MPlayer-${MPLAYER_VERSION}

View file

@ -0,0 +1,12 @@
# $NetBSD: depends.mk,v 1.1 2022/04/24 15:00:42 nia Exp $
#
DEPENDS+= mplayer-share>=${MPLAYER_VERSION}:../../multimedia/mplayer-share
.include "../../converters/libiconv/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../multimedia/ffmpeg5/buildlink3.mk"
.include "../../multimedia/libass/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"

View file

@ -1,23 +1,19 @@
$NetBSD: distinfo,v 1.101 2021/10/26 11:01:13 nia Exp $
$NetBSD: distinfo,v 1.102 2022/04/24 15:00:42 nia Exp $
BLAKE2s (mplayer/MPlayer-1.4.tar.xz) = 6a705d082c5742bb4e0e1da296e910c6696cc768bb56325d15c203d77dd7c831
SHA512 (mplayer/MPlayer-1.4.tar.xz) = 8ef71cad187d8c8f81c837279bd3a421b440c892d3347a667670b21c954007e35cf0d15828f0901f347b9c1b053e8da4bc7f0fb6de34382d1e463074923d7b34
Size (mplayer/MPlayer-1.4.tar.xz) = 15054920 bytes
BLAKE2s (mplayer/MPlayer-1.5.tar.xz) = 1a86b823bcc82e07cf43551151449dd1cbdd768d8281ebe32cea6ced91d029c5
SHA512 (mplayer/MPlayer-1.5.tar.xz) = 05fe1edf23cec53be676333b6299df4b3f1ee746e5ccd96dc0bed550e7a1602ba7ba182c1cc23fcac67aacde849a46628b1dcab8ee3d3d4117415c11b6a6ad74
Size (mplayer/MPlayer-1.5.tar.xz) = 15379972 bytes
SHA1 (patch-Makefile) = be30a8e90383d6af5902380587b5075fd9c73b83
SHA1 (patch-ae) = 286f5ac075ea4123a1a6276f97e02a4dda9b3e67
SHA1 (patch-an) = 330c427e30b686165fda15a85b730a3f53e0d217
SHA1 (patch-configure) = 1bba1d39be27c31f2345c8303f252404538c192f
SHA1 (patch-configure) = 70eee721bfb49e811d1b3c9376bdada5438f6b17
SHA1 (patch-gui_interface.c) = 04c347b6cb0a54132e6b089142c8ed282f583a1c
SHA1 (patch-libao2_ao__alsa.c) = da568da8b9290f1ed49ecedec7dc9141408698b1
SHA1 (patch-libao2_ao_sun.c) = ce7042b394b9b8c051597c734b70290c8bf0a8d5
SHA1 (patch-libmpcodecs_ad__spdif.c) = e44131414a599efc5bc0b96ed19b5ad46cb0d381
SHA1 (patch-libvo_vo__corevideo.h) = c29a24266edb6727dda68a378fac413b5b0ab7ec
SHA1 (patch-libvo_vo__gif89a.c) = f7ee649bebef4b7f3fd4659613f61667109ee825
SHA1 (patch-libvo_vo__vdpau.c) = df3de0e079f7047228065bf36390aa3ad01b7f97
SHA1 (patch-mplayer.c) = 8cfdca9d062d4a10320a0471c91dd7c264aa963c
SHA1 (patch-stream_ai__alsa.c) = 1ed116931f4fde910c9bbe23680463a71631185c
SHA1 (patch-stream_dvb_tune.c) = 46cb5fb4700d7da5ed997dd468033c1edbe9be03
SHA1 (patch-stream_dvbin.h) = ee4f74eb786100e7cc62be228d73ce29d88638d1
SHA1 (patch-stream_stream__dvdnav.c) = 6f7e54629b32c83de8e4b31fe414b78f6043e0e8
SHA1 (patch-sub_osd.c) = 95f1bc1c20f181720a2a073acbb3abdde3921608
SHA1 (patch-sub_subreader.c) = 3ec0d3824b6e9fe34cb33e9463d833868f0b03c1

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.68 2021/06/22 12:35:45 nia Exp $
# $NetBSD: options.mk,v 1.69 2022/04/24 15:00:42 nia Exp $
.if defined(PKGNAME) && empty(PKGNAME:Mmplayer-share*)
@ -6,8 +6,6 @@
# not defined yet, so we cannot use it here.
PKG_OPTIONS_VAR= PKG_OPTIONS.${PKGNAME:C/-[0-9].*//}
.include "../../mk/oss.buildlink3.mk"
.include "../../multimedia/libvdpau/available.mk"
.include "../../comms/lirc/available.mk"
@ -23,17 +21,15 @@ PKG_OPTIONS_VAR= PKG_OPTIONS.${PKGNAME:C/-[0-9].*//}
# Options supported by both mplayer* or mencoder*.
PKG_SUPPORTED_OPTIONS= gif jpeg mad dts dv png theora vorbis x264 debug
PKG_SUPPORTED_OPTIONS= gif gnutls jpeg mad dts dv png theora vorbis x264 debug
PKG_SUPPORTED_OPTIONS+= dvdread dvdnav libmpg123 opus
. if ${OSS_TYPE} != "none"
PKG_SUPPORTED_OPTIONS+= oss
. endif
PKG_SUPPORTED_OPTIONS+= faad
# Set options based on the specific package being built.
. if !empty(PKGNAME:M*mplayer*)
PKG_SUPPORTED_OPTIONS+= aalib alsa caca ggi mplayer-menu nas pulseaudio sdl
PKG_SUPPORTED_OPTIONS+= aalib alsa caca ggi gnutls jack ladspa mplayer-menu nas
PKG_SUPPORTED_OPTIONS+= openal pulseaudio sdl
. if ${VDPAU_AVAILABLE} == "yes"
PKG_SUPPORTED_OPTIONS+= vdpau
@ -54,8 +50,7 @@ PKG_SUPPORTED_OPTIONS+= cdparanoia
PKG_SUPPORTED_OPTIONS.SunOS+= mlib
PKG_SUPPORTED_OPTIONS.Linux+= vidix
# TODO: v4l2 option probably could be supported on Linux and OpenBSD too
. if ${OPSYS} == "NetBSD" && exists(/usr/include/sys/videoio.h)
. if ${OPSYS} == "NetBSD" || ${OPSYS} == "Linux"
PKG_SUPPORTED_OPTIONS+= v4l2
PKG_SUGGESTED_OPTIONS+= v4l2
. endif
@ -66,7 +61,7 @@ PKG_SUGGESTED_OPTIONS+= v4l2
PKG_SUPPORTED_OPTIONS+= mplayer-runtime-cpudetection
. endif
. if ${MACHINE_ARCH} == "i386"
PKG_SUPPORTED_OPTIONS+= mplayer-default-cflags mplayer-win32
PKG_SUPPORTED_OPTIONS+= mplayer-win32
. endif
. if ${MACHINE_ARCH} == "i386" || ${MACHINE_ARCH} == "x86_64"
PKG_SUPPORTED_OPTIONS+= mplayer-ssse3
@ -80,10 +75,10 @@ PKG_SUPPORTED_OPTIONS+= xvid
# Define PKG_SUGGESTED_OPTIONS.
# -------------------------------------------------------------------------
. for o in dvdread dvdnav gif jpeg \
mplayer-menu \
mplayer-default-cflags mplayer-runtime-cpudetection \
oss png sdl vdpau lirc
. for o in dvdread dvdnav gif gnutls jpeg \
ladspa mplayer-menu \
mplayer-runtime-cpudetection \
png sdl vdpau lirc
. if !empty(PKG_SUPPORTED_OPTIONS:M${o})
PKG_SUGGESTED_OPTIONS+= ${o}
. endif
@ -265,12 +260,6 @@ CONFIGURE_ARGS+= --enable-nas
CONFIGURE_ARGS+= --disable-nas
. endif
. if ${OSS_TYPE} != "none" && !empty(PKG_OPTIONS:Moss)
CONFIGURE_ARGS+= --enable-ossaudio
. else
CONFIGURE_ARGS+= --disable-ossaudio
. endif
. if !empty(PKG_OPTIONS:Mpng)
CONFIGURE_ARGS+= --enable-png
. include "../../graphics/png/buildlink3.mk"
@ -349,6 +338,34 @@ CONFIGURE_ARGS+= --enable-lirc
CONFIGURE_ARGS+= --disable-lirc
. endif
. if !empty(PKG_OPTIONS:Mgnutls)
CONFIGURE_ARGS+= --enable-gnutls
. include "../../security/gnutls/buildlink3.mk"
. else
CONFIGURE_ARGS+= --disable-gnutls
. endif
. if !empty(PKG_OPTIONS:Mjack)
CONFIGURE_ARGS+= --enable-jack
. include "../../audio/jack/buildlink3.mk"
. else
CONFIGURE_ARGS+= --disable-jack
. endif
. if !empty(PKG_OPTIONS:Mopenal)
CONFIGURE_ARGS+= --enable-openal
. include "../../audio/openal-soft/buildlink3.mk"
. else
CONFIGURE_ARGS+= --disable-openal
. endif
. if !empty(PKG_OPTIONS:Mladspa)
CONFIGURE_ARGS+= --enable-ladspa
. include "../../audio/ladspa/buildlink3.mk"
. else
CONFIGURE_ARGS+= --disable-ladspa
. endif
# -------------------------------------------------------------------------
# Handle extra libraries (part 1)
# -------------------------------------------------------------------------

View file

@ -1,4 +1,4 @@
$NetBSD: patch-configure,v 1.3 2019/06/02 09:48:11 tsutsui Exp $
$NetBSD: patch-configure,v 1.4 2022/04/24 15:00:42 nia Exp $
o Handle properly sh3, evbarm, and arm64 ports on NetBSD.
o Fix CPU family detection on NetBSD with /proc mounted with "-o linux"
@ -12,9 +12,9 @@ o Explicitly enable PIE to avoid text relocations on NetBSD/i386 8.x
o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
(see PR/54229) and OpenBSD (no /dev/sound since 6.1)
--- configure.orig 2016-02-13 21:05:42.000000000 +0000
--- configure.orig 2022-02-27 09:09:00.000000000 +0000
+++ configure
@@ -1640,7 +1640,7 @@ else
@@ -1768,7 +1768,7 @@ else
cc_name=$cc_name_tmp
echocheck "$_cc version"
cc_vendor=gnu
@ -23,10 +23,10 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
case $cc_version in
2.96*)
cc_fail=yes
@@ -1717,8 +1717,13 @@ if test -z "$_target" ; then
@@ -1845,8 +1845,13 @@ if test -z "$_target" ; then
sun4*|sparc*) host_arch=sparc ;;
parisc*|hppa*|9000*) host_arch=hppa ;;
aarch64*) host_arch=aarch64 ;;
aarch64*|ARM64) host_arch=aarch64 ;;
- arm*|zaurus|cats) host_arch=arm ;;
- sh3|sh4|sh4a) host_arch=sh ;;
+ arm*|zaurus|cats|evbarm)
@ -39,7 +39,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
s390) host_arch=s390 ;;
s390x) host_arch=s390x ;;
*mips*) host_arch=mips ;;
@@ -1930,7 +1935,7 @@ if x86 ; then
@@ -2068,7 +2073,7 @@ if x86 ; then
# gather more CPU information
pname=$($_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -n 1)
pvendor=$($_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -n 1)
@ -48,7 +48,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
pmodel=$($_cpuinfo | grep -v 'model name' | grep 'model' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -n 1)
pstepping=$($_cpuinfo | grep 'stepping' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -n 1)
@@ -2446,7 +2451,12 @@ case "$host_arch" in
@@ -2585,7 +2590,12 @@ case "$host_arch" in
test $_fast_clz = "auto" && _fast_clz=yes
;;
@ -62,25 +62,25 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
arch='sh4'
iproc='sh4'
;;
@@ -2806,23 +2816,23 @@ fi # if darwin && test "$cc_vendor" = "g
_install_strip="-s"
@@ -2949,23 +2959,23 @@ else
fi
if test -z "$CFLAGS" || test "$_profile" != "" || test "$_debug" != ""; then
if test "$cc_vendor" = "intel" ; then
- CFLAGS="-O2 $_march $_mcpu $_pipe -fomit-frame-pointer"
+ CFLAGS="$CFLAGS -fomit-frame-pointer"
+ CFLAGS="$CFLAGS $_march $_mcpu $_pipe -fomit-frame-pointer"
WARNFLAGS="-wd167 -wd556 -wd144"
elif test "$cc_vendor" = "sun" ; then
- CFLAGS="-O2 $_march $_mcpu $_pipe -xc99 -xregs=frameptr"
+ CFLAGS="$CFLAGS -xc99 -xregs=frameptr"
+ CFLAGS="$CFLAGS $_march $_mcpu $_pipe -xc99 -xregs=frameptr"
elif test "$cc_vendor" = "clang"; then
- CFLAGS="-O2 $_march $_pipe"
+ CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $_march $_pipe"
elif test "$cc_vendor" != "gnu" ; then
- CFLAGS="-O2 $_march $_mcpu $_pipe"
+ CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $_march $_mcpu $_pipe"
else
- CFLAGS="-O4 $_march $_mcpu $_pipe -ffast-math -fomit-frame-pointer"
+ CFLAGS="$CFLAGS -ffast-math -fomit-frame-pointer"
+ CFLAGS="$CFLAGS $_march $_mcpu $_pipe -ffast-math -fomit-frame-pointer"
WARNFLAGS="-Wall -Wno-switch -Wno-parentheses -Wpointer-arith -Wredundant-decls -Werror=format-security"
WARN_CFLAGS="-Werror-implicit-function-declaration"
extra_ldflags="$extra_ldflags -ffast-math"
@ -88,11 +88,11 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
if test "$_profile" != "" || test "$_debug" != ""; then
- CFLAGS="-O2 $_march $_mcpu $_pipe $_debug $_profile"
+ CFLAGS="$CFLAGS $_debug $_profile"
+ CFLAGS="$CFLAGS $_march $_mcpu $_pipe $_debug $_profile"
WARNFLAGS="-W -Wall $WARNFLAGS"
_install_strip=
fi
@@ -2830,8 +2840,8 @@ else
@@ -2973,8 +2983,8 @@ else
warn_cflags=yes
fi
@ -103,7 +103,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
# On glibc, add some more CPPFLAGS for enabling required functionality.
cpp_condition_check features.h "defined __GLIBC__" &&
@@ -2878,10 +2888,11 @@ if test $relocatable = "auto" ; then
@@ -3030,10 +3040,11 @@ if test $relocatable = "auto" ; then
elif win32 && ! wine ; then
relocatable=no
res_comment="unnecessary and broken on win32"
@ -117,7 +117,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
elif x86_64 && cflag_check -fpie -pie ; then
extra_ldflags="$extra_ldflags -fpie -pie"
extra_cflags="$extra_cflags -fpie"
@@ -4615,7 +4626,11 @@ if test "$_x11" = auto && test "$_x11_he
@@ -4951,7 +4962,11 @@ if test "$_x11" = auto && test "$_x11_he
-L/usr/X11/lib -L/usr/lib32 -L/usr/openwin/lib -L/usr/local/lib64 -L/usr/X11R6/lib64 \
-L/usr/lib ; do
if netbsd; then
@ -130,7 +130,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
else
ld_tmp="$I -lXext -lX11 $ld_pthread"
fi
@@ -5018,6 +5033,8 @@ if test "$_aa" = yes ; then
@@ -5354,6 +5369,8 @@ if test "$_aa" = yes ; then
def_aa='#define CONFIG_AA 1'
if cygwin ; then
libs_mplayer="$libs_mplayer $(aalib-config --libs | cut -d " " -f 2,5,6)"
@ -139,7 +139,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
fi
vomodules="aa $vomodules"
else
@@ -5105,7 +5122,6 @@ EOF
@@ -5441,7 +5458,6 @@ EOF
extra_cflags="$extra_cflags $inc_tmp" && break
done
fi
@ -147,7 +147,7 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
if test "$_dvb" = yes ; then
_dvbin=yes
inputmodules="dvb $inputmodules"
@@ -5114,14 +5130,29 @@ if test "$_dvb" = yes ; then
@@ -5450,14 +5466,29 @@ if test "$_dvb" = yes ; then
aomodules="mpegpes(dvb) $aomodules"
vomodules="mpegpes(dvb) $vomodules"
else
@ -183,10 +183,10 @@ o use /dev/audio instead of /dev/sound for OSS audio device for NetBSD
if darwin; then
@@ -5786,7 +5817,7 @@ if test "$_ossaudio" = yes ; then
@@ -6117,7 +6148,7 @@ if test "$_ossaudio" = yes ; then
if test "$_real_ossaudio" = yes; then
def_ossaudio_devdsp='#define PATH_DEV_DSP "/dev/dsp"'
elif netbsd || openbsd ; then
elif netbsd ; then
- def_ossaudio_devdsp='#define PATH_DEV_DSP "/dev/sound"'
+ def_ossaudio_devdsp='#define PATH_DEV_DSP "/dev/audio"'
extra_ldflags="$extra_ldflags -lossaudio"

View file

@ -1,24 +0,0 @@
$NetBSD: patch-libmpcodecs_ad__spdif.c,v 1.1 2021/04/10 13:06:50 ryoon Exp $
* Fix build with ffmpeg4-4.4.
From upstream revision 38198.
--- libmpcodecs/ad_spdif.c.orig 2016-03-06 13:00:49.000000000 +0000
+++ libmpcodecs/ad_spdif.c
@@ -298,14 +298,8 @@ static void uninit(sh_audio_t *sh)
if (spdif_ctx->header_written)
av_write_trailer(lavf_ctx);
av_freep(&lavf_ctx->pb);
- if (lavf_ctx->streams) {
- av_freep(&lavf_ctx->streams[0]->codec);
- av_freep(&lavf_ctx->streams[0]->info);
- av_freep(&lavf_ctx->streams[0]);
- }
- av_freep(&lavf_ctx->streams);
- av_freep(&lavf_ctx->priv_data);
+ avformat_free_context(lavf_ctx);
+ lavf_ctx = NULL;
}
- av_freep(&lavf_ctx);
av_freep(&spdif_ctx);
}

View file

@ -1,41 +0,0 @@
$NetBSD: patch-libvo_vo__gif89a.c,v 1.3 2015/11/21 09:47:23 leot Exp $
* Fix build with giflib 5.1.
--- libvo/vo_gif89a.c.orig 2014-10-05 02:39:08.000000000 +0000
+++ libvo/vo_gif89a.c
@@ -44,6 +44,7 @@
* entire argument being interpretted as the filename.
*/
+#include <stddef.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -227,7 +228,7 @@ static int config(uint32_t s_width, uint
return 1;
}
- reduce_cmap = MakeMapObject(256, NULL);
+ reduce_cmap = GifMakeMapObject(256, NULL);
if (reduce_cmap == NULL) {
free(slice_data); slice_data = NULL;
free(reduce_data); reduce_data = NULL;
@@ -284,7 +285,7 @@ static int gif_reduce(int width, int hei
}
R = Ra; G = Ga; B = Ba;
- return QuantizeBuffer(width, height, &size, R, G, B, dst, colors);
+ return GifQuantizeBuffer(width, height, &size, R, G, B, dst, colors);
}
static void flip_page(void)
@@ -377,7 +378,7 @@ static void uninit(void)
free(gif_filename);
free(slice_data);
free(reduce_data);
- if (reduce_cmap != NULL) FreeMapObject(reduce_cmap);
+ if (reduce_cmap != NULL) GifFreeMapObject(reduce_cmap);
// set the pointers back to null.
new_gif = NULL;

View file

@ -1,15 +0,0 @@
$NetBSD: patch-libvo_vo__vdpau.c,v 1.1 2017/10/23 10:38:22 ryoon Exp $
* Include vdpau_x11.h explicitly to fix build of multimedia/mplayer
with ffmpeg 3.4
--- libvo/vo_vdpau.c.orig 2016-02-14 22:28:20.000000000 +0000
+++ libvo/vo_vdpau.c
@@ -51,6 +51,7 @@
#include "subopt-helper.h"
#include "libavcodec/vdpau.h"
+#include <vdpau/vdpau_x11.h>
#include "libavutil/common.h"
#include "libavutil/mathematics.h"

View file

@ -1,18 +0,0 @@
$NetBSD: patch-sub_osd.c,v 1.3 2015/11/21 09:47:23 leot Exp $
XXX: OS X support
--- sub/osd.c.orig 2012-09-02 21:17:03.000000000 +0000
+++ sub/osd.c
@@ -31,6 +31,11 @@
#include "libmpcodecs/img_format.h"
#include "cpudetect.h"
+#if ARCH_X86 && defined(__APPLE__)
+#undef ARCH_X86
+#define ARCH_X86 0
+#endif
+
#if ARCH_X86
static const uint64_t bFF __attribute__((aligned(8))) = 0xFFFFFFFFFFFFFFFFULL;
static const unsigned long long mask24lh __attribute__((aligned(8))) = 0xFFFF000000000000ULL;

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.108 2021/06/22 12:35:45 nia Exp $
# $NetBSD: Makefile,v 1.109 2022/04/24 15:00:42 nia Exp $
PKGNAME= mplayer-${MPLAYER_VERSION}
PKGREVISION= 3
COMMENT= Fast, cross-platform movie player
@ -14,18 +13,13 @@ CONFIGURE_ARGS+= --confdir=${PREFIX}/share/mplayer
CONFIGURE_ARGS+= --enable-xvmc
CONFIGURE_ARGS+= --with-xvmclib=XvMCW
# Solaris/x86 has Xv, but the header files live in /usr/X11R6, not
# ${X11_BASE}, so we need to also look for headers in this path.
.if ${OPSYS} == "SunOS" && ${MACHINE_ARCH} == "i386"
CPPFLAGS+= -I/usr/X11R6/include
BUILDLINK_PASSTHRU_DIRS+= /usr/X11R6/include
.endif
INSTALLATION_DIRS+= bin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mplayer ${DESTDIR}${PREFIX}/bin
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../multimedia/mplayer-share/depends.mk"
.include "../../x11/libXScrnSaver/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
@ -33,11 +27,5 @@ do-install:
.include "../../x11/libXvMC/buildlink3.mk"
.include "../../x11/libXxf86dga/buildlink3.mk"
.include "../../x11/libXxf86vm/buildlink3.mk"
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../multimedia/mplayer-share/Makefile.depends"
.include "../../mk/termcap.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
.include "../../multimedia/mplayer-share/Makefile.cflags"

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.17 2020/03/01 11:50:24 wiz Exp $
# $NetBSD: Makefile,v 1.18 2022/04/24 15:00:42 nia Exp $
DISTNAME= MPlayer-1.4
DISTNAME= MPlayer-1.5
PKGNAME= ${DISTNAME:S/MPlayer/mencvcd/}
CATEGORIES= sysutils
MASTER_SITES= http://www.mplayerhq.hu/MPlayer/releases/

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.9 2021/10/26 11:19:51 nia Exp $
$NetBSD: distinfo,v 1.10 2022/04/24 15:00:42 nia Exp $
BLAKE2s (mplayer/MPlayer-1.4.tar.xz) = 6a705d082c5742bb4e0e1da296e910c6696cc768bb56325d15c203d77dd7c831
SHA512 (mplayer/MPlayer-1.4.tar.xz) = 8ef71cad187d8c8f81c837279bd3a421b440c892d3347a667670b21c954007e35cf0d15828f0901f347b9c1b053e8da4bc7f0fb6de34382d1e463074923d7b34
Size (mplayer/MPlayer-1.4.tar.xz) = 15054920 bytes
BLAKE2s (mplayer/MPlayer-1.5.tar.xz) = 1a86b823bcc82e07cf43551151449dd1cbdd768d8281ebe32cea6ced91d029c5
SHA512 (mplayer/MPlayer-1.5.tar.xz) = 05fe1edf23cec53be676333b6299df4b3f1ee746e5ccd96dc0bed550e7a1602ba7ba182c1cc23fcac67aacde849a46628b1dcab8ee3d3d4117415c11b6a6ad74
Size (mplayer/MPlayer-1.5.tar.xz) = 15379972 bytes
SHA1 (patch-TOOLS_mencvcd.sh) = 61ee925b9fcc5790158e1ea45b01380b837a0f2a