Changes 4.0nb2:

* Revision bump for boost-1.43.0
* Enable OpenMP on Mac OS X
This commit is contained in:
adam 2010-05-15 05:47:58 +00:00
parent fdf205fa7a
commit 2437d2ef12
3 changed files with 23 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.5 2010/01/18 09:58:57 wiz Exp $
# $NetBSD: Makefile,v 1.6 2010/05/15 05:47:58 adam Exp $
DISTNAME= enblend-enfuse-4.0
# XXX distribution file has changed; remove the line below on next update
DIST_SUBDIR= ${PKGNAME_NOREV}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=enblend/}
@ -25,6 +25,7 @@ GNU_CONFIGURE= yes
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "Darwin"
CONFIGURE_ARGS+= --enable-openmp
CONFIGURE_ARGS+= --with-apple-opengl-framework
.else
CONFIGURE_ARGS+= --with-x

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2010/01/05 09:32:36 adam Exp $
$NetBSD: distinfo,v 1.4 2010/05/15 05:47:58 adam Exp $
SHA1 (enblend-enfuse-4.0/enblend-enfuse-4.0.tar.gz) = 34c3a5ce11c6ef0ef520d8a15a3cb6a94a567033
RMD160 (enblend-enfuse-4.0/enblend-enfuse-4.0.tar.gz) = 9e531b5bf6f7258ef8778c01b456979e0bc04338
@ -6,3 +6,4 @@ Size (enblend-enfuse-4.0/enblend-enfuse-4.0.tar.gz) = 1046677 bytes
SHA1 (patch-aa) = b1809fe6ef6609658b697635c6cbf0c112a03fd1
SHA1 (patch-ab) = afc074bb94e2a2b96c654c37540072514ba0bce0
SHA1 (patch-ac) = 916f4655ff30013583014eb8deecc72bd19ae55d
SHA1 (patch-ad) = bc0a04dbf7477c3db7c9ef979fb851a975a93571

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ad,v 1.1 2010/05/15 05:47:58 adam Exp $
--- configure.orig 2009-12-20 15:40:28.000000000 +0000
+++ configure
@@ -14111,11 +14107,11 @@ cat >>conftest.$ac_ext <<_ACEOF
#ifdef __cplusplus
extern "C"
#endif
-char omp_set_num_threads ();
+#include <omp.h>
int
main ()
{
-return omp_set_num_threads ();
+return omp_get_num_threads ();
;
return 0;
}