Thou shalt not clobber other packages files.
This commit is contained in:
parent
a888b4ec93
commit
24482afd55
6 changed files with 81 additions and 50 deletions
|
@ -3,7 +3,7 @@
|
|||
# Date created: 11 October 1997
|
||||
# Whom: hubertf
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.7 1998/02/12 13:33:01 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.8 1998/02/22 10:06:44 tron Exp $
|
||||
# FreeBSD Id: Makefile,v 1.30 1997/12/14 02:03:53 asami Exp
|
||||
#
|
||||
|
||||
|
@ -20,7 +20,7 @@ RUN_DEPENDS= ${PREFIX}/bin/install-info:${PORTSDIR}/devel/gtexinfo
|
|||
GNU_CONFIGURE= yes
|
||||
#USE_GMAKE= yes
|
||||
CONFIGURE_ARGS+= ${MACHINE_ARCH}--netbsd --with-pop --with-x --with-x-toolkit=lucid
|
||||
MAN1= emacs.1 etags.1 ctags.1
|
||||
MAN1= emacs.1 emacs-etags.1 emacs-ctags.1
|
||||
OPSYS!= uname -s
|
||||
MAKE_ENV+= INSTALL_STRIP=${STRIPFLAG} \
|
||||
INSTALL_SCRIPT="${INSTALL_SCRIPT}"
|
||||
|
|
|
@ -178,42 +178,6 @@
|
|||
@comment !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||
@comment @setchapternewpage odd !! we don't want blank pages !!
|
||||
@comment %**end of header (This is for running Texinfo on a region)
|
||||
--- ./Makefile.in.org Mon Aug 19 21:12:19 1996
|
||||
+++ ./Makefile.in Tue Apr 15 00:15:28 1997
|
||||
@@ -184,7 +184,7 @@
|
||||
# Subdirectories to make recursively. `lisp' is not included
|
||||
# because the compiled lisp files are part of the distribution
|
||||
# and you cannot remake them without installing Emacs first.
|
||||
-SUBDIR = lib-src src leim
|
||||
+SUBDIR = lib-src src leim man
|
||||
|
||||
# The makefiles of the directories in $SUBDIR.
|
||||
SUBDIR_MAKEFILES = lib-src/Makefile man/Makefile src/Makefile oldXMenu/Makefile lwlib/Makefile
|
||||
@@ -368,14 +368,8 @@
|
||||
if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd ${infodir} && /bin/pwd)` ]; \
|
||||
then \
|
||||
(cd ${infodir}; \
|
||||
- if [ -f dir ]; then \
|
||||
- if [ ! -f dir.old ]; then mv -f dir dir.old; \
|
||||
- else mv -f dir dir.bak; fi; \
|
||||
- fi; \
|
||||
cd ${srcdir}/info ; \
|
||||
- (cd $${thisdir}; ${INSTALL_DATA} ${srcdir}/info/dir ${infodir}/dir); \
|
||||
- (cd $${thisdir}; chmod a+r ${infodir}/dir); \
|
||||
- for f in ccmode* cl* dired-x* ediff* emacs* forms* gnus* info* message* mh-e* sc* vip*; do \
|
||||
+ for f in ccmode* cl* dired-x* ediff* emacs* forms* gnus* message* mh-e* sc* vip*; do \
|
||||
(cd $${thisdir}; \
|
||||
${INSTALL_DATA} ${srcdir}/info/$$f ${infodir}/$$f; \
|
||||
chmod a+r ${infodir}/$$f); \
|
||||
@@ -426,7 +420,7 @@
|
||||
esac ; \
|
||||
fi ; \
|
||||
done
|
||||
- (cd ${infodir} && rm -f cl* dired-x* ediff* emacs* forms* gnus* info* mh-e* sc* vip*)
|
||||
+ (cd ${infodir} && rm -f cl* dired-x* ediff* emacs* forms* gnus* mh-e* sc* vip*)
|
||||
(cd ${man1dir} && rm -f emacs.1 etags.1 ctags.1)
|
||||
(cd ${bindir} && rm -f emacs-${version} $(EMACS))
|
||||
|
||||
--- ./man/Makefile.in.org Thu Jun 27 15:27:19 1996
|
||||
+++ ./man/Makefile.in Tue Apr 15 00:29:52 1997
|
||||
@@ -13,7 +13,7 @@
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- lib-src/Makefile.in.orig Mon Jul 28 07:50:45 1997
|
||||
+++ lib-src/Makefile.in Thu Feb 12 12:00:56 1998
|
||||
+++ lib-src/Makefile.in Sat Feb 21 23:22:00 1998
|
||||
@@ -276,7 +276,7 @@
|
||||
if [ `(cd ${archlibdir} && /bin/pwd)` \
|
||||
!= `(cd ${srcdir} && /bin/pwd)` ]; then \
|
||||
|
@ -9,12 +9,22 @@
|
|||
done ; \
|
||||
fi
|
||||
|
||||
@@ -288,7 +288,7 @@
|
||||
chmod a+rx ${bindir}/$${file}; \
|
||||
@@ -284,12 +284,14 @@
|
||||
@echo
|
||||
@echo "Installing utilities for users to run."
|
||||
for file in ${INSTALLABLES} ; do \
|
||||
- $(INSTALL_PROGRAM) $${file} ${bindir}/$${file} ; \
|
||||
- chmod a+rx ${bindir}/$${file}; \
|
||||
+ if [ $${file} = emacsclient ]; then \
|
||||
+ $(INSTALL_PROGRAM) $${file} ${bindir}/$${file} ; \
|
||||
+ else \
|
||||
+ $(INSTALL_PROGRAM) $${file} ${bindir}/emacs-$${file} ; \
|
||||
+ fi ; \
|
||||
done
|
||||
for file in ${INSTALLABLE_SCRIPTS} ; do \
|
||||
- $(INSTALL_PROGRAM) ${srcdir}/$${file} ${bindir}/$${file} ; \
|
||||
+ $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/$${file} ; \
|
||||
chmod a+rx ${bindir}/$${file}; \
|
||||
- chmod a+rx ${bindir}/$${file}; \
|
||||
+ $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/emacs-$${file} ; \
|
||||
done
|
||||
|
||||
uninstall:
|
||||
|
|
5
editors/emacs/patches/patch-ad
Normal file
5
editors/emacs/patches/patch-ad
Normal file
|
@ -0,0 +1,5 @@
|
|||
--- etc/ctags.1.orig Fri Jul 17 18:58:29 1992
|
||||
+++ etc/ctags.1 Sat Feb 21 20:59:45 1998
|
||||
@@ -1 +1 @@
|
||||
-.so man1/etags.1
|
||||
+.so man1/emacs-etags.1
|
52
editors/emacs/patches/patch-ae
Normal file
52
editors/emacs/patches/patch-ae
Normal file
|
@ -0,0 +1,52 @@
|
|||
--- Makefile.in.orig Tue Sep 16 22:23:57 1997
|
||||
+++ Makefile.in Sat Feb 21 23:49:32 1998
|
||||
@@ -185,7 +185,7 @@
|
||||
# Subdirectories to make recursively. `lisp' is not included
|
||||
# because the compiled lisp files are part of the distribution
|
||||
# and you cannot remake them without installing Emacs first.
|
||||
-SUBDIR = lib-src src leim
|
||||
+SUBDIR = lib-src src leim man
|
||||
|
||||
# The makefiles of the directories in $SUBDIR.
|
||||
SUBDIR_MAKEFILES = lib-src/Makefile man/Makefile src/Makefile oldXMenu/Makefile lwlib/Makefile leim/Makefile
|
||||
@@ -357,14 +357,8 @@
|
||||
if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd ${infodir} && /bin/pwd)` ]; \
|
||||
then \
|
||||
(cd ${infodir}; \
|
||||
- if [ -f dir ]; then \
|
||||
- if [ ! -f dir.old ]; then mv -f dir dir.old; \
|
||||
- else mv -f dir dir.bak; fi; \
|
||||
- fi; \
|
||||
cd ${srcdir}/info ; \
|
||||
- (cd $${thisdir}; ${INSTALL_DATA} ${srcdir}/info/dir ${infodir}/dir); \
|
||||
- (cd $${thisdir}; chmod a+r ${infodir}/dir); \
|
||||
- for f in ccmode* cl* dired-x* ediff* emacs* forms* gnus* info* message* mh-e* sc* vip*; do \
|
||||
+ for f in ccmode* cl* dired-x* ediff* emacs* forms* gnus* message* mh-e* sc* vip*; do \
|
||||
(cd $${thisdir}; \
|
||||
${INSTALL_DATA} ${srcdir}/info/$$f ${infodir}/$$f; \
|
||||
chmod a+r ${infodir}/$$f); \
|
||||
@@ -374,8 +368,13 @@
|
||||
cd ${srcdir}/etc; \
|
||||
for page in emacs etags ctags ; do \
|
||||
(cd $${thisdir}; \
|
||||
- ${INSTALL_DATA} ${srcdir}/etc/$${page}.1 ${man1dir}/$${page}${manext}; \
|
||||
- chmod a+r ${man1dir}/$${page}${manext}); \
|
||||
+ if [ $${page} = emacs ]; then \
|
||||
+ ${INSTALL_DATA} ${srcdir}/etc/$${page}.1 ${man1dir}/$${page}${manext}; \
|
||||
+ chmod a+r ${man1dir}/$${page}${manext}; \
|
||||
+ else \
|
||||
+ ${INSTALL_DATA} ${srcdir}/etc/$${page}.1 ${man1dir}/emacs-$${page}${manext}; \
|
||||
+ chmod a+r ${man1dir}/emacs-$${page}${manext}; \
|
||||
+ fi) \
|
||||
done
|
||||
|
||||
### Install LEIM files. Although they are machine-independent, we
|
||||
@@ -421,7 +420,7 @@
|
||||
esac ; \
|
||||
fi ; \
|
||||
done
|
||||
- (cd ${infodir} && rm -f cl* dired-x* ediff* emacs* forms* gnus* info* mh-e* sc* vip*)
|
||||
+ (cd ${infodir} && rm -f cl* dired-x* ediff* emacs* forms* gnus* mh-e* sc* vip*)
|
||||
(cd ${man1dir} && rm -f emacs.1 etags.1 ctags.1)
|
||||
(cd ${bindir} && rm -f emacs-${version} $(EMACS))
|
||||
|
|
@ -1,9 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 1998/02/12 13:33:18 hubertf Exp $
|
||||
bin/etags
|
||||
bin/ctags
|
||||
@comment $NetBSD: PLIST,v 1.7 1998/02/22 10:06:45 tron Exp $
|
||||
bin/emacs-etags
|
||||
bin/emacs-ctags
|
||||
bin/emacsclient
|
||||
bin/b2m
|
||||
bin/rcs-checkin
|
||||
bin/emacs-b2m
|
||||
bin/emacs-rcs-checkin
|
||||
bin/emacs-20.2
|
||||
bin/emacs
|
||||
@unexec %D/bin/install-info --delete %D/info/ccmode %D/info/dir
|
||||
|
@ -124,8 +124,8 @@ libexec/emacs/20.2/${MACHINE_ARCH}--netbsd/hexl
|
|||
libexec/emacs/20.2/${MACHINE_ARCH}--netbsd/rcs2log
|
||||
libexec/emacs/20.2/${MACHINE_ARCH}--netbsd/vcdiff
|
||||
man/man1/emacs.1
|
||||
man/man1/etags.1
|
||||
man/man1/ctags.1
|
||||
man/man1/emacs-etags.1
|
||||
man/man1/emacs-ctags.1
|
||||
share/emacs/20.2/etc/e/eterm
|
||||
share/emacs/20.2/etc/e/eterm.ti
|
||||
share/emacs/20.2/etc/COPYING
|
||||
|
|
Loading…
Reference in a new issue