Changes 9.0.3:

* Before exiting walreceiver, ensure all the received WAL is fsync'd to disk
* Avoid excess fsync activity in walreceiver
* Make "ALTER TABLE" revalidate uniqueness and exclusion constraints when needed
* Fix EvalPlanQual for "UPDATE" of an inheritance tree in which the tables are
  not all alike
* Avoid failures when "EXPLAIN" tries to display a simple-form CASE expression
* Fix assignment to an array slice that is before the existing range of
  subscripts
* Avoid unexpected conversion overflow in planner for very distant date values
* Fix PL/Python crash when an array contains null entries
* Remove ecpg's fixed length limit for constants defining an array dimension
* Fix erroneous parsing of tsquery values containing ... &
  !(subexpression) | ...
* Fix buffer overrun in "contrib/intarray"'s input function for the query_int
  type
* Fix bug in "contrib/seg"'s GiST picksplit algorithm
This commit is contained in:
adam 2011-02-09 08:48:16 +00:00
parent 4508467630
commit 245a7388d4
30 changed files with 178 additions and 351 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:27 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:17 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-adminpack-/}
COMMENT= Admin pack module for pgAdmin management
@ -9,10 +9,11 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
BUILD_DIRS= contrib/adminpack
BUILD_MAKE_FLAGS= PGXS=1
REQD_DIRS+= ${PG_SUBPREFIX}share/doc/postgresql/contrib
REQD_DIRS+= ${PG_SUBPREFIX}share/postgresql/contrib

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2010/12/24 08:07:57 asau Exp $
${PG_SUBPREFIX}lib/postgresql/adminpack.la
@comment $NetBSD: PLIST,v 1.4 2011/02/09 08:48:17 adam Exp $
${PG_SUBPREFIX}lib/postgresql/adminpack.so
${PG_SUBPREFIX}share/postgresql/contrib/adminpack.sql
${PG_SUBPREFIX}share/postgresql/contrib/uninstall_adminpack.sql

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.5 2011/02/08 15:50:07 brook Exp $
# $NetBSD: Makefile,v 1.6 2011/02/09 08:48:17 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-client-/}
COMMENT= PostgreSQL database client programs
@ -8,7 +8,6 @@ PKG_DESTDIR_SUPPORT= user-destdir
.include "../../databases/postgresql90/Makefile.common"
USE_TOOLS+= gzip tar
USE_LIBTOOL= yes
CONFIGURE_ARGS+= --with-openssl
CONFIGURE_ARGS+= --with-readline
CONFIGURE_ARGS+= --with-zlib

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2010/12/24 03:41:38 asau Exp $
@comment $NetBSD: PLIST,v 1.5 2011/02/09 08:48:17 adam Exp $
${PG_SUBPREFIX}bin/clusterdb
${PG_SUBPREFIX}bin/createdb
${PG_SUBPREFIX}bin/createlang
@ -509,11 +509,23 @@ ${PG_SUBPREFIX}include/sqlca.h
${PG_SUBPREFIX}include/sqlda-compat.h
${PG_SUBPREFIX}include/sqlda-native.h
${PG_SUBPREFIX}include/sqlda.h
${PG_SUBPREFIX}lib/libecpg.la
${PG_SUBPREFIX}lib/libecpg_compat.la
${PG_SUBPREFIX}lib/libecpg.so
${PG_SUBPREFIX}lib/libecpg.so.6
${PG_SUBPREFIX}lib/libecpg.so.6.2
${PG_SUBPREFIX}lib/libecpg.a
${PG_SUBPREFIX}lib/libecpg_compat.so
${PG_SUBPREFIX}lib/libecpg_compat.so.3
${PG_SUBPREFIX}lib/libecpg_compat.so.3.2
${PG_SUBPREFIX}lib/libecpg_compat.a
${PG_SUBPREFIX}lib/libpgport.a
${PG_SUBPREFIX}lib/libpgtypes.la
${PG_SUBPREFIX}lib/libpq.la
${PG_SUBPREFIX}lib/libpgtypes.so
${PG_SUBPREFIX}lib/libpgtypes.so.3
${PG_SUBPREFIX}lib/libpgtypes.so.3.1
${PG_SUBPREFIX}lib/libpgtypes.a
${PG_SUBPREFIX}lib/libpq.so
${PG_SUBPREFIX}lib/libpq.so.5
${PG_SUBPREFIX}lib/libpq.so.5.3
${PG_SUBPREFIX}lib/libpq.a
${PG_SUBPREFIX}lib/postgresql/pgxs/config/install-sh
${PG_SUBPREFIX}lib/postgresql/pgxs/src/Makefile.global
${PG_SUBPREFIX}lib/postgresql/pgxs/src/Makefile.port

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.3 2010/12/24 08:10:36 asau Exp $
# $NetBSD: buildlink3.mk,v 1.4 2011/02/09 08:48:17 adam Exp $
BUILDLINK_TREE+= postgresql90-client
@ -23,6 +23,7 @@ BUILDLINK_FILES.postgresql90-client+= bin/pg_config
.endif
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.endif # POSTGRESQL90_CLIENT_BUILDLINK3_MK

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:27 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:18 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-datatypes-/}
COMMENT= PostgreSQL data types support modules
@ -9,9 +9,12 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
CONFIGURE_ARGS+= --with-ossp-uuid
BUILD_MAKE_FLAGS= PGXS=1
# because global pg_config.h is included, we have to define this
CPPFLAGS+= -DHAVE_UUID_H
BUILD_DIRS+= contrib/citext
BUILD_DIRS+= contrib/hstore

View file

@ -1,12 +1,12 @@
@comment $NetBSD: PLIST,v 1.3 2010/12/24 08:13:34 asau Exp $
${PG_SUBPREFIX}lib/postgresql/_int.la
@comment $NetBSD: PLIST,v 1.4 2011/02/09 08:48:18 adam Exp $
${PG_SUBPREFIX}lib/postgresql/_int.so
${PG_SUBPREFIX}lib/postgresql/citext.so
${PG_SUBPREFIX}lib/postgresql/hstore.la
${PG_SUBPREFIX}lib/postgresql/hstore.so
${PG_SUBPREFIX}lib/postgresql/isn.so
${PG_SUBPREFIX}lib/postgresql/lo.so
${PG_SUBPREFIX}lib/postgresql/ltree.la
${PG_SUBPREFIX}lib/postgresql/unaccent.la
${PG_SUBPREFIX}lib/postgresql/uuid-ossp.la
${PG_SUBPREFIX}lib/postgresql/ltree.so
${PG_SUBPREFIX}lib/postgresql/unaccent.so
${PG_SUBPREFIX}lib/postgresql/uuid-ossp.so
${PG_SUBPREFIX}share/postgresql/contrib/_int.sql
${PG_SUBPREFIX}share/postgresql/contrib/citext.sql
${PG_SUBPREFIX}share/postgresql/contrib/hstore.sql

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:28 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:18 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-dblink-/}
COMMENT= Dblink module for remote database connections
@ -9,8 +9,10 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
CONFIGURE_ARGS+= --with-openssl
BUILD_MAKE_FLAGS= PGXS=1
BUILD_DIRS= src/interfaces/libpq
BUILD_DIRS+= contrib/dblink

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2010/12/24 08:16:19 asau Exp $
${PG_SUBPREFIX}lib/postgresql/dblink.la
@comment $NetBSD: PLIST,v 1.3 2011/02/09 08:48:18 adam Exp $
${PG_SUBPREFIX}lib/postgresql/dblink.so
${PG_SUBPREFIX}share/postgresql/contrib/dblink.sql
${PG_SUBPREFIX}share/postgresql/contrib/uninstall_dblink.sql

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2010/12/24 12:20:51 asau Exp $
@comment $NetBSD: PLIST,v 1.5 2011/02/09 08:48:18 adam Exp $
${PG_SUBPREFIX}man/man1/clusterdb.1
${PG_SUBPREFIX}man/man1/createdb.1
${PG_SUBPREFIX}man/man1/createlang.1
@ -881,6 +881,7 @@ ${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-17.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-18.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-19.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-2.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-20.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-3.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-4.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-2-5.html
@ -894,6 +895,7 @@ ${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-10.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-11.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-12.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-13.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-14.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-2.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-3.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-3-4.html
@ -909,9 +911,11 @@ ${PG_SUBPREFIX}share/doc/postgresql/html/release-8-4-3.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-4-4.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-4-5.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-4-6.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-4-7.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-8-4.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-9-0-1.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-9-0-2.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-9-0-3.html
${PG_SUBPREFIX}share/doc/postgresql/html/release-9-0.html
${PG_SUBPREFIX}share/doc/postgresql/html/release.html
${PG_SUBPREFIX}share/doc/postgresql/html/resources.html

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 2010/12/19 09:53:28 adam Exp $
# $NetBSD: Makefile,v 1.4 2011/02/09 08:48:18 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-monitoring-/}
COMMENT= PostgreSQL monitoring tools
@ -9,8 +9,9 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
BUILD_MAKE_FLAGS= PGXS=1
BUILD_DIRS+= contrib/auto_explain
BUILD_DIRS+= contrib/pg_buffercache

View file

@ -1,8 +1,8 @@
@comment $NetBSD: PLIST,v 1.3 2010/12/19 09:53:28 adam Exp $
lib/postgresql/auto_explain.la
lib/postgresql/pg_buffercache.la
lib/postgresql/pg_stat_statements.la
lib/postgresql/pgstattuple.la
@comment $NetBSD: PLIST,v 1.4 2011/02/09 08:48:18 adam Exp $
lib/postgresql/auto_explain.so
lib/postgresql/pg_buffercache.so
lib/postgresql/pg_stat_statements.so
lib/postgresql/pgstattuple.so
share/postgresql/contrib/pg_buffercache.sql
share/postgresql/contrib/pg_stat_statements.sql
share/postgresql/contrib/pgstattuple.sql

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:28 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:18 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-pgcrypto-/}
COMMENT= Module providing cryptographic functions for PostgreSQL
@ -9,8 +9,10 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
CONFIGURE_ARGS+= --with-zlib
BUILD_MAKE_FLAGS= PGXS=1
BUILD_DIRS= contrib/pgcrypto
REQD_DIRS+= ${PG_SUBPREFIX}share/doc/postgresql/contrib

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2010/12/19 09:53:28 adam Exp $
lib/postgresql/pgcrypto.la
@comment $NetBSD: PLIST,v 1.3 2011/02/09 08:48:19 adam Exp $
lib/postgresql/pgcrypto.so
share/postgresql/contrib/pgcrypto.sql
share/postgresql/contrib/uninstall_pgcrypto.sql

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:28 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:19 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-plperl-/}
COMMENT= PL/Perl procedural language for the PostgreSQL backend
@ -9,15 +9,15 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
USE_TOOLS+= perl
PERL5_CONFIGURE= no
CONFIGURE_ARGS+= --with-perl
BUILD_MAKE_FLAGS= PGXS=1
BUILD_DIRS= src/pl/plperl
MAKE_FILE= GNUmakefile
BUILD_MAKE_FLAGS= PGXS=1
.include "../../databases/postgresql90-client/buildlink3.mk"
.include "../../lang/perl5/module.mk"

View file

@ -1,11 +1,11 @@
@comment $NetBSD: PLIST,v 1.2 2010/12/19 09:53:28 adam Exp $
lib/postgresql/plperl.la
share/locale/de/LC_MESSAGES/plperl0-9.0.mo
share/locale/es/LC_MESSAGES/plperl0-9.0.mo
share/locale/fr/LC_MESSAGES/plperl0-9.0.mo
share/locale/it/LC_MESSAGES/plperl0-9.0.mo
share/locale/ja/LC_MESSAGES/plperl0-9.0.mo
share/locale/pt_BR/LC_MESSAGES/plperl0-9.0.mo
share/locale/ro/LC_MESSAGES/plperl0-9.0.mo
share/locale/tr/LC_MESSAGES/plperl0-9.0.mo
share/locale/zh_CN/LC_MESSAGES/plperl0-9.0.mo
@comment $NetBSD: PLIST,v 1.3 2011/02/09 08:48:19 adam Exp $
lib/postgresql/plperl.so
share/locale/de/LC_MESSAGES/plperl-9.0.mo
share/locale/es/LC_MESSAGES/plperl-9.0.mo
share/locale/fr/LC_MESSAGES/plperl-9.0.mo
share/locale/it/LC_MESSAGES/plperl-9.0.mo
share/locale/ja/LC_MESSAGES/plperl-9.0.mo
share/locale/pt_BR/LC_MESSAGES/plperl-9.0.mo
share/locale/ro/LC_MESSAGES/plperl-9.0.mo
share/locale/tr/LC_MESSAGES/plperl-9.0.mo
share/locale/zh_CN/LC_MESSAGES/plperl-9.0.mo

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:29 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:19 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-plpython-/}
COMMENT= PL/Python procedural language for the PostgreSQL backend
@ -9,12 +9,13 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
CONFIGURE_ARGS+= --with-python
CONFIGURE_ENV+= PYTHON="${PYTHONBIN}"
BUILD_DIRS= src/pl/plpython
BUILD_MAKE_FLAGS= PGXS=1
.include "../../databases/postgresql90-client/buildlink3.mk"
.include "../../lang/python/extension.mk"

View file

@ -1,12 +1,12 @@
@comment $NetBSD: PLIST,v 1.3 2010/12/19 09:53:29 adam Exp $
lib/postgresql/plpython.la
lib/postgresql/plpython2.la
share/locale/de/LC_MESSAGES/plpython0-9.0.mo
share/locale/es/LC_MESSAGES/plpython0-9.0.mo
share/locale/fr/LC_MESSAGES/plpython0-9.0.mo
share/locale/it/LC_MESSAGES/plpython0-9.0.mo
share/locale/ja/LC_MESSAGES/plpython0-9.0.mo
share/locale/pt_BR/LC_MESSAGES/plpython0-9.0.mo
share/locale/ro/LC_MESSAGES/plpython0-9.0.mo
share/locale/tr/LC_MESSAGES/plpython0-9.0.mo
share/locale/zh_CN/LC_MESSAGES/plpython0-9.0.mo
@comment $NetBSD: PLIST,v 1.4 2011/02/09 08:48:19 adam Exp $
lib/postgresql/plpython.so
lib/postgresql/plpython2.so
share/locale/de/LC_MESSAGES/plpython-9.0.mo
share/locale/es/LC_MESSAGES/plpython-9.0.mo
share/locale/fr/LC_MESSAGES/plpython-9.0.mo
share/locale/it/LC_MESSAGES/plpython-9.0.mo
share/locale/ja/LC_MESSAGES/plpython-9.0.mo
share/locale/pt_BR/LC_MESSAGES/plpython-9.0.mo
share/locale/ro/LC_MESSAGES/plpython-9.0.mo
share/locale/tr/LC_MESSAGES/plpython-9.0.mo
share/locale/zh_CN/LC_MESSAGES/plpython-9.0.mo

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2010/12/19 09:53:29 adam Exp $
# $NetBSD: Makefile,v 1.3 2011/02/09 08:48:19 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-pltcl-/}
COMMENT= PL/Tcl procedural language for the PostgreSQL backend
@ -9,12 +9,13 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
CONFIGURE_ARGS+= --with-tcl
CONFIGURE_ARGS+= --with-tclconfig="${BUILDLINK_PREFIX.tcl}/lib"
CONFIGURE_ENV+= TCLSH="${TCLSH}"
TCLSH= ${BUILDLINK_PREFIX.tcl}/bin/tclsh
BUILD_MAKE_FLAGS= PGXS=1
BUILD_DIRS= src/pl/tcl

View file

@ -1,15 +1,15 @@
@comment $NetBSD: PLIST,v 1.3 2010/12/19 09:53:29 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2011/02/09 08:48:19 adam Exp $
bin/pltcl_delmod
bin/pltcl_listmod
bin/pltcl_loadmod
lib/postgresql/pltcl.la
lib/postgresql/pltcl.so
share/postgresql/unknown.pltcl
share/locale/de/LC_MESSAGES/pltcl0-9.0.mo
share/locale/es/LC_MESSAGES/pltcl0-9.0.mo
share/locale/fr/LC_MESSAGES/pltcl0-9.0.mo
share/locale/it/LC_MESSAGES/pltcl0-9.0.mo
share/locale/ja/LC_MESSAGES/pltcl0-9.0.mo
share/locale/pt_BR/LC_MESSAGES/pltcl0-9.0.mo
share/locale/ro/LC_MESSAGES/pltcl0-9.0.mo
share/locale/tr/LC_MESSAGES/pltcl0-9.0.mo
share/locale/zh_CN/LC_MESSAGES/pltcl0-9.0.mo
share/locale/de/LC_MESSAGES/pltcl-9.0.mo
share/locale/es/LC_MESSAGES/pltcl-9.0.mo
share/locale/fr/LC_MESSAGES/pltcl-9.0.mo
share/locale/it/LC_MESSAGES/pltcl-9.0.mo
share/locale/ja/LC_MESSAGES/pltcl-9.0.mo
share/locale/pt_BR/LC_MESSAGES/pltcl-9.0.mo
share/locale/ro/LC_MESSAGES/pltcl-9.0.mo
share/locale/tr/LC_MESSAGES/pltcl-9.0.mo
share/locale/zh_CN/LC_MESSAGES/pltcl-9.0.mo

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2010/12/24 06:33:57 asau Exp $
# $NetBSD: Makefile,v 1.8 2011/02/09 08:48:19 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-server-/}
COMMENT= PostgreSQL database server programs
@ -11,8 +11,8 @@ NOT_FOR_PLATFORM= *-*-mips
.include "../../databases/postgresql90/Makefile.common"
# Use shlibtool (invoked as "$(LIBTOOL)") to build modules.
USE_LIBTOOL= yes
PKG_LIBTOOL= ${PKG_SHLIBTOOL}
#USE_LIBTOOL= yes
#PKG_LIBTOOL= ${PKG_SHLIBTOOL}
CONFIGURE_ARGS+= --with-openssl

View file

@ -1,54 +1,54 @@
@comment $NetBSD: PLIST,v 1.4 2010/12/24 06:34:38 asau Exp $
@comment $NetBSD: PLIST,v 1.5 2011/02/09 08:48:19 adam Exp $
${PG_SUBPREFIX}bin/postgres
${PG_SUBPREFIX}bin/postmaster
${PG_SUBPREFIX}lib/postgresql/ascii_and_mic.la
${PG_SUBPREFIX}lib/postgresql/cyrillic_and_mic.la
${PG_SUBPREFIX}lib/postgresql/dict_snowball.la
${PG_SUBPREFIX}lib/postgresql/euc2004_sjis2004.la
${PG_SUBPREFIX}lib/postgresql/euc_cn_and_mic.la
${PG_SUBPREFIX}lib/postgresql/euc_jp_and_sjis.la
${PG_SUBPREFIX}lib/postgresql/euc_kr_and_mic.la
${PG_SUBPREFIX}lib/postgresql/euc_tw_and_big5.la
${PG_SUBPREFIX}lib/postgresql/latin2_and_win1250.la
${PG_SUBPREFIX}lib/postgresql/latin_and_mic.la
${PG_SUBPREFIX}lib/postgresql/libpqwalreceiver.la
${PG_SUBPREFIX}lib/postgresql/plpgsql.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_ascii.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_big5.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_cyrillic.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc2004.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_cn.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_jp.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_kr.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_tw.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_gb18030.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_gbk.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_iso8859.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_iso8859_1.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_johab.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_sjis.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_sjis2004.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_uhc.la
${PG_SUBPREFIX}lib/postgresql/utf8_and_win.la
${PG_SUBPREFIX}lib/postgresql/ascii_and_mic.so
${PG_SUBPREFIX}lib/postgresql/cyrillic_and_mic.so
${PG_SUBPREFIX}lib/postgresql/dict_snowball.so
${PG_SUBPREFIX}lib/postgresql/euc2004_sjis2004.so
${PG_SUBPREFIX}lib/postgresql/euc_cn_and_mic.so
${PG_SUBPREFIX}lib/postgresql/euc_jp_and_sjis.so
${PG_SUBPREFIX}lib/postgresql/euc_kr_and_mic.so
${PG_SUBPREFIX}lib/postgresql/euc_tw_and_big5.so
${PG_SUBPREFIX}lib/postgresql/latin2_and_win1250.so
${PG_SUBPREFIX}lib/postgresql/latin_and_mic.so
${PG_SUBPREFIX}lib/postgresql/libpqwalreceiver.so
${PG_SUBPREFIX}lib/postgresql/plpgsql.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_ascii.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_big5.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_cyrillic.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc2004.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_cn.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_jp.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_kr.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_euc_tw.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_gb18030.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_gbk.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_iso8859.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_iso8859_1.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_johab.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_sjis.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_sjis2004.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_uhc.so
${PG_SUBPREFIX}lib/postgresql/utf8_and_win.so
${PG_SUBPREFIX}share/examples/rc.d/pgsql
${PG_SUBPREFIX}share/locale/de/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/de/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/de/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/es/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/es/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/es/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/fr/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/fr/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/fr/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/it/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/ja/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/it/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/ja/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/ja/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/ko/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/pt_BR/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/ko/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/pt_BR/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/pt_BR/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/ro/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/tr/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/ro/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/tr/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/tr/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/zh_CN/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/zh_CN/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/zh_CN/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/locale/zh_TW/LC_MESSAGES/plpgsql0-9.0.mo
${PG_SUBPREFIX}share/locale/zh_TW/LC_MESSAGES/plpgsql-9.0.mo
${PG_SUBPREFIX}share/locale/zh_TW/LC_MESSAGES/postgres-9.0.mo
${PG_SUBPREFIX}share/postgresql/conversion_create.sql
${PG_SUBPREFIX}share/postgresql/information_schema.sql

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 2010/12/19 09:53:30 adam Exp $
# $NetBSD: Makefile,v 1.4 2011/02/09 08:48:19 adam Exp $
PKGNAME= ${DISTNAME:C/-/90-upgrade-/}
COMMENT= PostgreSQL binary upgrade tool
@ -10,6 +10,8 @@ DEPENDS+= postgresql90-server>=${PKGVERSION_NOREV}:../../databases/postgresql90-
.include "../../databases/postgresql90/Makefile.common"
BUILD_MAKE_FLAGS= PGXS=1
BUILD_DIRS+= contrib/pg_upgrade
BUILD_DIRS+= contrib/pg_upgrade_support

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.8 2010/12/24 06:30:03 asau Exp $
# $NetBSD: Makefile.common,v 1.9 2011/02/09 08:48:16 adam Exp $
#
# used by databases/postgresql90-adminpack/Makefile
# used by databases/postgresql90-client/Makefile
@ -22,7 +22,7 @@
.include "../../databases/postgresql90/Makefile.mirrors"
DISTNAME= postgresql-9.0.2
DISTNAME= postgresql-9.0.3
CATEGORIES= databases
MASTER_SITES= ${PGSQL_MIRRORS:=source/v${PKGVERSION_NOREV}/}
EXTRACT_SUFX= .tar.bz2
@ -82,11 +82,6 @@ CONFIGURE_ARGS+= --without-readline
CONFIGURE_ARGS+= --without-tcl
CONFIGURE_ARGS+= --without-zlib
# Enable Bonjour on Mac OS X
.if ${OPSYS} == "Darwin"
CONFIGURE_ARGS+= --with-bonjour
.endif
# PGSQL_BLCKSZ is the size in bytes of a PostgreSQL disk page or block.
# This also limits the size of a tuple. The valid values are powers
# of 2 up to 32768, and the default size is 8196. Please don't change
@ -110,8 +105,6 @@ USE_LIBLTDL?= no
.if !defined(META_PACKAGE)
post-extract:
cp -f ${COMMON_FILESDIR}/Makefile.custom ${WRKSRC}/src/Makefile.custom
cp -f ${COMMON_FILESDIR}/Makefile.libtool ${WRKSRC}/src/Makefile.shlib
. if !empty(USE_LIBLTDL:M[yY][eE][sS])
cp -f ${COMMON_FILESDIR}/dynloader-ltdl.h \
${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.h

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.3 2010/12/19 09:53:27 adam Exp $
$NetBSD: distinfo,v 1.4 2011/02/09 08:48:17 adam Exp $
SHA1 (postgresql-9.0.2.tar.bz2) = 42a9518a2f11fa1d09a23bc628b00e992d3bcf4a
RMD160 (postgresql-9.0.2.tar.bz2) = 3313b4bafe3af6282f68f198da7d50af4d5c01c4
Size (postgresql-9.0.2.tar.bz2) = 14024244 bytes
SHA1 (postgresql-9.0.3.tar.bz2) = ea7b4729427f668cbf36184efbc58fd828a2d3ab
RMD160 (postgresql-9.0.3.tar.bz2) = 9f5e0584018265282a75be8597fb7ac51ccaa23a
Size (postgresql-9.0.3.tar.bz2) = 14040705 bytes
SHA1 (patch-aa) = c7e5aaff1c47d2e33df7692a412ef984c77ffcc0
SHA1 (patch-ab) = 6adfc53e325abe69582f1c7971f56144c697e9c1
SHA1 (patch-ac) = 76ddd3015d93b19cdd6000eaffc4f53cbd4965b5

View file

@ -1,36 +0,0 @@
# $NetBSD: Makefile.custom,v 1.2 2010/12/24 03:41:38 asau Exp $
#
# This file is included at the end of Makefile.global, which is included
# by every sub-Makefile in the build tree. Makefiles for shared
# libraries include Makefile.global then Makefile.shlib.
#
# Override any OS-specific locations for where to put SQL man pages.
sqlmansect = 7
# INSTALLED_LIBPQ is passed in from the environment and tells the build
# system how to link to an installed libpq.*.
#
ifdef INSTALLED_LIBPQ
libpq = -lpq
else
ifdef LIBTOOL
libpq = $(libpq_builddir)/libpq.la
endif
ifdef PGFILEDESC
libpq = -L$(libpq_builddir)/.libs -lpq
endif
endif
# In pkgsrc, libpython is always present as a shared library.
shared_libpython = yes
# $(libpq_builddir)/libpq.a is used in several places as a dependency,
# but if we're building with libtool, then we don't actually want to
# create that file since it will mess up the re-linking process.
# Declare it to be phony to prevent GNU make from thinking it's a
# target.
#
ifdef LIBTOOL
.PHONY: $(libpq_builddir)/libpq.a
endif

View file

@ -1,140 +0,0 @@
#-------------------------------------------------------------------------
#
# Makefile.libtool
# Common rules for buildling libtool archives
#
# IDENTIFICATION
# $NetBSD: Makefile.libtool,v 1.3 2010/12/11 17:15:24 asau Exp $
#
#-------------------------------------------------------------------------
##
## Hacks/workarounds for makefiles in certain directories
##
# The following directories are building loadable shared modules, not
# shared libraries.
#
ifneq (,$(findstring src/backend/replication/libpqwalreceiver,$(subdir)))
shmodule = yes
else
ifneq (,$(findstring src/backend/utils/mb/conversion_procs/,$(subdir)))
shmodule = yes
else
ifneq (,$(findstring src/backend/snowball,$(subdir)))
shmodule = yes
else
ifneq (,$(findstring src/pl/,$(subdir)))
shmodule = yes
else
ifneq (,$(findstring contrib/,$(subdir)))
shmodule = yes
else
shmodule = no
endif
endif
endif
endif
endif
# Fix dependencies in some makefiles that assume the target matches
# %.o so that when built for libtool, the target matches the corresponding
# %.lo.
#
ifeq ($(subdir), src/interfaces/ecpg/ecpglib)
path.lo: path.c $(top_builddir)/src/port/pg_config_paths.h
endif
ifeq ($(subdir), src/interfaces/libpq)
fe-connect.lo: fe-connect.c $(top_builddir)/src/port/pg_config_paths.h
endif
##
## VARIABLE DEFINITIONS
##
# Loadable shared modules are named differently from shared libraries
# and are installed into $(pkglibdir).
#
ifeq ($(shmodule),yes)
ltlib = $(NAME)$(DLSUFFIX)
ltmodule = -module
rpathdir = $(pkglibdir)
else
ltlib = lib$(NAME)$(DLSUFFIX)
ltmodule =
endif
DLSUFFIX = .la
SO_MAJOR_VERSION?=0
SO_MINOR_VERSION?=0
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(CPPFLAGS)
LTLINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(ltmodule) -rpath $(rpathdir) -version-info $(SO_MAJOR_VERSION):$(SO_MINOR_VERSION)
LTOBJS = $(OBJS:%.o=%.lo)
# Define INSTALL_SHLIB and shlib for the benefit of Makefiles for
# loadable modules that have their own target for installing the
# module.
#
INSTALL_LTLIB = $(LIBTOOL) --mode=install $(INSTALL)
INSTALL_STLIB = $(INSTALL_LTLIB)
INSTALL_SHLIB = $(INSTALL_LTLIB)
shlib = $(ltlib)
%.lo : %.c
$(LTCOMPILE) -c $< -o $@
##
## BUILD
##
.PHONY: all-lib all-static-lib all-shared-lib all-la-lib
all-lib all-static-lib all-shared-lib: all-la-lib
all-la-lib: $(ltlib)
$(ltlib): $(LTOBJS)
$(LTLINK) -o $@ $(LTOBJS) $(SHLIB_LINK)
##
## INSTALL
##
.PHONY: install-lib install-lib-static install-lib-shared installdirs-lib install-lib-la
install-lib install-static-lib install-shared-lib: install-lib-la
install-lib-la: $(ltlib)
ifeq ($(shmodule),yes)
$(INSTALL_LTLIB) $< $(DESTDIR)$(pkglibdir)/$(shlib)
else
$(INSTALL_LTLIB) $< $(DESTDIR)$(libdir)/$(ltlib)
endif
installdirs-lib:
ifeq ($(shmodule),yes)
$(MKDIR_P) '$(DESTDIR)$(pkglibdir)'
else
$(MKDIR_P) '$(DESTDIR)$(libdir)'
endif
##
## UNINSTALL
##
.PHONY: uninstall-lib
uninstall-lib:
$(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/$(ltlib)
##
## CLEAN
##
.PHONY: clean-lib
clean-lib:
$(LIBTOOL) --mode=clean rm -f $(ltlib) $(LTOBJS)

View file

@ -1,10 +1,21 @@
# $NetBSD: options.mk,v 1.4 2010/12/19 09:53:27 adam Exp $
# $NetBSD: options.mk,v 1.5 2011/02/09 08:48:17 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.postgresql90
PKG_SUPPORTED_OPTIONS= gssapi kerberos ldap pam xml
PKG_SUPPORTED_OPTIONS= bonjour gssapi kerberos ldap pam xml
.include "../../mk/bsd.options.mk"
###
### Bonjour support.
###
.if !empty(PKG_OPTIONS:Mbonjour)
CONFIGURE_ARGS+= --with-bonjour
. if ${OPSYS} != "Darwin"
LIBS+= -ldns_sd
. endif
. include "../../net/mDNSResponder/buildlink3.mk"
.endif
###
### GSSAPI authentication for the PostgreSQL backend.
###

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ae,v 1.1 2010/12/19 09:53:27 adam Exp $
--- src/makefiles/Makefile.darwin.orig 2010-12-17 18:28:46.000000000 +0000
+++ src/makefiles/Makefile.darwin
@@ -2,11 +2,7 @@ AROPT = crs
DLSUFFIX = .so
-ifdef PGXS
- BE_DLLLIBS = -bundle_loader $(bindir)/postgres
-else
- BE_DLLLIBS = -bundle_loader $(top_builddir)/src/backend/postgres
-endif
+BE_DLLLIBS = -bundle_loader $(bindir)/postgres
# Rule for building a shared library from a single .o file
%.so: %.o

View file

@ -1,13 +0,0 @@
$NetBSD: patch-an,v 1.2 2010/12/19 09:53:27 adam Exp $
--- src/interfaces/ecpg/test/Makefile.regress.orig 2010-12-14 02:55:50.000000000 +0000
+++ src/interfaces/ecpg/test/Makefile.regress
@@ -9,7 +9,7 @@ ECPG = ../../preproc/ecpg --regression -
%: %.c
$(CC) $(CPPFLAGS) $(CFLAGS) -c $< -o $*.o
- $(CC) $(CPPFLAGS) $(CFLAGS) $*.o $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@
+ ${LIBTOOL} --mode=link $(CC) $(CPPFLAGS) $(CFLAGS) $*.o $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@
%.c: %.pgc ../regression.h
$(ECPG) -o $@ -I$(srcdir) $<