Add -print to find(1) when listing files in Makefile rules.
Should fix PR pkg/26930 by Georg Schwarz.
This commit is contained in:
parent
4380814aec
commit
24a3780273
2 changed files with 24 additions and 1 deletions
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.5 2004/03/12 19:54:51 recht Exp $
|
||||
$NetBSD: distinfo,v 1.6 2004/09/12 22:25:08 salo Exp $
|
||||
|
||||
SHA1 (igerman98-20030222.tar.bz2) = 3c453257cab294260fc2157b175a3ab1318c5ade
|
||||
Size (igerman98-20030222.tar.bz2) = 305783 bytes
|
||||
SHA1 (patch-aa) = 8612712b6359f32a8c3bde3ab7ef039f8dc7b385
|
||||
|
|
22
textproc/ispell-german/patches/patch-aa
Normal file
22
textproc/ispell-german/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.3 2004/09/12 22:25:08 salo Exp $
|
||||
|
||||
--- Makefile.orig 2003-02-07 13:40:58.000000000 +0100
|
||||
+++ Makefile 2004-09-12 23:25:27.000000000 +0200
|
||||
@@ -209,14 +209,14 @@
|
||||
|
||||
sort:
|
||||
@if grep [äöüÄÖÜß] dicts/*.txt ;then echo "!!! wrong characters in dictionay files !!!";exit 1;fi
|
||||
- cd dicts; find . -name "*.txt" |while read i; do sort -u -o $$i $$i; done
|
||||
+ cd dicts; find . -name "*.txt" -print |while read i; do sort -u -o $$i $$i; done
|
||||
|
||||
pack: sort
|
||||
rm -f unpack
|
||||
- cd dicts; find . -name "*.txt" |while read i; do $(SQ) < $$i > $$i.sq && rm $$i; done
|
||||
+ cd dicts; find . -name "*.txt" -print |while read i; do $(SQ) < $$i > $$i.sq && rm $$i; done
|
||||
|
||||
unpack:
|
||||
- cd dicts; find . -name "*.sq" |while read i; do $(UNSQ) < $$i > `basename $$i .sq` && rm $$i; done
|
||||
+ cd dicts; find . -name "*.sq" -print |while read i; do $(UNSQ) < $$i > `basename $$i .sq` && rm $$i; done
|
||||
touch unpack
|
||||
|
||||
dist: sort pack clean
|
Loading…
Reference in a new issue