Changes 1.13.1:
- Fix bug in ntfs_attr_pwrite() when we sometimes lose current run in the runlist. - Fix build with --disable-gnome-vfs --enable-fuse-module. - ntfscluster: identify files even if their clusters aren't set in $Bitmap (useful to find potentially corrupted files). - mkntfs: set the physical drive and the extended boot signature to 0x80 in the Extended BPB which are needed to boot from disk. - ntfsinfo: fix two freed memory usages when dumping $SDS and index allocation entries. - libntfs: add ntfs_attr_readall() which reads the entire data from an ntfs attribute. - libntfs: add ntfs_index_root_get() which reads the index root of an attribute. - ntfsclone: the --metadata option will wipe the timestamps in the index allocation attributes as well. This further decreases the compressed metadata image size by 10-25% and more importantly it eliminates non-interesting ntfscmp differences. - ntfscmp: support bad cluster list, compare full attribute headers for non-resident attributes, added manual, build and install by default. - Fix bug with renaming directories with names in DOS and WIN32 namespaces. - ntfsclone: fix 64 bit destination size calculation on Mac OS X
This commit is contained in:
parent
11df16de6a
commit
24b09649fc
6 changed files with 19 additions and 35 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.5 2006/03/04 21:30:42 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2006/07/20 08:22:02 adam Exp $
|
||||
|
||||
DISTNAME= ntfsprogs-1.13.0
|
||||
DISTNAME= ntfsprogs-1.13.1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=linux-ntfs/}
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2006/03/03 10:15:46 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2006/07/20 08:22:02 adam Exp $
|
||||
bin/ntfscat
|
||||
bin/ntfscluster
|
||||
bin/ntfscmp
|
||||
bin/ntfsfix
|
||||
bin/ntfsinfo
|
||||
bin/ntfsls
|
||||
|
@ -44,6 +45,7 @@ man/man8/mkntfs.8
|
|||
man/man8/ntfscat.8
|
||||
man/man8/ntfsclone.8
|
||||
man/man8/ntfscluster.8
|
||||
man/man8/ntfscmp.8
|
||||
man/man8/ntfscp.8
|
||||
man/man8/ntfsfix.8
|
||||
man/man8/ntfsinfo.8
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.9 2006/06/07 23:30:34 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.10 2006/07/20 08:22:02 adam Exp $
|
||||
|
||||
SHA1 (ntfsprogs-1.13.0.tar.gz) = 14dc4c6e47974d1c9d9cd2175557e30819054b41
|
||||
RMD160 (ntfsprogs-1.13.0.tar.gz) = 17f1f185f68ce77c538058dfb05fbfb56985f3eb
|
||||
Size (ntfsprogs-1.13.0.tar.gz) = 860532 bytes
|
||||
SHA1 (patch-aa) = 2acb065ae42bbbdb960ea1e217f775bbcea7081b
|
||||
SHA1 (ntfsprogs-1.13.1.tar.gz) = a4e50f6fc10fcc1e1f562ad64bcbf9a0d46ca72a
|
||||
RMD160 (ntfsprogs-1.13.1.tar.gz) = 4fea1dd03f7c4d2b7cfb05ca101aee902e1ed9d2
|
||||
Size (ntfsprogs-1.13.1.tar.gz) = 870260 bytes
|
||||
SHA1 (patch-ab) = cde641aad8d76e2b7abe14b9634c5d23c459f4a6
|
||||
SHA1 (patch-ac) = e8205fc7e2e3acc18c1289a2d99800507779b89e
|
||||
SHA1 (patch-ae) = 7c3f009489a97673e2f1c7667b7650d1da70cd52
|
||||
SHA1 (patch-af) = b3ea3caaf4b9eaef9f8906508d7aad1f7e470660
|
||||
SHA1 (patch-af) = 582bee0039ca88906dd1883f1cf3c5dc2a7da1d7
|
||||
SHA1 (patch-ah) = b6da89fc9b5bbc83fa503dd887f3f2ec493ad7c7
|
||||
SHA1 (patch-am) = 937c0c34c8b11b6953c12f5012c0d6ea0b946ec6
|
||||
SHA1 (patch-am) = a4382e075c046f3acdeecd12dcfbf99da43771d9
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2006/06/07 23:30:34 joerg Exp $
|
||||
|
||||
--- ntfsprogs/mkntfs.c.orig 2006-06-07 23:06:30.000000000 +0000
|
||||
+++ ntfsprogs/mkntfs.c
|
||||
@@ -3703,9 +3703,12 @@ static BOOL mkntfs_override_vol_params(n
|
||||
"of the device will be used.\n");
|
||||
return FALSE;
|
||||
}
|
||||
+
|
||||
page_size = sysconf(_SC_PAGESIZE);
|
||||
+#if !defined(__DragonFly__)
|
||||
if (page_size < 0)
|
||||
page_size = sysconf(_SC_PAGE_SIZE);
|
||||
+#endif
|
||||
if (page_size >= 0)
|
||||
ntfs_log_debug("System page size is %li bytes.\n", page_size);
|
||||
else {
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-af,v 1.5 2006/03/03 10:15:46 adam Exp $
|
||||
$NetBSD: patch-af,v 1.6 2006/07/20 08:22:02 adam Exp $
|
||||
|
||||
--- ntfsprogs/ntfsclone.c.orig 2006-02-08 22:46:40.000000000 +0100
|
||||
--- ntfsprogs/ntfsclone.c.orig 2006-06-21 09:59:19.000000000 +0200
|
||||
+++ ntfsprogs/ntfsclone.c
|
||||
@@ -55,6 +55,19 @@
|
||||
#include <getopt.h>
|
||||
|
@ -22,7 +22,7 @@ $NetBSD: patch-af,v 1.5 2006/03/03 10:15:46 adam Exp $
|
|||
#include "debug.h"
|
||||
#include "types.h"
|
||||
#include "support.h"
|
||||
@@ -108,7 +121,11 @@ struct {
|
||||
@@ -110,7 +123,11 @@ struct {
|
||||
int restore_image;
|
||||
char *output;
|
||||
char *volume;
|
||||
|
@ -34,7 +34,7 @@ $NetBSD: patch-af,v 1.5 2006/03/03 10:15:46 adam Exp $
|
|||
} opt;
|
||||
|
||||
struct bitmap {
|
||||
@@ -559,7 +576,7 @@ static void copy_cluster(int rescue, u64
|
||||
@@ -561,7 +578,7 @@ static void copy_cluster(int rescue, u64
|
||||
if (write_all(&fd_out, buff, csize) == -1) {
|
||||
int err = errno;
|
||||
perr_printf("Write failed");
|
||||
|
@ -43,7 +43,7 @@ $NetBSD: patch-af,v 1.5 2006/03/03 10:15:46 adam Exp $
|
|||
Printf("Apparently you tried to clone to a remote "
|
||||
"Windows computer but they don't\nhave "
|
||||
"efficient sparse file handling by default. "
|
||||
@@ -1322,7 +1339,7 @@ static void set_filesize(s64 filesize)
|
||||
@@ -1426,7 +1443,7 @@ static void set_filesize(s64 filesize)
|
||||
Printf("WARNING: Couldn't get filesystem type: "
|
||||
"%s\n", strerror(errno));
|
||||
else
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-am,v 1.2 2006/03/03 10:15:46 adam Exp $
|
||||
$NetBSD: patch-am,v 1.3 2006/07/20 08:22:02 adam Exp $
|
||||
|
||||
--- ntfsprogs/Makefile.in.orig 2006-02-27 10:12:13.000000000 +0100
|
||||
--- ntfsprogs/Makefile.in.orig 2006-06-21 10:41:46.000000000 +0200
|
||||
+++ ntfsprogs/Makefile.in
|
||||
@@ -848,7 +848,6 @@ install-data-am: install-man
|
||||
@@ -851,7 +851,6 @@ install-data-am: install-man
|
||||
|
||||
install-exec-am: install-binPROGRAMS install-sbinPROGRAMS
|
||||
@$(NORMAL_INSTALL)
|
||||
|
|
Loading…
Reference in a new issue