Rather than a direct assignation to the signal mask, use sigemptyset(3),

from Roland Illig by email. "Needed for Linux 2.4.22"
This commit is contained in:
agc 2004-02-08 23:37:13 +00:00
parent 0c0d532f27
commit 24b206be47
2 changed files with 14 additions and 5 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.3 2004/02/08 12:58:55 grant Exp $
$NetBSD: distinfo,v 1.4 2004/02/08 23:37:13 agc Exp $
SHA1 (crashme-2.4-shar) = 0648322959634f21e61a5d5e1b308e3c89dc2841
Size (crashme-2.4-shar) = 57010 bytes
SHA1 (patch-aa) = 01f981d1ac274bf00ba8d5f9ddcad8aeeaf3dffb
SHA1 (patch-ab) = 4c7bdcbaae5c802ee27142b3a41638151dff3638
SHA1 (patch-ab) = 2dc1213fe4621b947a9ce8d589925a9bd83653e0

View file

@ -1,7 +1,16 @@
$NetBSD: patch-ab,v 1.1 1999/06/27 01:41:46 abs Exp $
$NetBSD: patch-ab,v 1.2 2004/02/08 23:37:13 agc Exp $
--- crashme.c.orig Sat Jun 26 18:35:17 1999
+++ crashme.c Sat Jun 26 18:36:01 1999
--- crashme.c 2004/02/08 23:29:34 1.1
+++ crashme.c 2004/02/08 23:31:28
@@ -260,7 +260,7 @@
#else
struct sigaction act;
act.sa_handler = func;
- act.sa_mask = 0;
+ sigemptyset(&act.sa_mask);
#ifdef linux
act.sa_restorer = 0;
#endif /* linux */
@@ -591,7 +591,7 @@
status = fork();
#endif