Update to 2.1.14:

2.1.14

2007-08-14

* Integrated authreg_oracle by fundy.
* Operands incompatibility fix for Sun compiler.
* contrib/cyrus-sasl-digest-md5-fix added
* Applied MIO memleak fix related to time_checks by Christof Meerwald.

2.1.13

2007-08-08

* Reverted broken [311] and [313] changes to source:trunk/mio/mio_impl.h
* compilation fix
* Fix configuration XML files domain update
* Don't allow reinstalling on newer version
* Fixed off-by-one error in base64
* Force uninstall previous version on upgrade.

2.1.12

2007-07-30

* Fixed many memleaks
* Check if OpenSSL is already initialized in PostgreSQL backend.
* Implemented PQconnectdb PostgreSQL connection method.
* Applied pg_config using by configure patch by Michael Krelin.
* Implemented auth/reg stream features advertisement.
* Removed useless while/alloc loops
* WiX notes for Windows README
* WiX new "JabberWelcomeDlg?"
* WiX fixed cases of reinstall & upgrade
* nad_cache_new & nad_cache_free exported as JABBERD2_API functions.
* Changed allocator BLOCKSIZE to 128 bytes

2.1.11

2007-07-27

* Changed SASL level error reporting to malformed-request error according
  to rfc3920bis.
* Fixed ./configure tests reliability.
* Changed DOS line endings to UNIX line endings.
* Fixed XML predefined entities quoting in serialized XML.

2.1.10

2007-07-20

* Removed SASL backend fallbacks
* Added roster items limit option. Closes #89
* Added count support in SQLite3 backend

2.1.9

2007-07-19

* Added jabberoob redirection support during in-band registration
* Logging JID on disconnection
* Added counting packets on c2s and s2s connections
* Added TLS indicator for c2s and s2s logs.
* Added type='log' to ComponentProtocol <route/> wrapper for logged packets.
This commit is contained in:
xtraeme 2007-08-26 09:10:54 +00:00
parent 457dc30100
commit 24b85346dd
4 changed files with 39 additions and 46 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.40 2007/08/01 21:45:30 joerg Exp $
# $NetBSD: Makefile,v 1.41 2007/08/26 09:10:54 xtraeme Exp $
#
DISTNAME= jabberd-2.1.8
PKGREVISION= 1
DISTNAME= jabberd-2.1.14
#PKGREVISION= 1
CATEGORIES= chat
MASTER_SITES= http://ftp.xiaoka.com/jabberd2/releases/
EXTRACT_SUFX= .tar.bz2
@ -40,7 +40,7 @@ REPLACE_PERL+= tools/*.pl
JABBERD_DBDIR?= ${VARBASE}/db/jabberd
BUILD_DEFS+= VARBASE
BUILD_DEFS+= VARBASE JABBERD_USER JABBERD_GROUP
BUILD_DEFS+= JABBERD_LOGDIR JABBERD_PIDDIR JABBERD_DBDIR
PKG_SYSCONFSUBDIR= jabberd
@ -79,13 +79,13 @@ OWN_DIRS_PERMS+= ${f} ${JABBERD_USER} ${JABBERD_GROUP} 770
post-extract:
.for f in ${FILES}
${MV} ${WRKSRC}/etc/${f}.dist.in ${WRKSRC}/etc/${f}.in
mv ${WRKSRC}/etc/${f}.dist.in ${WRKSRC}/etc/${f}.in
.endfor
${MV} ${WRKSRC}/etc/jabberd.cfg.dist.in ${WRKSRC}/etc/jabberd.cfg.in
mv ${WRKSRC}/etc/jabberd.cfg.dist.in ${WRKSRC}/etc/jabberd.cfg.in
pre-configure:
.for f in ${FILES} jabberd.cfg
${SED} \
sed \
-e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g" \
-e "s|@PIDDIR@|${JABBERD_PIDDIR}|g" \
-e "s|@LOGDIR@|${JABBERD_LOGDIR}|g" \

View file

@ -1,13 +1,13 @@
$NetBSD: distinfo,v 1.12 2007/07/13 09:43:36 xtraeme Exp $
$NetBSD: distinfo,v 1.13 2007/08/26 09:10:54 xtraeme Exp $
SHA1 (jabberd-2.1.8.tar.bz2) = 9d405239a0e54719f33643dcac73d84212c79258
RMD160 (jabberd-2.1.8.tar.bz2) = ad91437263ecab6da2319312357784be45b97433
Size (jabberd-2.1.8.tar.bz2) = 1035763 bytes
SHA1 (jabberd-2.1.14.tar.bz2) = dd12ed8956ffc0118e6bfd0424d788d4bd1c128c
RMD160 (jabberd-2.1.14.tar.bz2) = 3a6f1c2104ce0d88c4535139fd705e06da564863
Size (jabberd-2.1.14.tar.bz2) = 1046630 bytes
SHA1 (patch-aa) = bd62fd5956cb6722f7cb4b5bdca05ee502f43e46
SHA1 (patch-ab) = de1c8ec12b55117223bcca2071499c42ab145a34
SHA1 (patch-ac) = 6750c724910a7be4b19488af02d57784ff06af3d
SHA1 (patch-ad) = 3a4b9f80912c70fb1cdc7756b6d4dcc12feadb5a
SHA1 (patch-ae) = 56cb29f139c9f6e74afd9bb0361d70fe4fad0c47
SHA1 (patch-af) = 83b16643caae2a0c5ca396793f0a80c0bb5d83e7
SHA1 (patch-ag) = e4dc021acbc40dd9bc6206014fe12ee4aedefdc7
SHA1 (patch-ag) = 34965f9b001fbf66bca500f115c60f0450ce92ab
SHA1 (patch-ah) = f896a30c9ee44bb0bd19a9c848a455e94eefcdb4

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.17 2007/07/13 09:43:36 xtraeme Exp $
# $NetBSD: options.mk,v 1.18 2007/08/26 09:10:54 xtraeme Exp $
#
PKG_OPTIONS_VAR= PKG_OPTIONS.jabberd2
@ -69,12 +69,12 @@ CONFIGURE_ARGS+= --disable-ldap
.endif
.if !empty(PKG_OPTIONS:Mcyrus-sasl)
CONFIGURE_ARGS+= --with-sasl=cyrus
CONFIGURE_ARGS+= --enable-sasl=cyrus
. include "../../security/cyrus-sasl/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mgnusasl)
CONFIGURE_ARGS+= --with-sasl=gsasl
CONFIGURE_ARGS+= --enable-sasl=gsasl
. include "../../security/gsasl/buildlink3.mk"
.endif

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ag,v 1.4 2007/05/26 11:50:13 xtraeme Exp $
$NetBSD: patch-ag,v 1.5 2007/08/26 09:10:54 xtraeme Exp $
--- etc/c2s.xml.in.orig 2007-05-26 12:07:39.000000000 +0200
+++ etc/c2s.xml.in 2007-05-26 12:09:13.000000000 +0200
--- etc/c2s.xml.in.orig 2007-08-26 10:52:06.000000000 +0200
+++ etc/c2s.xml.in 2007-08-26 10:53:53.000000000 +0200
@@ -6,7 +6,7 @@
<!-- The process ID file. comment this out if you don't need to know
to know the process ID from outside the process (eg for control
scripts) -->
- <pidfile>@localstatedir@/jabberd/pid/c2s.pid</pidfile>
+ <pidfile>@PIDDIR@/c2s.pid</pidfile>
+ <pidfile>@PIDDIR@/c2s.pid</pidfile>
<!-- Router connection configuration -->
<router>
@ -29,16 +29,7 @@ $NetBSD: patch-ag,v 1.4 2007/05/26 11:50:13 xtraeme Exp $
-->
</log>
@@ -109,7 +109,7 @@
<id register-enable='true'>localhost</id>
<!-- or
<id realm='company'
- pemfile='/usr/local/etc/jabberd/server.pem'
+ pemfile='@SSLCERTS@/server.pem'
verify-mode='7'
require-starttls='true'
register-enable='true'
@@ -142,7 +142,7 @@
@@ -147,7 +147,7 @@
If this is commented out, clients will not be offered
the STARTTLS stream extension -->
<!--
@ -47,23 +38,7 @@ $NetBSD: patch-ag,v 1.4 2007/05/26 11:50:13 xtraeme Exp $
-->
<!-- SSL verify mode - see SSL_CTX_set_verify(3), mode parameter -->
@@ -339,7 +339,7 @@
<!-- Berkeley DB module configuration -->
<db>
<!-- Directory to store database files under -->
- <path>@localstatedir@/jabberd/db</path>
+ <path>@DBDIR@</path>
<!-- Synchronize the database to disk after each write. If you
disable this, database accesses may be faster, but data may
@@ -403,13 +403,13 @@
<!-- Pipe module configuration -->
<pipe>
<!-- Program to execute -->
- <exec>@bindir@/pipe-auth.pl</exec>
+ <exec>@BINDIR@/pipe-auth.pl</exec>
</pipe>
@@ -362,7 +362,7 @@
<!-- SQLite driver configuration -->
<sqlite>
<!-- Database name -->
@ -72,3 +47,21 @@ $NetBSD: patch-ag,v 1.4 2007/05/26 11:50:13 xtraeme Exp $
<!-- Transacation support. If this is commented out, transactions
will be disabled. This might make database accesses faster,
@@ -376,7 +376,7 @@
<!-- Berkeley DB module configuration -->
<db>
<!-- Directory to store database files under -->
- <path>@localstatedir@/jabberd/db</path>
+ <path>@DBDIR@</path>
<!-- Synchronize the database to disk after each write. If you
disable this, database accesses may be faster, but data may
@@ -440,7 +440,7 @@
<!-- Pipe module configuration -->
<pipe>
<!-- Program to execute -->
- <exec>@bindir@/pipe-auth.pl</exec>
+ <exec>@BINDIR@/pipe-auth.pl</exec>
</pipe>
</authreg>